InfoSnippet: nach Update->1.0.6 kein Frontend, kein Backend!

Hallo allerseits, wir benutzen das Plugin „InfoSnippet“ von BlueWolf-Produktion. Nach dem Update von 1.0.4 auf 1.0.6 ist weder Frontend noch Backend erreichbar. Es gib eine Fehlermeldung beim Aufruf des Frontends „Synatx error, unexpected „[“ in …bootstrap.php on line 43“. Wir können nur den alten Zustand wiederherstellen, indem wir die Version 1.0.4 per ftp wieder hochladen und die 1.0.6 überschreiben. Alle anderen Plugins und Updates funktionieren gut. Der Entwickler von InfoSnippet kennt diese Fehlermeldung nur von uns. Wer von euch hat ein ähnliches Problem damit und vielleicht sogar ein Lösung gefunden? Beste Grüße Rudolf@herz-und-geist.de Tantra Online-Shop

Das Fehlverhalten konnte in keinem anderen Shop nachgestellt werden. Folgende Zeilen in der Bootstrap führen zu der Fehlermeldung: [quote] public function enable() { return [‚success‘ => true, ‚invalidateCache‘ => [‚template‘, ‚theme‘] ]; } [/quote] Diese Funktion ist auch in anderen Plugins und funktioniert. EDIT: Der Code ist wohl nur PHP 5.4 tauglich… Ich stelle das nochmal auf PHP 5.3 um.

1 Like

Hat alles geklappt mit php 5.4 Und nach Ihrer Anpassung auch mit dem alten php 5.3 Danke, Herr Wolf.