HILFE! Keine Registrierung und Bestellung möglich!

Hallo Leute, wochenlang funktionierte meine 4.3 Version wie am Schnürchen. Schön flott und schnell. Ohne das jedoch etwas gemacht wurde, außer Artikelneuanlagen, streikt dieser heute mit nachfolgender Fehlermeldung. Ich bitte um dringende Hilfe: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. An exception occurred while executing ‚SELECT s0_.id AS id0, s0_.userID AS userID1, s0_.mopt_payone_consumerscore_result AS mopt_payone_consumerscore_result2, s0_.mopt_payone_consumerscore_date AS mopt_payone_consumerscore_date3, s0_.mopt_payone_consumerscore_color AS mopt_payone_consumerscore_color4, s0_.mopt_payone_consumerscore_value AS mopt_payone_consumerscore_value5, s0_.swp_pol_may_precheck AS swp_pol_may_precheck6, s0_.sofag_ideal_bank AS sofag_ideal_bank7, s0_.sofort_ideal_bank AS sofort_ideal_bank8 FROM s_user_attributes s0_ WHERE s0_.userID = ? LIMIT 1 OFFSET 0‘ with params [„3“]: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚s0_.sofag_ideal_bank‘ in ‚field list‘ in vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php on line 91 Stack trace: #0 vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(701): Doctrine\DBAL\DBALException::driverExceptionDuringQuery(Object(PDOException), ‚SELECT s0_.id A…‘, Array) #1 vendor/doctrine/orm/lib/Doctrine/ORM/Query/Exec/SingleSelectExecutor.php(50): Doctrine\DBAL\Connection->executeQuery(‚SELECT s0_.id A…‘, Array, Array, NULL) #2 vendor/doctrine/orm/lib/Doctrine/ORM/Query.php(286): Doctrine\ORM\Query\Exec\SingleSelectExecutor->execute(Object(Doctrine\DBAL\Connection), Array, Array) #3 vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(794): Doctrine\ORM\Query->_doExecute() #4 vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(612): Doctrine\ORM\AbstractQuery->execute(NULL, 2) #5 engine/core/class/sAdmin.php(2729): Doctrine\ORM\AbstractQuery->getOneOrNullResult(2) #6 engine/core/class/sAdmin.php(4556): sAdmin->getUserAttributes(‚3‘) #7 engine/core/class/sAdmin.php(2647): sAdmin->getUserCountryData(Array, ‚3‘) #8 Shopware/Controllers/Frontend/Checkout.php(483): sAdmin->sGetUserData() #9 Shopware/Controllers/Frontend/Checkout.php(73): Shopware_Controllers_Frontend_Checkout->getUserData() #10 Enlight/Controller/Action.php(150): Shopware_Controllers_Frontend_Checkout->preDispatch() #11 Enlight/Controller/Dispatcher/Default.php(528): Enlight_Controller_Action->dispatch(‚confirmAction‘) #12 Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #13 Shopware/Kernel.php(141): Enlight_Controller_Front->dispatch() #14 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(472): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #15 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #16 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(243): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #17 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(260): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #18 Shopware/Components/HttpCache/AppCache.php(132): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #19 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(189): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #20 Shopware/Components/HttpCache/AppCache.php(113): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #21 shopware.php(109): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #22 {main} Es wurden keine Updates von Plugins durchgeführt o.ä. Es lief mit allen Plugins reibungslos und fon jetzt auf gleich nichts mehr :-(:wtf::wtf: Gruß Pit

Hi, die Fehlermeldung besagt, dass von der User-Attribut-Tabelle ein Feld namens sofag_ideal_bank gelesen werden soll - das es aber nicht gibt. Zur Ursache kann ich wenig sagen - aber vll. kannst du das Plugin, das mit “sofa_ideal_bank” in Verbindung steht einmal neu installieren oder den gesamten Cache über das Performance-Modul leeren (wenn noch nicht geschehen), vll. werden dann die entsprechenden Attribute schon korrekt neu generiert. So oder so aber eben ein Backup anfertigen, ich kenne dein System nicht und kann letztlich auch nur Vermutungen anstellen. lG Daniel

1 Like

Danke Daniel, eine Neuinstallation des Sofort AG Moduls hat geholfen. Das erklärt jedoch nicht das Problem. Es ist eine saubere Neuinstallation des Shops gewesen um diesen dann nur noch mit Artikeln zu füllen. Alles blieb im Original und wiederholt hat das Ding ein Eigenleben welches sich nicht nachvollziehen lässt, Einen Support gibt es ja nur für Kunden ab der Prof. Version. Sehe ich aber nicht ein solange das Ding immer wieder dubiose Fehler ohne Auslöser hat. Würde gern mit allen vier Shops zu Shopware wechseln aber nachdem was ich bislang erlebt habe bleiben die anderen drei besser bei Oxid :frowning: Für das Problem mit dem anderen Shopware Shop gibt es ja auch noch keine Lösung. Trotzdem ersteinmal vielen Dank Gruß Pit

Hi, > Sehe ich aber nicht ein solange das Ding immer wieder dubiose Fehler ohne Auslöser hat. So schlimm scheint es ja nicht zu sein: > wochenlang funktionierte meine 4.3 Version wie am Schnürchen. Schön flott und schnell. Letztlich kannst du das halten wie du möchtest, aus meiner Sicht ist es gerade eher so, dass du schnell, kompetent und kostenlos Hilfe bekommen hast - mir persönlich hätte ein einfaches Danke ohne „aber“ „ersteinmal“(?) gereicht :). lG Daniel