[GELÖST] Formatiereung, Bilder und Text

Hallo, wen ich unter PDF Belegerstellung was änderen möchte, wird die Formatierung für Texte, Tabellen und Bilder nicht übernommen. Beispiel: Unter Rechnung wähle ich Footer aus und wenn ich die Tabelle ändere, neue Tabelle erstelle oder aus Word einfüge, sieht auf den ersten Blick alles gut aus. Nur, sobald ich Footer speichere, ist die ganze Formatierung weg. Einfacher Text wird nicht übernommen, nur bold Text wird nach dem speichern übernommen. Bilder z.B. werden gar nicht angezeigt nach dem speichern. Bild einfügen klappt nur nach dem speichern wird der Link geändert: \"http://xxxxxxxxx.de/store/rechnung.jpg\" Das verlinkte Bild kann ich im Browser abrufen und habe auch Shop Cache geleert. Habe noch paar Screens angehängt das ihr sieht wie sich der HTML Code jedes mal nach dem speichern ändert.

Danke schon mal für eure Hilfe

Hier: templates-und-design-f14/gelost-content-bearbeiten-unterschiedliches-verhalten-bei-2-t4898.html#p26205

1 Like

Hmmm, liegt es an Magic Quotes Einstellungen? Das hat der Provider schon abgeschaltet und hier ist der Inhalt aus der .htaccess Datei. [code]
RewriteEngine on

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews # php_value memory_limit 128M # php_value max_execution_time 18000 # php_flag magic_quotes_gpc off # php_flag session.auto_start off # php_flag suhosin.session.cryptua off # php_flag zend.ze1_compatibility_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php[/code]

[quote=“blond”]Hmmm, liegt es an Magic Quotes Einstellungen? Das hat der Provider schon abgeschaltet und hier ist der Inhalt aus der .htaccess Datei. [code]
RewriteEngine on

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews # php_value memory_limit 128M # php_value max_execution_time 18000 # php_flag magic_quotes_gpc off # php_flag session.auto_start off # php_flag suhosin.session.cryptua off # php_flag zend.ze1_compatibility_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php[/code][/quote] entferne mal das “#” am Anfang von: # php\_flag magic\_quotes\_gpc off

1 Like

Ohje, manchmal übersehe ich das offensichtliche :slight_smile: Danke für die schnelle Hilfe