gelöst // domainFactory - Installation

guten tag, ich sitze seit ein paar stunden an der installation und so langsam komme ich der sache näher (hoffe ich) ich versuche mal die ereignisse/fehlermeldungen der reihe nach zu beschreiben: - daten auf den server geladen - http://www.meinedomain.de/engine aufgerufen - „Fatal Error …“-Message bekommen (kann sie nicht besser beschreiben) - hab dann ein bisschen im netz gelesen und auch eine lösung gefunden: dort stand, man solle in der config.php und in der application.php ein paar zeilen anpassen/ändern (finde gerade leider den link nicht wieder) - dieses problem war gelöst -dann ging es aber direkt mit einem 404 weiter -wieder im netz gelesen: es soll wohl an der .htacces liegen -.htacces vom server geöffnet: kein inhalt -hab dann einfach mal aus diesem thema (installation-einstieg-f9/backend-wird-nicht-aufgerufen-installation-auf-domainfactory-t564.html) den code kopiert und eingefügt -meine .htacces sieht jetzt folgendermaßen aus: ErrorDocument 500 /errordocs/500.html ErrorDocument 404 /errordocs/404.html ErrorDocument 403 /errordocs/403.html ErrorDocument 401 /errordocs/401.html RewriteEngine on RewriteBase / RewriteRule shopware.dll shopware.php RewriteRule files/documents/.\* engine [NC,L] RewriteRule application.yaml engine [NC,L] RewriteRule images/ayww/(.\*) images/banner/$1 RewriteRule sitemap.xml(.\*) shopware.php?controller=SitemapXml RewriteRule templates/.\*(css|js)$ engine/backend/php/sCacheTemplate.php?file=$0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php$ engine/backend/php/sAjaxSearch.php [NC,L] RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L] RewriteCond %{REQUEST\_URI} !(engine\/|images\/|files\/|templates\/|\.js$|\.css$|\.jpg$|\.png$) RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d RewriteRule ^(.\*)$ shopware.php [PT,L,QSA] DirectoryIndex index.php DirectoryIndex shopware.php<files> Deny from all </files>Options -Indexes # Options -MultiViews # php\_value memory\_limit 128M # php\_value max\_execution\_time 18000 php\_flag magic\_quotes\_gpc off # php\_flag session.auto\_start off # php\_flag suhosin.session.cryptua off # php\_flag zend.ze1\_compatibility\_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php Wenn ich jetzt „meinedomain.de/engine“ aufrufe, bekomme ich folgende meldung: „Fehler 500 Scriptfehler Sehr geehrter Besucher, leider ist ein Problem aufgetreten. Die angeforderte Seite hat einen Script-Fehler verursacht. Haben Sie sich vielleicht vertippt oder eine alte URL aufgerufen? Wenn nicht, informieren Sie bitte den Webmaster dieser Homepage per Email. Um zu der vorherigen Seite zurückzukehren, verwenden Sie bitte einfach die „Zurück“ - Taste Ihres Browsers.“ weiß nicht weiter und finde auch keine infos im netz (vllt. fehlen mir auch die richtigen suchbegriffe). würde mich über ein paar tips sehr freuen! grüße

Hi, ich hoffe, Du guckst noch einmal hier rein, denn ich habe genau die gleiche Fehler-Historie wie Du und laut dem „gelöst“-Tag hast Du es ja irgendwann anscheinend geschafft. Magst Du mir noch kurz verraten, welche Anpassungen noch fehlten oder woran es sonst lag? Alle anderen, die mir helfen können dürfen sich natürlich auch gerne melden :wink: Danke schonmal

Hi, also das hier als minimal - .htaccess muss gehen: [code]
RewriteEngine on

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes [/code] Lass mal oben die Fehlerseiten weg (oder auskommentieren), habe ich auch nicht drin. …magic_quotes_gpc off machst du eigentlich in der php.ini… Warum hier das steht weiss ich nicht: [quote]- http://www.meinedomain.de/engine aufgerufen[/quote] …einfach Deine http://www.DeineDomain.de im Browser eintragen und Seite laden. PS: den Punkt vor .htaccess nicht vergessen :wink: Grüße rattatui

hey rattatui, ich hatte tatsächlich aus versehen ein rewriterule zuviel gelöscht, daher der server error. in meiner .htaccess stehen die fehlerseiten nicht drin, die rewritebase leitet auf das unterverzeichnis weiter, in dem der shop installiert ist und die magic_quotes hab ich in der php.ini ausgeschaltet. und trotzdem krieg ich immer noch nen fehler (immerhin, jetzt kein 500er, dafür ein 404er). was meinst du mit “einfach die domain laden und das engine weglassen”? ich möchte doch schließlich endlich mal ins backend kommen, und das wiederum kann ich ja über die engine aufrufen. so langsam verzweifle ich an dem ganzen projekt und dabei ists bestimmt nur ne kleinigkeit, wetten? :slight_smile: edit: den punkt vor htaccess hab ich auch nicht vergessen :wink:

Hi, [quote]was meinst du mit „einfach die domain laden und das engine weglassen“? ich möchte doch schließlich endlich mal ins backend kommen,[/quote] Der Aufruf für das Backend ist: http://www.DeineDomain.de/backend/auth oder auch nur http://www.DeineDomain.de/backend

1 Like

hey rattatui, danke für deine hilfe. warum steht eigentlich im wiki, dass man das backend über den ordner engine aufrufen soll? wie dem auch sei, ich habe letztendlich den installationsort für meinen testshop geändert von einem komplett eigenen unterordner auf meinem server bei df auf einen unterordner im ordner webseiten. mit deinem hinweis zum aufrufen des backend über “backend” hat es dann auch geklappt. vielleicht hilft es ja dem nächsten, der sich daran noch die zähne ausbeißt :smiley: nun ja, dann werd ich mal richtig loslegen, die nächsten stolpersteine warten schließlich :smiley: vielen dank nochmal!

Früher war es mal /engine :wink: heute funktioniert es auch noch aber /Backend ist die Vorzugsvariante