Backend wird nicht aufgerufen Installation auf Domainfactory

Servus, Installation auf Managed Server von Domainfactory ist erfolgreich durchgelaufen, ich werde auf folgende Seite weitergeleitet wenn ich auf „Backend aufrufen“ klicke… http://muster.domainfactory-kunde.de/shopware/backend/auth wo ich einen[color=red] Fehler 404[/color] erhalte das die Seite nicht gefunden werden konnte. Dei Shopsoftware habe ich ganz normal installiert, also kein Unterordner oder so… Meine .htaccess Datei sieht wie folgt aus: RewriteEngine on RewriteBase / RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule application.yaml engine [NC,L] RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.\*) shopware.php?controller=SitemapXml RewriteRule templates/.\*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L] RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L] RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews # php_value memory_limit 128M # php_value max_execution_time 18000 # php_flag magic_quotes_gpc off # php_flag session.auto_start off # php_flag suhosin.session.cryptua off # php_flag zend.ze1_compatibility_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php
Kann mir jemand weiterhelfen ?

Hallo, das selbe Problem habe ich auch bei der Installtion bei Domainfactory: Beim ersten Aufruf des Backends tritt ein Fehler 404 auf. Ich muss dazu auch sagen, dass ich bis jetzt nur das Paket MyHome zu Testzwecken benutze - das weniger Performance bietet, aber für Testzwecke hoffentlich ausreicht. Ich hänge mal einen Screenshot der check.php an. Fehler treten demnach nur bei mod_rewrite und magic_quotes auf. Wie kann ich das ändern und wirkt sich dies überhaupt auf die Installation aus? Mod_rewrite sollte aber eigentlich funktionieren… Der leicht zu wenige memory_limit wird wohl zu Testzwecken keine Probleme bereiten, oder?

Hallo, wenn die Umleitung, also mod_rewrite, nicht funktioniert, liegt es mit 100%iger Wahrscheinlichkeit an der htaccess-Datei. Zu das und DF findet ihr auch etwas in der Anleitung: http://www.shopware.de/wiki/Installatio … ainFACTORY Bei euch muss also diese Zeile: [quote]RewriteBase /[/quote] angepasst werden. Bei Balu wäre das Ergebniss also so: [quote]RewriteBase /shopware/[/quote] und bei eWort müssete es also so aussehen: [quote]RewriteBase /shop/[/quote] edit: Der Punkt „mod_rewrite“ dürfte damit dann abgeschlossen sein. Nur der Punkt „magic_quotes“ ist noch wichtig. Wenn das nicht angepasst wird, können u.a. keine Artikel angelegt werden. Das sollte aber leicht zu lösen sein, indem man in der htaccess-Datei in dieser Zeile: [quote]# php_flag magic_quotes_gpc off[/quote] das Route-Zeichen entfernt. Der Punkt „memory_limit“ wird nur für die Belege benötigt. Viele Grüße Heiner

1 Like

DANKE ! Bei mir klappt es jetzt wunderbar kann alles Auffrugen supi … dann kann es ja endlich weiter gehen mit dem testen… :slight_smile: