Frontend will nicht

Hallo, ich bekomme es leider nicht gebacken, das frontend zum laufen zu kriegen. das backend funktioniert wunderbar. vielleicht kann mir jemand helfen :slight_smile: Fehlerausgabe: end\_Session::start() - /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Loader.php(Line:57): Error #2 include() [function.include]: open\_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/vhosts/s369189542.online.de/httpdocs/:/tmp/) Array in Enlight/Zend/Session.php on line 503 Stack trace: #0 Shopware/Bootstrap.php(118): Zend\_Session::start(Array) #1 [internal function]: Shopware\_Bootstrap-\>initSession() #2 Enlight/Bootstrap.php(99): call\_user\_func(Array) #3 Enlight/Bootstrap.php(69): Enlight\_Bootstrap-\>loadResource('Session') #4 Shopware/Shopware.php(69): Enlight\_Bootstrap-\>getResource('Session') #5 Shopware/Plugins/Default/Core/Shop/Bootstrap.php(0): Shopware-\>Session() #6 [internal function]: Shopware\_Plugins\_Core\_Shop\_Bootstrap::onInitResourceShop() #7 Enlight/Event/EventHandler.php(60): call\_user\_func(Object(Enlight\_Event\_EventArgs)) #8 Enlight/Event/EventManager.php(96): Enlight\_Event\_EventHandler-\>execute('Shopware\_Plugin...', Object(Enlight\_Event\_EventArgs)) #9 Enlight/Bootstrap.php(96): Enlight\_Event\_EventManager-\>notifyUntil(Object(Enlight\_Event\_EventArgs)) #10 Enlight/Bootstrap.php(57): Enlight\_Bootstrap-\>loadResource('Enlight\_Bootstr...', Array) #11 Enlight/Application.php(289): Enlight\_Bootstrap-\>hasResource('Shop') #12 Shopware/Plugins/Default/Core/Shop/Bootstrap.php(0): Enlight\_Application-\>\_\_call('Shop') #13 [internal function]: Shopware\_Plugins\_Core\_Shop\_Bootstrap::onPreDispatch('Shop', Array) #14 Enlight/Event/EventHandler.php(60): call\_user\_func() #15 Enlight/Event/EventManager.php(70): Enlight\_Event\_EventHandler-\>execute(Object(Enlight\_Event\_EventArgs)) #16 Enlight/Controller/Front.php(75): Enlight\_Event\_EventManager-\>notify('Shopware\_Plugin...', Object(Enlight\_Event\_EventArgs)) #17 Shopware/Bootstrap.php(21): Enlight\_Controller\_Front-\>dispatch(Object(Enlight\_Event\_EventArgs)) #18 Enlight/Application.php(69): Shopware\_Bootstrap-\>run('Enlight\_Control...', Array) #19 shopware.php(6): Enlight\_Application-\>run() #20 {main} oder live unter: http://s369189542.online.de Der Server sieht wie folgt aus: 1und1 virtual host xxl bs: centos 5 php ver: 5.2.17 zend optimizer: 3.3.9 ioncube loader: 4.0.8 beim installer skript sehe ich nur grüne haken, bis auf zip bei sonstige. ich hoffe dass ihr mir helfen könnt. lg

Hast du ganz sicher überall die richten Schreibrechte? Hast du mal im backend unter Einstellungen/Systeminfo geschaut, ob da alles passt? Grüße Frank

ja alles grün bis auf: engine/vendor/html2ps/cache/ not found Wird für Neu-Installationen 3.5 nicht benötigt engine/vendor/html2ps/temp/ not found Wird für Neu-Installationen 3.5 nicht benötigt

Das Problem ist wohl, dass das Verzeichnis auf das der Session-Save-Path von PHP konfiguriert ist, keine Schreibrechte besitzt. Probiere mal in einer leeren PHP-Datei

hi stefan, danke für deinen tipp aber scheint nicht der fehler zu sein. session.save_path = “/var/lib/php/session” scheint beschreibbar zu sein. es existieren auch sessions in dem dir. dein php code produziert auch keine fehler: http://s369189542.online.de/test.php

Wie sieht denn deine Application.php aus? (Liegt im Shopware-Root-Verzeichnis) - ist die komplett Standard? Kannst du die mal posten?

ja die ist standart: [code]<?php include(dirname( FILE ).DIRECTORY_SEPARATOR.‘config.php’);

return array(
‘db’ => array( ‘username’ => $DB_USER, ‘password’ => $DB_PASSWORD, ‘dbname’ => $DB_DATABASE, ‘host’ => $DB_HOST ), ‘front’ => array( ‘noErrorHandler’ => false, ‘throwExceptions’ => false, ‘useDefaultControllerAlways’ => true, ‘disableOutputBuffering’ => false, ‘showException’ => true, ), ‘template’ => array( ‘compileCheck’ => true, ‘compileLocking’ => true, ‘useSubDirs’ => false, ‘forceCompile’ => false, ‘ignoreNamespace’ => false ), ‘cache’ => array( ‘frontendOptions’ => array( ‘automatic_serialization’ => true, ‘automatic_cleaning_factor’ => 0, ‘lifetime’ => 3600 ), ‘backend’ => ‘File’, ‘backendOptions’ => array( ‘hashed_directory_umask’ => 0771, ‘cache_file_umask’ => 0644, ‘hashed_directory_level’ => 0, ‘cache_dir’ => $this->DocPath().‘cache/database’, ‘file_name_prefix’ => ‘shopware’ ), /* ‘backend’ => ‘Memcached’, ‘backendOptions’ => array( ‘servers’ => array( array( ‘host’ => ‘localhost’, ‘port’ => 11211, ‘persistent’ => true, ‘weight’ => 1, ‘timeout’ => 5, ‘retry_interval’ => 15, ‘status’ => true, ‘failure_callback’ => null ) ), ‘compression’ => false, ‘compatibility’ => false ) */ ), ‘session’ => array( ‘name’ => ‘SHOPWARESID’, ‘cookie_lifetime’ => 0, ‘use_trans_sid’ => false, ‘gc_probability’ => 1, ‘gc_divisor’ => 100, ‘save_handler’ => ‘db’ ), /* ‘session’ => array( … ‘save_handler’ => ‘memcache’, ‘save_path’ => ‘tcp://localhost:11211?persistent=1&weight=1&timeout=1&retry_interval=15’ ), ‘session’ => array( … ‘save_handler’ => ‘files’ ), */ ‘backend’ => array( ‘refererCheck’ => true, ), ‘phpsettings’=>array( ‘error_reporting’=>E_ALL | E_STRICT, ‘display_errors’=>1, ‘date.timezone’=>‘Europe/Berlin’ ) );[/code] habe auch noch nie shopware benutzt. mein chef hätte das jetzt gerne zwecks warenwirtschaft anbindung. momentan nutzen wir noch joomla mit virtuemart. das läuft auch wie gewohnt auf dem gleichen server. ich habe daher irgendwie ioncube oder zend im verdacht. achso installiert is übrigens die ioncube variante. bei der zend variane sehe ich garnix :slight_smile: nur weiss :slight_smile:

ich habe jetzt nochmal die zend variante installiert und da bleibt das browserfenster weiss. beim cache ordner habe ich auch chmod 777 versucht wie im wiki beschrieben. leider auch ohne erfolg :confused:

Wie hast du denn installiert? Manuell? Dann hast du die Dateien vermutlich nicht im Binär-Modus übertragen - aktiviere sonst mal die Optionen throwExceptions und showException aus der Application.php . Ansonsten eventuell fehlende Schreibrechte auf engine/Shopware/Proxies oder noch Cache-Rest aus der vorherigen Ioncube-Installation?

ich habe das lokale installationsskript benutzt. also die install.php hochgeladen und installiert. ‘throwExceptions’ => true gibt ähnliches aus: Fatal error: Uncaught exception 'Zend\_Session\_Exception' with message 'Zend\_Session::start() - /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Loader.php(Line:57): Error #2 include() [[function.include](function.include)]: open\_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/vhosts/s369189542.online.de/httpdocs/:/tmp/) Array' in /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Zend/Session.php:503 Stack trace: #0 /var/www/vhosts/s369189542.online.de/httpdocs/engine/Shopware/Bootstrap.php(118): Zend\_Session::start(Array) #1 [internal function]: Shopware\_Bootstrap-\>initSession() #2 /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Bootstrap.php(99): call\_user\_func(Array) #3 /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Bootstrap.php(69): Enlight\_Bootstrap-\>loadResource('Session') #4 /var/www/vhosts/s369189542.online.de/httpdocs/engine/Shopware/Shopware.php(69): Enlight\_Bootstrap-\>getResource('Sess in /var/www/vhosts/s369189542.online.de/httpdocs/engine/Enlight/Enlight/Zend/Session.php on line 503 könnte es sein dass die datei, die in der loader.php zeile 57 (include($path):wink: geladen werden soll, nicht geladen werden kann weil sie nicht drauf zugreifen darf? hab jetzt noch nicht nachgeforscht welche das genau ist. in der php.ini ist die option open_basedir aber auskommentiert also nicht aktiv.

Probiere nochmal folgendes in die config.php (unten) einzufügen: ini_set(‚session.save_path‘,’/tmp’); Ansonsten schick mir mal FTP-Daten an forum@shopware.de - dann schaue ich selbst nochmal

1 Like

hat leider auch nich geklappt. ich schick dir mal die daten. in der zeit vergleich ich mal meine php.ini mit der aus dem xampp packet

Hi, das ist wahrscheinlich irgendein Bug in deiner PHP-/Suhosin-Version. Das kann durch folgende Konfiguration-Eintrag in der Application.php umgangen werden. Einfach hinter den Eintrag „save_handler“ den Eintrag „throw_startup_exceptions“ hinzufügen. Beispiel: 'session' =\> array( ... 'save\_handler' =\> 'db', 'throw\_startup\_exceptions' =\> false ), Viele Grüße Heiner

1 Like

Tatsache! :slight_smile: Es läuft…ich danke euch vielmals :slight_smile: