Frontend 403 Fehler und .htaccess Datei

Hallo Ich habe das selbe Problem wie viele andere hier auch … Leider habe ich bei der Suche nix gefunden was mir irgendwie weiterhelfen konnte … Aktuellste Shopware Version installiert … Bei der Installation war nachdem ich die Schreibrechte der Ordner geändert hatte auch alles grün … Die Installation verlief eige3ntlich ohne Probleme … Ich kann aber das Frontend nicht aufrufen und bekomme eine 403 Fehlermeldung Zugriff verweigert! Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt. Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber. Error 403 www.naturprodukte-hexovital.com Sat Oct 11 14:54:11 2014 Apache/2.2.17 (Linux/SUSE) Ich kann das Shop Frontend aber unter folgender URL aufrufen http://www.naturprodukte-hexovital.com/shopware.php Auch ins Backend komme ich ohne Probleme rein http://www.naturprodukte-hexovital.com/ … p/backend/ Im Ordner „recovery“ gibt es einen Ordner Install und dort gibt es eine .htaccess Datei mit folgenden Inhalt
RewriteEngine On
RewriteRule .* - [E=MOD_REWRITE:1]
RewriteCond %{REQUEST_URI} !(/(templates)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php [QSA,L]
DirectoryIndex index.php
Order Deny,Allow
Deny from all

Order Allow,Deny
Allow from all

Order Allow,Deny
Allow from all
Es gibt eine weitere .htaccess Datei auf dem Server vor dem Ordner „public_html“ Da steht aber nicht zuviel drinnen und diese müßte ja eigentlich auch egal sein weil der Server direkt auf den Ordner „public_html“ springt … php_value session.save_path /home/p260120/www.naturprodukte-hexovital.com/.sess Ich denke es liegt mit Sicherheit irgendwie an der .htaccess Datei das der Shop nicht direkt aufrufbar ist ??? Aber ich habe keine Ahnung was ich da diesbezüglich machen soll … Hat jemand eine Idee ? Danke

Hallo Keiner eine Idee ? MFG Torben Kania

Schaue mal zunächst in deine .htaccess Datei. Dort evtl. Require all granted anstatt Order allow,deny Allow from all oder eine Ebene höher in deiner Apache Config, dort nach den Einträgen sehen und ändern. Apache einmal neu starten: sudo /etc/init.d/apache2 restart (Ubuntu) Dateirechte in deiner Installation waren ja ok, daher schau noch mal wer der Besitzer von deinem Pfad ist, falls root, dann auf www-data ändern. Hier mal alles was ich ausgeführt habe zum Thema Rechte und Shopware Installation. chmod 0777 /var/www/html/DEIN-ORDNER/config.php chmod 0777 /var/www/html/DEIN-PFAD/cache/html chmod 0777 /var/www/html/DEIN-PFAD/cache/general chmod 0777 /var/www/html/DEIN-PFAD/cache/templates chmod 0777 /var/www/html/DEIN-PFAD/cache/proxies chmod 0777 /var/www/html/DEIN-PFAD/cache/mpdf/tmp chmod 0777 /var/www/html/DEIN-PFAD/cache/mpdf/ttfontdata chmod 0777 /var/www/html/DEIN-PFAD/cache/doctrine/filecache chmod 0777 /var/www/html/DEIN-PFAD/cache/doctrine/proxies chmod 0777 /var/www/html/DEIN-PFAD/cache/doctrine/attributes chmod 0777 /var/www/html/DEIN-PFAD/files/documents chmod 0777 /var/www/html/DEIN-PFAD/files/downloads chmod 0777 /var/www/html/DEIN-PFAD/engine/Library/Mpdf/tmp chmod 0777 /var/www/html/DEIN-PFAD/engine/Library/Mpdf/ttfontdata chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Frontend chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Core chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Backend chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Frontend chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Core chmod 0777 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Backend chmod 0777 /var/www/html/DEIN-PFAD/logs chmod 0777 /var/www/html/DEIN-PFAD/media/archive chmod 0777 /var/www/html/DEIN-PFAD/media/image chmod 0777 /var/www/html/DEIN-PFAD/media/image/thumbnail chmod 0777 /var/www/html/DEIN-PFAD/media/music chmod 0777 /var/www/html/DEIN-PFAD/media/pdf chmod 0777 /var/www/html/DEIN-PFAD/media/unknown chmod 0777 /var/www/html/DEIN-PFAD/media/video chmod 0777 /var/www/html/DEIN-PFAD/media/temp Installation ausführen, dann sudo chown -R www-data:www-data /var/www/html/DEIN-PFAD chmod 0750 /var/www/html/DEIN-PFAD/ sudo chmod -R 775 /var/www/html/DEIN-PFAD chmod 0644 /var/www/html/DEIN-PFAD/config.php chmod 0775 /var/www/html/DEIN-PFAD/cache/html chmod 0775 /var/www/html/DEIN-PFAD/cache/general chmod 0775 /var/www/html/DEIN-PFAD/cache/templates chmod 0775 /var/www/html/DEIN-PFAD/cache/proxies chmod 0775 /var/www/html/DEIN-PFAD/cache/mpdf/tmp chmod 0775 /var/www/html/DEIN-PFAD/cache/mpdf/ttfontdata chmod 0775 /var/www/html/DEIN-PFAD/cache/doctrine/filecache chmod 0775 /var/www/html/DEIN-PFAD/cache/doctrine/proxies chmod 0775 /var/www/html/DEIN-PFAD/cache/doctrine/attributes chmod 0775 /var/www/html/DEIN-PFAD/files/documents chmod 0775 /var/www/html/DEIN-PFAD/files/downloads chmod 0775 /var/www/html/DEIN-PFAD/engine/Library/Mpdf/tmp chmod 0775 /var/www/html/DEIN-PFAD/engine/Library/Mpdf/ttfontdata chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Frontend chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Core chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Community/Backend chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Frontend chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Core chmod 0775 /var/www/html/DEIN-PFAD/engine/Shopware/Plugins/Default/Backend chmod 0775 /var/www/html/DEIN-PFAD/logs chmod 0775 /var/www/html/DEIN-PFAD/media/archive chmod 0775 /var/www/html/DEIN-PFAD/media/image chmod 0775 /var/www/html/DEIN-PFAD/media/image/thumbnail chmod 0775 /var/www/html/DEIN-PFAD/media/music chmod 0775 /var/www/html/DEIN-PFAD/media/pdf chmod 0775 /var/www/html/DEIN-PFAD/media/unknown chmod 0775 /var/www/html/DEIN-PFAD/media/video chmod 0775 /var/www/html/DEIN-PFAD/media/temp ### Apache Datei : /etc/apache2/sites-available/DEINE-DOMAIN.de.conf DocumentRoot /var/www/html/DEIN-PFAD.de ServerName DEINE-Domain.de
Options None
Options FollowSymLinks
AllowOverride All
Require all granted
Satisfy all

1 Like