Formate von Bannern in den Einkaufswelten

Hi,

ich wechsel gerade zu Shopware. Da noch nicht alle benötigten Plugins für die 6er verfügbar sind, musss ich erstmal mit der 5er arbeiten. Ich richte gerade die Startseite ein und komme da nicht klar. Die Formate sind in jeder Ansicht (Mobile, Desktop, Tablet etc.) anders. Ist das nicht responsive? Muss ich die Banner für jede Ansicht neu gestalten und hochladen?

Wenn ja, dann habe ich ich auch noch nicht gecheckt wie ich das für unterschiedliche Ansichten speichere. Vielleicht sehe ich den Wald vor lauter Bäumen nicht, aber immer wenn ich was für eine andere Ansicht hochlade, wird das in allen anderen Ansichten wieder überschrieben und es passt wieder nur in einer Ansicht Foot-in-Mouth

 

Hast Du dich schon mal mit der Doku beschäftigt ?:

https://docs.shopware.com/de/shopware-5-de/marketing-und-einkaufswelten/einkaufswelten

Wir haben zwei Einkaufswelten angelegt einmal für Mobile und einmal für Desktop. Dabei insbesondere drauf achten die Viewports (Ansichten) vor dem Abspeichern zu verknüpfen. 

Danach muss zur Ansicht auch der Template-Cache geleert und neu kompiliert werden. Am besten auch noch den Browser-Cache leeren (F5)

Ja, ich habe auch das Video darin geschaut. Aber irgendwas mache ich falsch.

Ich erkläre es mal von vorne. ich habe die 5 Device Einstellungen (Desktop, Mobile Portrait, Mobile Landscape, Tablet Portrait und Tablet Landscape) aktiviert. Layout fluid/responsive…

Ich klicke rechts im Fenster auf Mobile Portrait und lege mir dort eine Startseite mit mobile optimierten Bannern an. Nun möchte ich verknüpfen. Mobile Portrait kann ich nicht verknüpfen, es kommt die Meldung “Dies ist der aktuelle Viewpoint. Es können andere blb bla…” Zum Test möchte ich noch alle andere Ansichten, außer Desktop damit verknüpfen. Das klappt auch, es ist bei allen 4 Ansichten die Kette (Symbol) geschlossen, bei Desktop ist die Kette geöffnet. Bis hier hin erscheint mir das noch logisch und korrekt. Die 4 kleineren Ansichten sind verknüpft. Für Desktop sollen die gleichen Banner in einer anderne Auflösung verwendet und angelegt werden. Desktop ist daher nicht verknüpft.

Jetzt speichere ich…und nun ist die Kette überall wieder geöffnet. Wenn ich nun auf Desktop klicke und dort alles für den Desktop optimiert anlege und speichere, dann haben auch die Mobile und Tablet Ansichten die Desktop Auflösung.

Ist bestimmt was ganz einfaches, aber ich bin gerade überfordert.

Muss ich die Einkaufswelt 2x identisch anlegen? Einmal nur für die mobilen Geräte sichtbare und 1x nur für Desktop?

@Meppi schrieb:

Jetzt speichere ich…und nun ist die Kette überall wieder geöffnet. Wenn ich nun auf Desktop klicke

 

 

Und hier STOP

Hier gehst Du raus nach dem Speichern (das ist jetzt deine Mobile Einkaufswelt “EKW”) und legst eine neue EKW nur für den Desktop an. 

Ah sch…ich dachte man kann die Einkaufswelt selber für mehrere Geräte optimieren. Alles klar, jetzt ist der Groschen gefallen. Danke dir!

Welches Seitenverhältnis nimmt man denn am besten, damit in keiner Richtung etwas abgeschnitten wird? Versuche mich gerade an mobile Portrait, aber ständig wird unten oder seitlich was weggeschnitten. Auch wen nes nur ein paar Pixel sind. In der vorschau klappt es meist noch, aber live am Smartphone fehlt dann doch immer was.

Anderen Modus Layout verwenden. 

https://docs.shopware.com/de/shopware-5-de/marketing-und-einkaufswelten/einkaufswelten#layout

Das ganze ist ziemlich tricky, je nachdem was man in welcher Folge optimal darstellen will…

Nach dem was ich probiert habe, kommt das fluide / responsive noch am nähesten. Ich denke mal, man wird es nicht perfekt für jedes Smartphone hinbekommen. Bei mir wird seitlich was abgeschnitten. Am IPhone meiner Frau kurioserweise unten. Wenn ich jetzt noch 10 andere Handymodelle teste, wird noch was anderes raus kommen.

Wenn bspw. Mode verkauft und Models auf freigestellten weißem Hintergrund verwendet, würde das wohl garnicht auffallen, wenn da ein paar weiße Pixel fehlen. Ich muss meine Grafiken halt jetzt so anpassen, dass Logos und Siegel nicht so am Rand liegen, dort erkennt man es halt, wenn was abgeschnitten ist.

Was mich aber stört, ist die Tatsache, dass sich der Shop nicht nicht nur hoch und runter scrollen läßt sondern auch etwas zur Seite schieben läßt. Es “schwimmt” irgendwie. Bei meiner Frau ist der Shop seitlich fest, so wie es sein soll. Es kann nur nach oben und unten gescrollt werden. Bei mir schwimmt es wie gesagt, ich habe dann an der Seite einen grauen Rand und und wenn ich runter scrolle kommt sogar manchmal das Hintergrundbild, was nur am Desktop sichtbar sein soll. Liegt das an meinem Samsung Edge (das mit den runden Rändern) oder habe ich das eine falsche Konfiguration im Shop?