Fehlermeldung

Hallo zusammen, habe vor kurzem den neuen Shop auf den Server von Profihost gezogen. Alle Einstellungen stimmen und auch Profihost konnte mir nicht mehr weiterhelfen. Folgende Fehlermeldung bekomme ich beim Aufrufen des Backendbereiches. Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[HY000] [2005] Unknown MySQL server host ‘127.0.0.1:3307’ (3)’ in /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php:129 Stack trace: #0 /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php(129): PDO->__construct(‘mysql:dbname=us…’, ‘lifvmaky’, ‘jm6v55rx’, Array) #1 /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Vendor/Zend/library/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect() #2 /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Pdo_Mysql->_connect() #3 /lifvmaky/www.bastelbedarf-basteln.de/engine/Shopware/Bootstrap.php(48): Zend_Db_Adapter_Abstract->getConnection() #4 [internal function]: Shopware_Bootstrap->initDb() #5 /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Enlight/Bootstrap.php(99): call_user_func(Array) #6 /lifvmaky/www. in /lifvmaky/www.bastelbedarf-basteln.de/engine/Enlight/Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php on line 144 Uns diese Fehlermeldung im Frontbereich SQLSTATE[HY000] [2005] Unknown MySQL server host ‘127.0.0.1:3307’ (3) in Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php on line 144 Stack trace: #0 Vendor/Zend/library/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect() #1 Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Pdo_Mysql->_connect() #2 Shopware/Bootstrap.php(48): Zend_Db_Adapter_Abstract->getConnection() #3 [internal function]: Shopware_Bootstrap->initDb() #4 Enlight/Bootstrap.php(99): call_user_func(Array) #5 Shopware/Bootstrap.php(12): Enlight_Bootstrap->loadResource(‘Db’) #6 Enlight/Application.php(69): Shopware_Bootstrap->run() #7 shopware.php(6): Enlight_Application->run() #8 {main} Kann mir jemand nach 2 stündiger Suche und lesen erklären was genau hier vorliegt. Mit freundlichen Grüßen Kay79

Hi, das Thema steht eigentlich auch in der installationsanleitung unter Besonderheiten bei den Providern. :wink: Hast Du evtl. noch nicht diese Zeile in der application.php auskommentiert bzw. gelöscht? 'host' =\> $DB\_HOST Mach das ansonsten einmal bitte und poste, obe es dann geht!? Stefan :shopware: PS.: Die Datei liegt direkt im Shop-Rootverzeichnis, dort wo auch die shopware.php und die config.php liegt

alles schon gemacht. vielleicht mache ich ja etwas verkehr. was aber eigentlich nicht sein kann das nur hinein zu kopieren. Muss noch etwas dazu geschrieben werden? Dieses host findet man ja bei application.php 2 mal im Verzeichnis. ‘db’ => array( ‘username’ => $DB_USER, ‘password’ => $DB_PASSWORD, ‘dbname’ => $DB_DATABASE, ‘host’ => $DB_HOST und ‘backend’ => ‘Memcached’, ‘backendOptions’ => array( ‘servers’ => array( array( ‘host’ => $DB_HOST ‘port’ => 11211, ‘persistent’ => true, ‘weight’ => 1, ‘timeout’ => 5, ‘retry_interval’ => 15, ‘status’ => true, ‘failure_callback’ => null Die confic.php sieht so momentan aus. $DB_HOST = “127.0.0.1:3307”; $DB_USER = “…”; $DB_PASSWORD = “…”; $DB_DATABASE = “…”; $DB_CONNECTOR = “mysql”; ?>

Trag mal versuchsweise als Host localhost ein - ansonsten bitte Zugangsdaten FTP per Mail an forum@shopware.de - dann schaue ich da mal rein!

1 Like

das war es. es muss localhost eingetragen werden bei beiden Punkten, dann zeigt er auch das Backend an. Recht herzlichen Dank

Ja, ich glaube Profihost hat da zwischenzeitlich etwas an der PDO-Konfiguration verändert - nun gut, wenn es läuft, alles super :wink: