Fehler oder zu doof zum bedienen?

Hallo,

ich komm gerade nicht weiter - vielleicht kann jemand helfen? 

Ich hab eine Einkaufswelt erstellt, dort das Element „Artikel“ verwendet, mit einem ausgewählten Artikel.

In meiner Testumgebung (ca. 10 Tage alte Kopie des Live Systems, seit dem aber keine Plugins hinzugefügt oder Updates gemacht - lediglich Template Frontend abgeändert worden aber bei beiden System gleich) klappt das wunderbar, in meinem Live System fehlt der „Jetzt bestellen“ Button. Einstellungen scheinen alle richtig zu sein, oder ich übersehe was? 

Jemand eine Idee so spontan wie ich da den Fehler finden kann?

Danke im voraus!

Einstellungen - Storefront  -  Kategorien / Listen

“Kaufenbutton im Linsting anzeigen” auf ja stellen;

aber Vorsicht - rechtliches Beachten ! (Ich weiss nicht wie das mit den angebotenen Dienstleistungen ist)

Danke für die rasche Antwort - war es leider nicht. Ist in “live” und “testumgebung” jeweils auf nein. Ein ändern habe ich gerade ausprobiert, macht keinen Unterschied. 
Für den Kauf auf dem Listing nutze ich ein Plugin. Das funktioniert aber auch auf allen Seiten.

Was nicht klappt, ist der “Jetzt bestellen” Button in der Einkaufswelt bei dem Modul “Artikel”. Und was mich daran wundert, ist dass es in der Testumgebung aber funktioniert.

Kann man solche Darstellungsfehler nicht irgendwie mit Firefox oder Chrome auslesen/finden?

F12

Die betreffenden artikel stehen gar nicht zur Verfügung (Datum muss angewählt werden) - deswegen ist der Warenkorb-Button ausgeblendet !

Danke. Die Entwicklertools an sich kenne ich - sehe aber leider keinen “FEHLER” oder sowas auftauchen. Wenn ich mir den Quelltext ansehe, seh ich schon dass das Element für den Button einfach nicht da ist (im Gegensatz zu der Testumgebung). Aber weiß nicht ob man irgendwo sehen könnte das was nicht “klappt”. 

Die Idee, dass es an Varianten liegt hatte ich auch, der Fehler ist aber auch bei normalen Artikeln vorhanden (hatte ich ausprobiert). Und zudem klappt es mit diesen Varianten Artikeln in der Testumgebung, die Optionen sucht man sich dann aus wenn man drauf drückt (da kommt das Plugin ins Spiel).

Irgendwas muss im Live System passiert sein (höchstwahrscheinlich durch mich, schon klar), dass das jetzt nicht mehr geht. 

jetzt gehts!

Um die Frage zu beantworten - eher zu dumm zum bedienen.

Es gab noch eine Einstellung im Plugin um dies in Einkaufswelten explizit zu erlauben. Wusste ich nicht, das stand schon immer so eingestellt.
Warum in der Testumgebung (1:1 Kopie) es angestellt war und im Live System nicht (mehr) keine Ahnung.
 

Danke fürs mithelfen - zu zweit findet man sowas immer schneller raus!

DANKE :slight_smile:

Dann schalt das plugin mal ab, wenns dann geht weist Du das es am plugin in der Live-Umgebung liegt.

Fleisig cache leeren und template kompilieren nicht vergessen.

1 Like