Error in Shop?

Gestern verschwanden einfach ein paar Bilder (mit Links) in den Einkaufswelten - inkl. der Einstellungen des Dreitags Banner Advance. OHNE Errrormeldung.

Heute früh dann diese Error Meldung - mit der ich irgendwie nix anfangen kann… Würde mir jemand sagen, welcher Teil von Shopware betroffen ist?:

ERROR

Message:

 exception 'SmartyException' with message 'unable to write file /../var/cache/production\_201510221322/templates/backend\_de\_DE\_5a6df/f1/7b/46/wrt5742a8cb7e8e37.15415154' in /../engine/Library/Smarty/sysplugins/smarty\_internal\_write\_file.php:48

 Stack trace:

 #0 /../engine/Library/Smarty/sysplugins/smarty\_internal\_template.php(201): Smarty\_Internal\_Write\_File::writeFile('/homepages/12/d...', '<?php /* Smarty...', Object(Enlight_Template_Manager))</pre>

     #1 /../engine/Library/Smarty/sysplugins/smarty\_internal\_templatebase.php(155): Smarty\_Internal\_Template-\>compileTemplateSource()



     #2 /../engine/Library/Smarty/sysplugins/smarty\_internal\_template.php(286): Smarty\_Internal\_TemplateBase-\>fetch(NULL, NULL, NULL, NULL, false, false, true)



     #3 /../var/cache/production\_201510221322/templates/backend\_de\_DE\_5a6df/26/db/83/26db832e907ddbf83a80c38665ecdf7b56b7bf56.snippet.index.tpl.php(142): Smarty\_Internal\_Template-\>getSubTemplate('backend/custome...', NULL, 'backend\_de\_DE\_5...', NULL, NULL, Array, 0)



     #4 /../engine/Library/Smarty/sysplugins/smarty\_internal\_templatebase.php(180): content\_5742a8cb026576\_76465591(Object(Enlight\_Template\_Default))



     #5 /../engine/Library/Enlight/View/Default.php(274): Smarty\_Internal\_TemplateBase-\>fetch()



     #6 /../engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight\_View\_Default-\>render(Object(Enlight\_Template\_Default))



     #7 /../engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>renderTemplate(Object(Enlight\_Template\_Default))



     #8 /../engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>render()



     #9 [internal function]: Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>onPostDispatch(Object(Enlight\_Controller\_ActionEventArgs))



     #10 /../engine/Library/Enlight/Event/Handler/Default.php(91): call\_user\_func(Array, Object(Enlight\_Controller\_ActionEventArgs))



     #11 /../engine/Library/Enlight/Event/EventManager.php(210): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Controller\_ActionEventArgs))



     #12 /../engine/Library/Enlight/Controller/Action.php(201): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs))



     #13 /../engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight\_Controller\_Action-\>dispatch('loadAction')



     #14 /../engine/Library/Enlight/Controller/Front.php(227): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))



     #15 /../engine/Shopware/Kernel.php(148): Enlight\_Controller\_Front-\>dispatch()



     #16 /../vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)



     #17 /../engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)



     #18 /../vendor/symfony/http-kernel/HttpCache/HttpCache.php(263): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true)



     #19 /../engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true)



     #20 /../shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))



     #21 {main}



**Time:**



     2016-05-23T08:52:59.565109+0200



**Channel:**



     core



**request:**



     {



     &nbsp;&nbsp;&nbsp; "uri": "/backend/customer/load/?f=m/Customer|m/Billing|m/Shipping|m/Debit|m/PaymentData|m/List|m/Order|m/Chart|m/BillingAttributes|m/ShippingAttributes|m/Attribute|m/Batch|v/detail/Window|v/detail/Base|v/detail/Billing|v/detail/Shipping|v/detail/Debit|v/detail/Comment|v/detail/Additional|v/list/List|v/main/Window|v/order/List|v/order/Chart|store/Detail|store/List|store/Orders|store/Chart|store/Batch|c/Main|c/List|c/Detail|c/Order&no-cache=1463986368+1+1",



     &nbsp;&nbsp;&nbsp; "method": "GET",



     &nbsp;&nbsp;&nbsp; "query": {



     &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "f": "m/Customer|m/Billing|m/Shipping|m/Debit|m/PaymentData|m/List|m/Order|m/Chart|m/BillingAttributes|m/ShippingAttributes|m/Attribute|m/Batch|v/detail/Window|v/detail/Base|v/detail/Billing|v/detail/Shipping|v/detail/Debit|v/detail/Comment|v/detail/Additional|v/list/List|v/main/Window|v/order/List|v/order/Chart|store/Detail|store/List|store/Orders|store/Chart|store/Batch|c/Main|c/List|c/Detail|c/Order",



     &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "no-cache": "1463986368 1 1",



     &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "module": "backend",



     &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "controller": "customer",



     &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "action": "load"



     &nbsp;&nbsp;&nbsp; },



     &nbsp;&nbsp;&nbsp; "post": []



     }



**session:**



     {



     &nbsp;&nbsp;&nbsp; "userId": "XX",



     &nbsp;&nbsp;&nbsp; "roleId": "1"



     }



**shop:**



     No shop data available

Ich würde mal bei

'unable to write file

anfangen und gucken ob das Verzeichnis (inkl. erwartetem Inhalt) existiert und ob die Rechte passen.

1 Like

Alternativ gleich noch schauen ob genügen Speicherplatz frei ist.

mfg Matthias

2 Likes

Danke für Eure Tipps!

Leider hat das nichts geholfen.

  • Platz ist noch ausreichend

-die ORdner ab /…/f1/ fehlten. Ein Einrichten der Ordnerstruktur brachte keine Änderung.

Wenn man wenigstens wüßte, welches Plugin da betroffen ist…

Okay, Problem gelöst.

Es war ein veraltetes Plugin von Shopware! (Customer Import/Export)