[ERLEDIGT]PayPal Plugin - Bestellung kommt weder im Shop noch bei PayPal (Zahlung) an

Hallo zusammen,

da ich mit dem alten PayPal PlugIn ständig Update-Probleme hatte (es ließ sich nicht updaten) habe ich heute das aktuelle installiert. Soweit so gut.

Beim ersten Mal wenn ich die Sandbox aktiviert habe, klappte alles perfekt, konnte danach aber mit den Live-Daten nix mehr anfangen, ich erhielt immerzu folgende Fehlermeldung:

Der Webhook konnte auf Grund dieses Fehlers nicht registriert werden:
An error occurred: The token passed in was not found in the system [invalid_token]

Nach etlichen Versuchen, habe ich einfach alles gelöscht und komplett neu gemacht. PlugIn neu installiert und alles von vorne. Diesmal ohne Sandbox, sondern direkt im Live-Modus mit den Live-Daten von PayPal.

Der API-Einstellungs-Test war fehlerfrei
Die Webhook-Registrierung war fehlerfrei

Eine Freundin hat im Shop eine Bestellung ausgelöst und mit PayPal bezahlt. SIE bekam keine Fehlermeldung, allerdings ist die Bestellung weder im Shop, noch bei PayPal als Zahlung eingegangen.

Ich bin am verzweifeln und sehe einfach nicht, WO ich eventuell noch einen Fehler im System habe.

Shopware Version 5.4.6
PlugIn Version: PayPal 1.0.5

Ich würde mich über eine Antwort freuen, sonst steht der Shop quasi still :-( 

 

Vielen Dank schon mal 

Mopi

 

Folgende PlugIns laufen im Shop:

 

Das Problem hat sich quasi selbst erledigt… nach der x-ten Neuinstallation funktioniert das ding nun… warum auch immer

1 Like

ich hatte das gleiche Problem.

Erst nach einer Neuinstallation des Plugins hat sich der Webhook endlich gefangen.

Ich schließ mich hier mal an, das Workaround hat bei mir geholfen.

Webhooks konnte ich registrieren nachdem das Plugin neu installiert wurde.