Downloadpath von wird nicht umgeleitet

Hallo zusammen,

ich habe seit kurzem das Problem dass meine Downloadpath’s nicht umgeleitet werden. 5.1.1

 

Ich hole mir über ein Freitextfeld den Downloadpath erfolgreich ins Frontend:

www.xxx.de/media/pdf/dateiname.pdf

 

Bekomme allerdings beim aufrufen des Links folgende Fehlermeldung:

404 - not found

The requested URL /media/pdf/dateiname.pdf was not found on this server.

Apache Server at www.xxx.de Port 443

 

In einer anderen Version des Shops wird bei dem Aufruf des Links ein 302 redirect in des korrekte Verzeichnis erstellt und die PDF ist verfügbar. An welcher Stelle wird der 302 erstellt?

 

Weiß jemand woran dies liegt? :o

Weiß jemand woran dies liegt?

Hm, wie soll man so aus der Ferne darauf antworten? 

In der Regel liegen die PDFs ja in Unterverzeichnisse. Also so in der Art /media/pdf/fa/0e/94/dateiname.pdf … ich würde prüfen ob das PDF auch wirklich dort liegt. Ob der Dateiname auch wirklich stimmt. Eventuell stimmt etwas an der htaccess nicht. Vielleicht ist dieser Bereich des Ordners durch eine zusäzliche htccess gesichert.

1 Like

@R4M schrieb:

Weiß jemand woran dies liegt?

Hm, wie soll man so aus der Ferne darauf antworten? 

In der Regel liegen die PDFs ja in Unterverzeichnisse. Also so in der Art /media/pdf/fa/0e/94/dateiname.pdf … ich würde prüfen ob das PDF auch wirklich dort liegt. Ob der Dateiname auch wirklich stimmt. Eventuell stimmt etwas an der htaccess nicht. Vielleicht ist dieser Bereich des Ordners durch eine zusäzliche htccess gesichert.

 

Dein Tipp mit der .htaccess hat mich weiter gebracht!

 

Ich habe mir nur die “root”-htaccess angeschaut, jedoch lag in dem media-Ordner noch eine zusätzliche, danke :slight_smile:

Das war nur ins Blaue geraten :slight_smile: