Domainumzug auf Subdomain

Hallo, mein Ziel war es von www.xyz.de/shop nach shop.xyz.de umzuziehen. Dazu habe ich mein Shopverzeichnis komplett kopiert (download/upload). Dann die Pfade sPath und sBasepath auf shop.xyz.de abgeändert. Danach den Eintrag in s_core_multilanguage auch auf shop.xyz.de. Trozdem erhalte ich den bekannten Fehler keine gültige Lizens, obwohl ich eine neue Lizens eingegeben habe. Die alte Lizens habe ich entfernt. Eine Sache fällt auf, die Domain shop.xyz.de wird nun unter Subshops angezeigt. Dort steht auch, dass für Subshops eine zusätzliche Lizenz erforderlich ist. Check.php zeigt an, dass keine Lizenz vorhanden ist. Ich weiß nun nicht wie ich mich dem Problem nähern soll. Hat jemand noch eine Idee? Vielen Dank

Mit einmal gehts! Leider weiß ich nicht wieso! Cache löschen etc. hatte ich auch vorher schon gemacht, das hat alles nix genützt. Ich hatte mir nochmal die Tabelle s_core_multilanguage angeschaut und den Eintrag unverändert gespeichert. Vll war es das! Möglicherweise ein Leerzeichen zuviel? keine ahnung.

Wahrscheinlich hättest du den Browser danach einmal neu starten müssen - der speichert ja Teile der Konfiguration in der Session und die wird erst bei einem Browser-Neustart erneuert!

1 Like

Der Witz ist, dass check.php nach wie vor eine fehlende Lizenz anmahnt. Genauso werden Shopware Coredateien wie z.B. sArticels.php als fehlend gemeldet. Diese habe ich bereits einmal nachinstalliert - ohne Ergebnis. Trotzdem funktionieren jetzt Frontend und Backend scheinbar wie gehabt. Ich hoffe, dass ich das ignorieren kann. Hat jemand dazu eine Idee? Oder sollte vorsichtshalber alles neu aufsetzten? Vielen Dank

Hi, Mit 3.5.4 brauchst du ja eh keine Lizenz für den Core mehr bei der CE Version, die wird nur für die Pro Version benötigt. Das mit den Dateien liegt daran, dass das Systemchecktool noch auf die 3.5.3 prüft. Bei Dir sollte also alles in Ordnung sein und Du brauchst auf keinen Fall neu aufsetzen. Gruß Stefan

1 Like