Der Hinweis für die Cookies popt mit jeder Seite auf

Hallo zusammen,

beim Einrichten meines Shops fällt mir gerade auf, dass wenn man auf die Shopseite geht, unten zuerst ein Hinweis aufpoppt, dass die Webseite Cookies verwendet. Abgesehen davon, dass ich mich gerade überhaupt nicht um Cookies kümmere, wahrscheinlich macht das Shopware per Default, stört mich das nicht, ist man ja schon gewohnt. Aber egal ob ich dem Zustimme oder Ablehne, der Dialog geht mit der Bestätigung weg, sobald ich aber im Shop die Seite wechsle, erscheint der Hinweis wieder, und immer wieder. Das verstehe ich nun gar nicht, ist das nur bei mir so, das muss dann doch jedem gehen. Es ist dabei egal ob Desktop oder mobile Version. Kann man da was einstellen, wie gesagt, ist das Thema Cookies für mich erst mal uninteressant, ich werde da auch nie was einrichten, geschweige denn dazu programmieren.

In der Vorschau aus dem Admin-Bereich passiert das nicht, aber eben auf der öffentlich zugänglichen Webseite.

Gruß Frank

Lehnt dein Browser ggfs. alle Cookies ab?

Hallo Max, muss ich noch prüfen, es sprechen aber mehrere Dinge dagegen:
Auf keiner anderen Webseite habe ich den Effekt.
Es tritt auf dem PC wie auch auf dem Handy und einem anderen Rechner auf.
Warum tritt es auch auf, wenn ich Cookies ablehne, dann muss sich Shopware die Info doch eh woanders Speichern, auf meinen Rechner dürfen dann ja keine Cookies bzw. fremde Daten.

Das muss was mit Shopware, der Domain oder sonst was sein.

Gruß Frank

Ich glaube, du kennst dich nicht ganz mit der Cookie-Richtlinie aus. Funktionale Cookies dürfen immer gespeichert werden, auch ohne Einwilligung des Nutzers.

Woher soll denn das Cookie Banner wissen, dass das Cookie abgelehnt wurde, wenn die Information nicht in einem Cookie gespeichert wurde? Dann müsste man Sessions per URL übergeben.

Hallo Max, ja, da hast du vollkommen recht, mit Cookies kenne ich mich nicht aus.

Das Problem hat sich aber mittlerweile gelöst. Meine Domain vom Shop habe ich ja gerade erst anlegen lassen. Dabei wurde sie auch noch als Unsicher angezeigt, obwohl ich gestern noch ein SSL Zertifikat zufügt habe. Dazu hatte ich dann noch ein Ticket bei meinem Webhoster laufen. Er hatte festgestellt, dass ich die Option HTTP zu HTTPS umleiten noch nicht aktiviert hatte, seit das nun aktiviert ist, ist auch der Cookie-Fehler weg. Wie auch bei den Cookies kenne ich mich mit Server- und Web Administration nicht aus, meine Domäne sind eher die Industrie Automation und eben mein Kreativ-Shop, der gerade entsteht.
Dennoch Danke für deine Mithilfe. Der Post hilft evtl. anderen die ebenso wie ich Cookies nur in süßer Form mögen.

Gruß Frank

1 Like