Conexco Template nach update zerschossen (Artikel Slider)

Hallo, ich habe gerade ein update auf die neueste Conexco Responsive Template Version durchgeführt. Jetzt ist das Template zerschossen > alles was als Artikel Slider dargestellt werden sollte wird nicht mehr als Slider, sondern die Artikel werden untereinander dargestellt (z.B. Kunden haben sich ebenfalls angesehen und Artikel Slider). Ist das jetzt nur bei mir passiert? Gruß Christian

Und wenn mehrere Artikelbilder vorhanden sind, dann wird daraus keine Vorschau gemacht, sondern alle komplett in voller Größe dargestellt.

Hi, hatte das auch! Nutz du zufällig das Plugin „Individueller SEO Footer pro Kategorie definierbar“? Wenn ja deaktivier das, das ist jetzt nicht mehr kompatibel mit der neuen Conexco Version und überschreibt da irgendwelche .js Dateien. Musste das bei mir leider auch deaktivieren. Solltest Du Anpassungen am Template vorgenommen haben, so würde ich diese auch erstmal entfernen. Dann das Update durchführen und nach und nach die Änderungen wieder in die entsprechenden Ordner schmeißen. Musste bei mir aber auch 1-2 Sachen neumachen, da sich mit dem Update sehr viel geändert hatte. Gruß

1 Like

…tatsächlich benutze ich den dreischild Seo Footer und der hat auch alles zerschossen! Das ist ja ein Ding. Ich mache das update erst einmal wieder retoure und warte mit dem update so lange, bis Dennis aus dem Urlaub zurück ist und hoffentlich den Seo Footer schnellstmöglich anpasst. Danke Erst einmal für den Tipp!

Hallo, vermutlich (d.h. ohne Gewähr) sollte sich das Problem beheben lassen in dem man im File: engine/Shopware/Plugins/Community/Frontend/DreiscFooter/templates/frontend/dreisc_footer/index_conexco.tpl Die Zeilen 33-38: {block name="frontend\_index\_footerr\_javascript\_jquery"} <script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/jquery-ui-1.10.3.custom.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/shopware-responsive.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script> {/block} gegen folgenden Inhalt austauscht: {block name="frontend\_index\_footerr\_javascript\_jquery"} <script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap.min.js'%7D?v=%7B%24CacheBreaker%7D-%7B%24swVersion%7D-%7B%24swrtVersion%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/jquery-ui-1.10.3.custom.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap-select.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/shopware-responsive.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/slick.min.js'%7D?v=%7B%24CacheBreaker%7D"></script>{/block} Bitte unbedingt das File vorher sichern und am besten nicht im Live-Betrieb testen. Hierbei handelt es sich auf jeden Fall nur um einen “hotfix” die finale Lösung wird dann vermutlich in Kürze von Dreischild veröffentlicht werden. Gruß,

[quote=“Joscha”]Hallo, vermutlich (d.h. ohne Gewähr) sollte sich das Problem beheben lassen in dem man im File: engine/Shopware/Plugins/Community/Frontend/DreiscFooter/templates/frontend/dreisc_footer/index_conexco.tpl Die Zeilen 33-38: {block name="frontend\_index\_footerr\_javascript\_jquery"} <script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/jquery-ui-1.10.3.custom.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/shopware-responsive.min.js'%7D?cachebreaker=%7B%24CacheBreaker%7D"></script> {/block} gegen folgenden Inhalt austauscht: {block name="frontend\_index\_footerr\_javascript\_jquery"} <script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap.min.js'%7D?v=%7B%24CacheBreaker%7D-%7B%24swVersion%7D-%7B%24swrtVersion%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/jquery-ui-1.10.3.custom.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/bootstrap-select.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/shopware-responsive.min.js'%7D?v=%7B%24CacheBreaker%7D"></script><script type="text/javascript" src="%7Blink%20file='frontend/_resources/js/slick.min.js'%7D?v=%7B%24CacheBreaker%7D"></script>{/block} Bitte unbedingt das File vorher sichern und am besten nicht im Live-Betrieb testen. Hierbei handelt es sich auf jeden Fall nur um einen “hotfix” die finale Lösung wird dann vermutlich in Kürze von Dreischild veröffentlicht werden. Gruß,[/quote] Hallo Joscha, geilo! Hat super funktioniert, vielen Dank! :thumbup: Was mir noch aufgefallen ist: Bei der Artikelansicht, dauert es jetzt immer länger bis sich alle Bilder richtig positioniert haben. Wenn man nur ein Bild hat ist alles ok. Sobald aber mhrere hinterlegt sind, dauert ist immer eine Zeit bis sich die Thumbnails unter dem Hauptartikelbild richtig positioniert haben. Das sieht nicht wirklich schön aus. Kann man da noch was machen, das dies schneller geht? Gruß

Moin, ich benutze das Plugin Seo-Footer nicht und trotzdem ist das Layout zerschossen nach dem Update. Herstellerbanner die als Slider auf der Startseite angelegt worden sind stehen jetzt alle statisch untereinander. Ebenso stehen die Cross-Seller in der Detailansicht der Artikel statisch untereinander. Hat da irgendjemand eine Idee wo man ansetzen könnte?

[quote=„saar-erotik-shop“]Moin, ich benutze das Plugin Seo-Footer nicht und trotzdem ist das Layout zerschossen nach dem Update. Herstellerbanner die als Slider auf der Startseite angelegt worden sind stehen jetzt alle statisch untereinander. Ebenso stehen die Cross-Seller in der Detailansicht der Artikel statisch untereinander. Hat da irgendjemand eine Idee wo man ansetzen könnte?[/quote] Also das war bei mir auch. Ich hatte allerdings das SEO-Footer Plugin und hatte dann alles wieder auf den alten Stand gebracht, damit der Fehler weg ist. Gut, dass ich das update nun nicht schon wieder ausgeführt habe, wenn es auch ohne das Plugin diese Probleme gibt.:wtf:

OK, vielleicht sollte man vorher im Store in seine Lizenzen schauen und nicht einfach die Updates aus dem Backend heraus machen. Beim genannten Conexco-Template Plugin steht bei mir folgender Hinweistext: [quote]Changelogs: de_DE Achtung: Bitte beachten Sie, dass es mit diesem Update zu vielen Anpassungen / Neuerungen am Shopware Responsive Template gekommen ist. Aus diesem Grund haben wir uns auch dazu entschlossen dieses Update als neue Version (2.0.0) zu veröffentlichen. Sollten Sie an Ihrem Shop Individualisierungen vorgenommen haben, die über die Einstellungen im Backend hinaus gehen (Anpassungen an den Template-Files, Erweiterungen über das Theme-Verzeichnis etc.) bzw. Plugins nutzen, welche nicht von uns ausdrücklich als kompatibel deklariert wurden, so weisen wir hiermit ausdrücklich darauf hin, dass es zu Kompabilitäts-Problemen kommen kann und empfehlen Ihnen dringend das Update auf einem Test-System vorzunehmen und dies zu prüfen bevor Sie das Template Ihres Live-Shops aktualisieren. In beiden Fällen sollten Sie zwingend ein Backup Ihres Systems vornehmen, um im Notfall darauf zurückgreifen zu können. Änderungen in Version 2.0.0: Neuerungen: - Update auf Bootstrap Version 3.3.1 - Flexslider durch Slick-Slider ersetzt - Slider können nun je Viewport konfiguriert werden - Bootstrap Select als Standard für Auswahlboxen - Kompatibilität mit Cookie-Permission-Plugin hergestellt - Kompatibilität mit neuer Version der Trusted Shops Integration hergestellt - Kompatibilität mit dem Premium Plugin Advanced Cart hergestellt - Anzeige der ausgewählten Filter oberhalb der Artikelliste als Tags - Auswahl der Filter als Bootstrap-Select statt Bootstrap Panel - Konfiguration der Breakpoints aus dem Backend-Modul heraus möglich Verbesserungen: - Artikelbilder im Listing werden nun vertikal zentriert angezeigt - Viele zusätzliche Einstellungen und Variablen im Backend-Modul - Artikelvergleich optimiert - Größeres Modal für die Anzeige des Produktbilds auf der Detailseite - Neues PayPal Logo integriert - Kompatibilität mit der neuen Version des Bonuspunkte Plugins hergestellt - Das Template registriert sich nun früher, was zur Verbesserung im Zusammenspiel mit anderen Plugins führt - Anzeige der Zusammenfassung und Artikelmenge im Warenkorb verbessert - LESS Struktur optimiert - Ausgabe des SEO-Titles im Blog - AGB öffnen sich jetzt unabhängig vom Snippet im Modal - Spinner/Loading und Breite des AJAX-Warenkorbs optimiert - Effekt für CSS-Transitions hinzugefügt - Kein erneutes Laden der Seite mehr nachdem ein Artikel in den Warenkorb gelegt wurde Fehlerbehebungen - stand beim englischen Shop auf „de“ - Links im Footer nun in allen Viewports klickbar - Zubehör-Artikel werden auf der Detailseite korrekt übergeben - Navigation in Suchvorschlägen im Google Chrome korrigiert - Title Tag des Service Menüs in mobiler Ansicht korrigiert - Kompabilität des DHL-Intgration Plugins korrigiert - Hersteller-Links korrigiert - Der Slider wird nun nicht mehr initialisiert, wenn er nicht benötigt wird - Fehlenden Border-Radius für Shop-Menü bei geöffnetem AJAX-Warenkorb hinzugefügt - Fehlt das Herstellerbild im Emotion-Slider so wird nun der Name des Herstellers ausgegeben[/quote] Da bin ich froh das ich vor jeder Änderung ein Backup angelegt habe. Template downgrade und fertig, alles wieder OK. Kann allerdings eigentlich nicht Sinn der Sache sein! :thumbdown:

Der Hinweis steht aber auch im Backend unter Changelog. Also bei mir funzt das jetzt wieder dank des Hotfix. Evtl liegt es bei auch wirklich an Templateanpassungen. War bei mir auch so, musste dann 1-2 Anpassungen neu machen. War aber halb so wild.

[quote=“saar-erotik-shop”]OK, vielleicht sollte man vorher im Store in seine Lizenzen schauen und nicht einfach die Updates aus dem Backend heraus machen.[/quote] Dies empfiehlt sich generell bei allen Updates - also sowohl von Shopware als auch von Plugins. Leider hat es sich etwas “eingebürgert”, dass man einfach mal schnell im Live-System auf Update klickt und sich dann wundert das sich was geändert hat :wink: [quote=“saar-erotik-shop”]Kann allerdings eigentlich nicht Sinn der Sache sein! :thumbdown:[/quote] Wie meinen Sie das genau?

[quote=“saar-erotik-shop”]Kann allerdings eigentlich nicht Sinn der Sache sein! :thumbdown:[/quote] [quote=“Joscha”] Wie meinen Sie das genau?[/quote] Damit war das Downgrade des Templates gemeint. :sunglasses:

Eigentlich wollte Dennis ein update für den Seo Footer bringen, damit das aus der Welt ist. Bis jetzt ist noch nichts gekommen, oder habe ich etwas übersehen?:frowning:

Bin mir nicht sicher aber kann auch sein dass der Fix in einem der zahlreichen Cenexco Updates enthalten war. Ich nutze die aktuellste Version vom Conexco und auch den Seo Footer, läuft einwandfrei. Hatte vor dem Update aber auch den Hotfix hier von Joscha genutzt. Entweder greift dieser noch oder die haben was am Conexco geändert.