Captcha Kontaktformular und mobile Version

hallo, musste meine geliebten wirklich uralt xtcommerce shop aufgegeben, weil 1und1 mysql 4 abgeschaltet hat. habe jetzt Shopware 4 empfohlen bekommen und es zum laufen gebracht. jedoch suche ich eine möglichekeit das captcha auszuschalten, hatte ich früher auch nicht, mit capcha habe ich keine anfragen mehr. und eine mobile version wäre auch klasse. ansonsten überlege ich doch die aktuelle version von xt commerce zu nehmen nehmen, wobei ich keine ahnung habe, ob diese beiden punkte dort möglich sind? komme mir vor wie in der steinzeit:-) danke !

ach ich könnt heuelen, daß ich keine mobile version habe, könnte ich ja noch verschmerzen, aber hat jemand mal auf dem iphone versucht über das kontaktformular eine nachricht zu verfassen ? einfach nur schrecklich, wieso kann man cptcha nicht abschalaten ? jetzt erstelle ich bei 1und1 ein kontaktformular und verlinke im text unter den produkten, das kanns doch aber nicht sein?!?!? hilffeeeeeee !

das Captcha kann man abschalten. Geh einfach in die Konfig und entferne die Farbwerte. cooler Name für das Shopware Forum :sunglasses: :thumbup:

mit capcha meine ich, das man umständliche zahlen und buchstaben eingeben muss, bevor das kontaktformular versendet wird, das würde ich gerne abschalten. was sollen die farbwerte damit zu tun haben, und wo genau soll ich die entfernen vielen dank.

das war kein Witz. Entferne die Farbwerte aus Grundeinstellungen --> Captcha und das Captcha ist weg.

1 Like

Und xtcommerce man merkt gleich das du ein typischer xt-Shopbetreiber bist. Dieses “häää wieso warum bitte macht mir mal schnell alles heil” ist typisch in deren Community. Blos nicht selber nachdenken… :smiley:

vielen dank an kordoradeluxe für den tip , die farbwerte zu löschen hilft nix, eventuell bringt es was beide der 3 er version, bei meiner 4 er nicht. vielen dank an g-dev, nachdenken hilf da allerdings nix, eventuell ein studium in programmierung, also einige dateien im eingeweide des shops müssen wohl verändert werden. froh kann jeder sein, der es kann oder jemanden hat. dann auf weiterhin gute zusammenarbeit!

hi, also das mit der Farbe stimmt aber leider… siehe: https://github.com/ShopwareAG/shopware-4/blob/master/engine/Shopware/Controllers/Frontend/Forms.php#L177 Im Template wird es trotzdem angezeigt nur nicht mehr validiert… blende es doch einfach aus per CSS oder entferne es aus frontend/forms/elements.tpl