Bezahlen über Amazon wirft Fehler aus

Hallo zusammen, habe Bezahlen über Amazon eingerichtet. (SSL Zertifikat läuft). Button wird angezeigt, nach dem Login kommt folgender Fehlercode: Lizenz konnte nicht verifiziert werden "meinedomain.de" in Shopware/Plugins/Community/Frontend/BestitAmazonCBA/Controllers/Frontend/AmazonCBA.php on line 17 Stack trace: #0 Shopware/Plugins/Community/Frontend/BestitAmazonCBA/Controllers/Frontend/AmazonCBA.php(17): Shopware\_Controllers\_Frontend\_AmazonCBA::init() #1 Enlight/Class.php(74): Shopware\_Controllers\_Frontend\_AmazonCBA-\>init() #2 Enlight/Controller/Action.php(91): Enlight\_Class-\>\_\_construct() #3 Enlight/Controller/Dispatcher/Default.php(507): Enlight\_Controller\_Action-\>\_\_construct(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #4 Enlight/Controller/Front.php(214): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #5 Shopware/Components/HttpCache/HttpKernel.php(79): Enlight\_Controller\_Front-\>dispatch() #6 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(434): Shopware\Components\HttpCache\HttpKernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #7 Shopware/Components/HttpCache/AppCache.php(234): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #8 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(403): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #9 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(303): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>fetch(Object(Symfony\Component\HttpFoundation\Request), true) #10 Shopware/Components/HttpCache/AppCache.php(158): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #11 Symfony/Component/HttpKernel/HttpCache/HttpCache.php(192): Shopware\Components\HttpCache\AppCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #12 Shopware/Components/HttpCache/AppCache.php(110): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 Shopware/Bootstrap.php(70): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #14 Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #15 shopware.php(83): Enlight\_Application-\>run() #16 {main} Ich habe alles nach der Anleitung von bestit erstellt. Danke für Eure Hilfe.

Hast du auch ein von Amazon erlaubtes SSL Zerfifikat ? https://payments.amazon.de/help/Bezahle … llback-API IonCubeloader installiert ?

Hm. Ich habe ein „GeoTrust RapidSSL“ Zertifikat. GeoTrust ist aufgeführt, aber das Spezielle RapidSSL nicht. Und IonCubeloader habe ich nicht installiert.

[quote=„dasi“]Hm. Ich habe ein „GeoTrust RapidSSL“ Zertifikat. GeoTrust ist aufgeführt, aber das Spezielle RapidSSL nicht. Und IonCubeloader habe ich nicht installiert.[/quote] Laut dem Plugin muss der Iconcubeloader installiert sein. http://store.shopware.de/bezahlung-paym … n-payments [quote]Hinweis: Für die Nutzung dieses Plugins ist der ionCube Loader erforderlich. Eine Zend Guard / Optimizer Version steht nicht zur Verfügung.[/quote] Das GeoTrust RapidSSL sollte meines Wissens nach funktionieren.

1 Like

Wo finde ich diesen ioncube loader denn? Im Shopware Plugin Bereich habe ich ihn nicht gefunden.

Okay vielen Dank. ioncube Loader 4.5 ist auf meinem Server installiert. :wtf:

Was sagt die systeminfo von shopware?

Auf welche Domain hast Du den Aktivierungsschlüssel ausgestellt? wirklich auf meinedomain.de? Ist die Servervariable $_SERVER[‚SERVER_NAME‘] bei http und https eventuell unterschiedlich? Gruß

[quote=“Martin Weinmayr”]Was sagt die systeminfo von shopware?[/quote] Siehe hier: http://www.bilder-upload.eu/show.php?fi … 046455.jpg @Tonne: Das geht mir gerade zu weit. :oops: Mit der Server Variablen. Bei der Domain habe ich meine für den Post hier ausgetauscht.

Der Hinweis zum IonCube Loader ist nur noch für die Shopware 3.5er Versionen gültig. Das Problem liegt auch nicht im SSL Zertifikat. Hier scheint die best it interne Lizenzierung den Fehler zu verursachen. Da würde ich mal anfragen. Viele Grüße

1 Like

[quote=“Aquatuning GmbH”] Hier scheint die best it interne Lizenzierung den Fehler zu verursachen. Da würde ich mal anfragen.[/quote] Es scheint das hier gar kein Aktivierungsschlüssel hinterlegt wurde. @dasi hast Du auf deinedomain.de ein Aktivierungsschlüssel unter http://activate.bestit-online.de/ beantragt?

[quote=“Tonne”] Es scheint das hier gar kein Aktivierungsschlüssel hinterlegt wurde. @dasi hast Du auf deinedomain.de ein Aktivierungsschlüssel unter http://activate.bestit-online.de/ beantragt?[/quote] Ja diesen habe ich beantragt und auch eingetragen. Dann frage ich vielleicht wirklich mal bei bestit nach.

[quote=“Aquatuning GmbH”]Der Hinweis zum IonCube Loader ist nur noch für die Shopware 3.5er Versionen gültig. Das Problem liegt auch nicht im SSL Zertifikat. Hier scheint die best it interne Lizenzierung den Fehler zu verursachen. Da würde ich mal anfragen. Viele Grüße[/quote] Ganz genau das war der Grund. Ich habe meine Domain mit www. angegeben. Daher funktionierte der Lizenzschlüssel nicht! Besten Dank für Eure Hilfe! Jetzt funktioniert alles tadellos.:wink: :thumbup: :thumbup: :thumbup: