Aufträge nachträglich bearbeiten verursacht Fehlermeldung

Hi Forum,

wenn ich versuche einen Auftrag im Nachhinein zu ändern (Preis, Anzahl oder Artikel hinzufügen) dann bekomme ich immer eine Fehlermeldung.

Fehler

Beim Speichern der Bestellpositionen ist ein Fehler aufgetreten.
The order has been changed in the meantime. To prevent overwriting these changes, saving the order was aborted. Please close the order and re-open it.

Natürlich habe ich die Anweisung schon befolgt und selbiges Probiert (Auftrag schließen und neu öffnen) aber der Fehler kommt trotzdem. Das ganze kommt auch bei jedem Auftrag; Also egal welcher Status usw.

Muss ich den Auftrag irgendwie öffnen oder so? 

Danke euch schonmal für die Hilfe

Welche Shopware-Version nutzt Du? Es gab in einer der letzten Versionen (5.5.2? 5.5.3?) ein solches Problem. Die Bestellung wurde zwar gespeichert, die Meldung erschien aber dennoch. Ist das bei Dir der Fall? Dann könnte ein Update helfen.

Hi @hsoebbing‍

vielen Dank Dir für dein schnelles Feedback! 

Das Update habe ich gleich mal gemacht… Nutze jetzt die aktuellste 5.5.5 (war vorher bei 5.5.1) aber leider ohne Erfolg.

Die Fehlermeldung kommt immernoch…

 

Wird die Bestellung denn trotzdem gespeichert? Check mal ob Dein Webserver, Datenbankserver und Browser die gleiche Zeitzone nutzen, vielleicht gibt es da irgendwo ein Problem.

1 Like

@hsoebbing‍

vielen Dank für dein Feedback.

Habe ein Profi-Host System. Bin da aber leider nicht so fit um herauszufinden wie die Uhrzeit/Zeitzone eingestellt ist. Verändert haben wir aber nichts. Wo genau muss ich denn da schauen? 

Ach ja, die Bestellung wird nicht gespeichert. Also die Fehlermeldung kommt, und dann springt die Zahl die ich vorher geändert habe wieder zurück.

Hi, habt ihr eine Lösung für das Problem finden können? Wir haben das selbe Problem mit Shopware 5.6.9 und können uns das nicht erklären. Die Zeiten und Zeitzonen vom Server und der Datenbank stimmen überein, das kann es also nicht sein. Habt ihr eine Idee?

Hallo,

die Uhrzeit/Zeitzone an Deinem PC stimmt auch ?

Viele Grüße

Hi. Ja die Uhrzeit war auch korrekt.

Ansonsten ggfs. mal eine Testumgebung einrichten und sämtliche Drittanbieter-Plugins, die ggfs. in die Funktion eingreifen, der Reihe nach deaktivieren, wenn Server-Zeit / Zeitzone usw. überall korrekt ist.

Viele Grüße