Artikelbilder werden nicht angezeigt

Hallo zusammen, nach der Installation der neuen Version bin ich dabei neue Artikel anzulegen. Nur leider bekomme ich die hochgeladenen Artikelbilder nicht angezeigt. Ich sehe zwar, dass sie da sind, aber nur mit einem Platzhalter. Hab schon mehrer Formate ausprobiert, leider ohne Erfolg. Vielleicht habe ich ja irgendeine Einstellung übersehen. Wer kann mir helfen? Vielen Dank Gruß Karsten

Hast Du mittlerweile eine Lösung? Habe selbes Problem.

Hallo, wurden die Bilder im Artikel hochgeladen? Wichtig ist, dass die Bilder im passenden Ordner des Mediamanagers gespeichert werden, da dort die benötigten Bildgrößen erstellt werden. Wichtig: Wenn dem Artikel Bilder zugewiesen wurden muss der Artikel gespeichert werden. Ansonsten sind da keine Probleme bekannt und mir fällt keine andere mögliche Fehlerquelle aktuell ein.

Hallo, Hatte vor kurzem das selbe Problem. Gelöst habe ich es dadurch, dass ich die Schreibrechte der Medienordner auf dem Server auf 777 gesetzt habe. Hoffentlich hilft Dir das weiter

Ich habe noch etwas gesucht und den Fehler gefunden. Quelle-Bild: Vespaonline-Aufnäher.jpeg (JPEG !!!) 1. Thumbnails werden erstellt (JPG !!!) -rw-r–r-- 1 www-data www-data 828 4. Sep 19:31 vespaonline-aufn-her_105x105.jpg -rw-r–r-- 1 www-data www-data 940 4. Sep 19:31 vespaonline-aufn-her_140x140.jpg -rw-r–r-- 1 www-data www-data 1696 4. Sep 19:31 vespaonline-aufn-her_285x255.jpg -rw-r–r-- 1 www-data www-data 704 4. Sep 19:31 vespaonline-aufn-her_30x30.jpg -rw-r–r-- 1 www-data www-data 736 4. Sep 19:31 vespaonline-aufn-her_57x57.jpg -rw-r–r-- 1 www-data www-data 6808 4. Sep 19:31 vespaonline-aufn-her_720x600.jpg 2. Der Links auf der Artikelseite ruft jedoch folgende URL auf (JPEG !!!): http://www.dealshop.de/media/image/thum … 0x600.jpeg Er wird versucht das Bild mit Endung .jpeg statt .jpg aufzurufen. Fixed: Quelle-Bild von .jpeg nach .jpg umbenennen und hochladen! Dann funktioniert alles bestens.

Habe das selbe bzw. ähnliches Problem. Im Frontend läuft alles prima (Alles wird normal angezeigt). Im Backend aber: • Es funktionieren die Thumbnails in “Zugewiesene Bilder” im Modul Artikel -> Bilder nicht. Ein Platzhalter (kleines Quadrat mit Fragezeichen) wird angezeigt. Sobald man auf das jeweilige Produktbild klickt wird das Bild rechts in der “großen Vorschau” angezeigt • Im Medienverwaltung kann man keine Bilder erkennen bzw. werden mit einem Platzhalter (gekreuzte diagonale Linien) gekennzeichnet. Sämtliche Bilder sind als .jpg angelegt. Die Schreiberechte auf 777 zu ändern brachte keinen Erfolg. Nach dem Artikel Bilder zugewiesen wurde immmer gespeichert

Gut das Du das erwähnst. Im Backend verhält es sich bei mir ebenso.

Gleiches Problem: Vor dem Upload die Datei *.jpeg in *.jpg umbenennen. Scheinbar kommt Schopware auch nicht mit allen Bilddaten klar. Ein Bild ging einfach nicht mehr (schwarzer Block), wenn es von Shopware in eine andere Größe konvertiert wird.

Bei mir gleiches Problem. Habe die Bilder als jpg in der Medienverwaltung unter Artikel hochgeladen. Diese werden im Shop leider nicht angezeigt, nur der Platzhalter selbst. Im Backend werden diese aber angezeigt. Benutze zZ noch eine Demoversion von Shopware, bin aber schon erstaunt wie toll das System ist :slight_smile: Leider werden die Bilder nicht angezeigt. Habe auch schon alles möglich probiert. 1. Die Dateien benutzen keine Sonderzeichen, sind klein geschrieben und enden mit .jpg 2. Alle Rechte des Medien Ordners auf 777 gestellt 3. Bild wurde unter Inhalte-> Medienverwaltung-> Album „Artikel“ hochgeladen. Wie gesagt im Backend alles wunderbar, nur im Shop wird das Vorschaubild nicht angezeigt :frowning: Liegt es vielleicht an der Bildgröße von 403x403 Pixeln? Kann wer helfen?

gerade ein ähnliches Problem gehabt. Bilder im PNG-Format werden jetzt jedoch angezeigt.

ich habe shopware 4.3 und ich habe das gleiche Problem!! gibt es da eine Lösung?

Ja bitte, ich habe dasselbe Problem. Ich kann die Bilder nur sehen wenn ich die vierspaltige Variation auswähle. Wenn ich aber gerne die zweispaltige Ansicht möchte, dann gibts nur Platzhalter :frowning:

Hallo, vieleicht ein Tipp von mir. Bei mir lag es im Zusammenhang mit dem Theme von Conexco, wenn man da das Adaptive-Images tritt genau das auf. # SwfResponsive Template #### # Adaptive-Images ----------------------------------------------------------------------------------- # Add any directories you wish to omit from the Adaptive-Images process on a new line # RewriteCond %{REQUEST_URI} !some-directory # RewriteCond %{REQUEST_URI} !another-directory RewriteCond %{REQUEST_URI} !assets # Send any GIF, JPG, or PNG request that IS NOT stored inside one of the above directories # to adaptive-images.php so we can select appropriately sized versions RewriteRule .(?:jpe?g|gif|png)$ adaptive-images.php # END Adaptive-Images -------------------------------------------------------------------------------

Wir haben das gleiche Problem. Gestern die neuste Shopwareversion 5.0.2 installiert, wir sehen keine Bilder im Backend. JPG / JPEG / PNG spielen keine Rolle, wir haben einen anderen Shop, der genau das machen kann. haben es eben getestet, auch ohne 777 Berechtigung. Wo ist der Fehler liebes Shopware TEam? Das ist ein Bug seid der Version 4.2 und irgendwann müsst ihr das ja mal beheben können!? Ist doch nicht so schwer

Hier genau das selbe Problem … Shopware 5.0.2 :frowning: PS: Hier ist meine Fehlersuche Dokumentiert … installation-einstieg-f99/shopware-5-0-2-artikelbilder-komisch-t30403.html

Gibt es hier Neugikeiten? Habe genau das gleiche Problem!

Ich habe das gleiche Problem -> im Backend keine Thumbnails… Scheint ein echter Käfer zu sein :wink: Also, sehr geehrtes Shopware team, gibt’s ne Lösung CE;5.04 Danke

Hallo zusammen, im Standard kennen wir das Verhalten so nicht. Wie oben schon geschrieben, tippe ich auch auf Anpassungen. Also z.B. in der .htaccess Datei. Ihr könnt ja den Pfad per Firebug prüfen. Evtl. wird der falsch zusammengebaut. Man bräuchte da detailliertere Infos zur Installation. Ist die htaccess komplett Standard? Ist Shopware in einem Unterordner installiert? Sebastian

Standard /xxx/bin/… /cache/… /engine/… usw. .htaccess: [i]
RewriteEngine on
RewriteBase /
RewriteRule ^(.*).html$ test/index.html

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews #php_flag session.auto_start off #php_flag suhosin.session.cryptua off #php_flag zend.ze1_compatibility_mode Off AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php # Staging-Rules start #SetEnvIf Host „staging.test.shopware.in“ ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration
Deny from all
# Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json


ExpiresActive on
ExpiresDefault „access plus 1 month“
FileETag None

Header append Cache-Control „public“
Header unset ETag


# Disables auto directory index
Options -Indexes

Options -MultiViews
[/i]

Hallo, schau mal genau ob du diese Zeile hast: https://github.com/shopware/shopware/bl … access#L12 Die ist für die Anzeige der Bilder im Backend. Wenn du einen Ngix hast, muss das natürlich per Ngix-Regel umgesetzt werden. Moritz

1 Like