Artikel/ Kategorien importieren

Guten Tag, ich versuche mich in der eingerichteten Shopdemo und versuche Artikel und Kategorien zu importieren. Ich habe hierzu als erstes das Jeweilige exportiert und die Dateien angepasst. Leider klappt aber nichts. Ich erhalte die Meldung: “Es konnten keine Daten zum Importieren ausgelesen werden.” Mittlerweile habe ich hier gelesen, dass man keine leeren Spalten importieren kann. Ok, das habe ich zusätzlich berücksichtigt. Trotzdem klappt es nicht. Kann es sein, dass man in der Demo nichts echt testen kann? Oder muss ich die CSV-Datei erxtraeinrichten (semikolon, komma,) Danke für Tipps Andreas

In einer normalen Demo kann auf jeden Fall alles auch real getestet werden, hier gibt es bei den Importen und Exporten keine Einschränkungen. Mir ist jetzt noch nicht ganz klar, in welchem Format die Daten excportiert wurden und in welchem Format diese wieder importiert werden sollen. Bei CSV ist auf jeden Fall darauf zu achten, dass Semikolon als Trennzeichen verwendet wird und die Datei auch immer explizit Trennzeichen-getrennt gespeichert wird vor dem Import (z.B. mit Excel). Pflichtfelder sind auch zu beachten. Evtl. hilft ja schon dieser Artikel: http://www.shopware.de/wiki/Import-Expo … l_480.html Ist das denn eine normale Demo oder eine FTP-Umgebung? Bei einer FTP-Umgebung gibt es aktuell Einschränkungen…

Hi, um zu schauen welche Felder benötigt werden, einfach eine Beispiel CSV aus Shopware exportieren. Dies kann man darüber darstellen, indem man ein Test-Artikel anlegt und schaut welche Spalten dort für was stehen. Im Umkehrschluss schauen Sie sich Ihre CSV an und schauen welche Kopfzeile für was steht und mit copy & paste einfach einfügen. Wenn Sie damit nicht weiter kommen, laden Sie doch mal Ihre bearbeitete CSV hoch, um zu schauen wo das Problem liegt. Alternativ einfach nach dem Wiki-Link handeln :wink: Gruß

Ich danke für die schnellen Antworten. Ich habe mir ja auch gedacht, dass das Importieren auch in der Demo klappen sollte. Trotzdem hilft mir das leider nicht. Also ich habe die Kategorien und die Artikel aus dem Demoshop exportiert. Ich finde das gut so, dass man das machen kann, so stellt sich ja automatisch eine Vorlage dar… Ich habe dann alles mit OpenOffice bearbeitet. (Ich arbeite sonst mit Mac und da klappt es mit OO am besten.) Trennzeichen Semikolon und Txttrenner ("), alles als CSV-Datei mit Zeichensatz UTF-8 gespeichert… Das dürfte ja eigentlich so richtig sein… Da ja auch (und das gefällt mir gut) alles sehr gut dokumentiert ist, dachte ich nicht, dass das so schwierig sein kann… Der Artikelexport, also die „Testdatei“, lässt sich wieder importieren. Da sitzt sicher der Fehler wieder vor dem Rechner, nur welchen Fehler mache ich? Gruß Andreas

Hi, achte darauf in welchem Format du das speicherst. Oft kann es vorkommen, das wenn du aus Openoffice Daten abspeicherst es eine Konvertierung hat. Probiere sie in dem Format für Windows zu konvertieren. Gruß Edit: Versuch einfach einmal einen weiteren Test-Artikel über den Import hochzuladen, jedoch nutze nur die wichtigsten Felder. Noch eine Frage btw: Steht das der Durchlauf des Import erfolgreich abgeschlossen ist?

Also jetzt klappt es. Ich habe es nun doch noch einmal mit Excel versucht und als CSV/ Windows gespeichert, das klappt dann hervorragend. Also Danke für den Hinweis. beachten muss man eben die Art zu speichern und tatsächlich, alle Spalten zu löschen, in denen nichts drin steht. Gruß Andreas

Eine Frage muss ich aber nun doch noch stellen: Wie bekomme ich unsere Umlaute richtig eingepflegt. Ich dachte durch UTF-8 klappt das… Gruß Andreas

Hi, ich weiß nicht ob dich das weiter bringt, aber denke schon :wink: http://jendryschik.de/wsdev/einfuehrung … nkodierung Alternativ gibt es doch bei Excel noch die Option, das man ersetzen kann. Probiere es einfach dort mit falls es nicht mit der anderen Kodierung klappt. gruß edit: kurz und knapp ISO-8859-1 statt UTF-8

1 Like

Vielen Dank erst einmal. Vielleicht stelle ich mich ja auch umständlich an, aber ich finde in Excel keine Möglichkeit, Zeichensätze wie ISO-8859-1 zu hinterlegen. Wenn ich aber mit Textwrangler oder eben einem Texteditor das mache, klappts schon. Beste Grüße

Hi, ich meinte auch nicht die Zeichenkodierung sondern die Umlaute kann man einfach ersetzen lassen. Demnach bräuchte man doch nur beispielsweise ß durch ß ersetzen für die ganze CSV. Aber wenn dieses nun funktioniert, kann man ja nicht meckern :). Gruß!

Also hier noch einmal eine Antwort, um das Thema zu beenden. Es ist wie oft eine Änderung der Denkweise nötig. Meine Artikeldatei erstelle ich nun generell in Excel. Diese Datei wird als “Mutterdatei” gepflegt und gespeichert. Will ich nun neue Artikel einpflegen oder alte ändern, bearbeite ich sie in Excel, spiechere sie dort, und exportiere/speichere sie anschließend in eine “import”-csv-Datei. Dann gibt es kein Problem mit Zeichensätzen usw. Das Csv-Format ist dann csv(windows). Ich hoffe, das hilft auch anderen. Gruß

Das stimmt so nicht ganz. Die Shopware “frisst” auch csv-Dateien ohne Trennzeichen, es reicht wenn die Daten in getrennten Feldern stehen. Aber OpenOffice und Excel sind leider nicht ganz ohne Bugs, OpenOffice “verschluckt” beispielsweise in der aktuellen Version gerne mal Umlaute oder kann etwa in Formeln nichts mit Sonderzeichen anfangen. Ältere Excel-Versionen (vor 2007) verhalten sich übrigens ähnlich, das musste ich leider schon feststellen :wink: Bei Excel ist ausserdem unbedingt darauf zu achten dass erst beim finalen Schritt als csv gespeichert wird. Bis dahin unbedingt immer mit xls oder xlsx arbeiten! Speichert man bereits bei den Zwischenschritten als csv kodiert Excel teilweise die Zeichen falsch. [quote=“Stefan Heyne”]In einer normalen Demo kann auf jeden Fall alles auch real getestet werden, hier gibt es bei den Importen und Exporten keine Einschränkungen. Mir ist jetzt noch nicht ganz klar, in welchem Format die Daten excportiert wurden und in welchem Format diese wieder importiert werden sollen. Bei CSV ist auf jeden Fall darauf zu achten, dass Semikolon als Trennzeichen verwendet wird und die Datei auch immer explizit Trennzeichen-getrennt gespeichert wird vor dem Import (z.B. mit Excel). Pflichtfelder sind auch zu beachten. Evtl. hilft ja schon dieser Artikel: http://www.shopware.de/wiki/Import-Expo … l_480.html Ist das denn eine normale Demo oder eine FTP-Umgebung? Bei einer FTP-Umgebung gibt es aktuell Einschränkungen…[/quote]

Ich importiere meine Artikel auch via csv und habe ein Problem mit diesem Zeichen:  Zu sehen hier: http://www.mein-lernspielzeug.de/Motori … _3071.html Wie kann ich das entfernen???