503 Unavilable - Newsletter Plugin

Seit heute bekommen wir eine lange Fehlermeldung beim öffnen des Newsletter Tools. Es werden keine alten Kampagnen mehr angezeit und es können keine neuen Newsletter mehr erstellt werden. Sobald wir auf speichern klicken poppt die Meldung erneut auf. Siehe Anhang für Screenshot. Vielen Dank für Eure Hilfe.

Hallo, habe dir bereits hier geantwortet: administration-f55/intelligenter-newsletter-dicke-fehlermeldung-t25018.html#p137383 Grüße Moritz

1 Like

Hallo Mortiz, danke für Deine Antwort! Unser Hoster (HostEurope) sagte mir, dass die Variablen nur per session von uns angepasst werden können und nicht Global. Die Variable bliebt dann solange eine Verbindung mit der Datenbank herrscht aktiv. Ich habe nun Set Sql_big_selects = 1 ausgeführt und dieser Befehl wurde auch so angenommen und bestätigt. Leider kommt jedoch immernoch die Fehlermeldung wie vorher. Kannst Du dir das vielleicht mal anschauen? Viele Grüße!

Jemand ne Idee? Wir haben den ganzen Tag versucht das Problem zu beheben, ohne Erfolg … Hosteurope erlaubt keine gloablen Änderungen. Wir haben versucht die config-php anzupassen, sodass SET SQL_BIG_SELECTS=1 beim laden. Jedoch lädt dann weder das Backend noch der Shop. Es muss da doch irgendwie eine Lösung geben? Hier die Antwort von HostEurope: Wie die Fehlermeldung bereits aussagt, versucht hier ein MySQL-Query mehr Reihen zu durchsuchen, als in “MAX_JOIN_SIZE” definiert ist. Um zu vermeiden das unsere Shared-Hosting-Pakete durch zu schlecht optimierte MySQL-SELECTs überlastet werden, können wir den Wert der MAX_JOIN_SIZE auch nicht erhöhen. In diesem Fall müssten Sie also einfach die SELECTs optimieren. Dies kann zum Beispiel durch das setzen sinnvoller Indizes in der Datenbank erreicht werden. Nähere Informationen hierüber finden Sie unter dem folgenden Link: http://dev.mysql.com/doc/refman/5.6/en/ … speed.html Eine weitere Möglichkeit wäre es, die SQL_BIG_SELECTS zu aktivieren. Hierbei handelt es sich um eine Session-Variable, die beim Verbindungsaufbau _einmalig_ gesetzt werden muss. Diese gilt dann für diese eine Verbindung zur Datenbank, bis diese wieder beendet wird. Innerhalb dieser Verbindung würde MAX_JOIN_SIZE dann auch nicht mehr beachtet werden. http://dev.mysql.com/doc/refman/5.6/en/ … ig_selects Die SQL_BIG_SELECTS sind bei uns Standardmäßig deaktiviert. Die Aktivierung muss wie oben beschrieben über Ihr Skript erfolgen.

Hallo, probiere mal folgende Code in deiner config.php Der Abschnitt mit driver_options ist neu: 'db' =\> array( 'username' =\> 'USERNAME', 'password' =\> 'PASSWORD', 'dbname' =\> 'DATABASE', 'host' =\> 'localhost', 'charset' =\> null, 'driver\_options' =\> array( PDO::MYSQL\_ATTR\_INIT\_COMMAND =\> "SET NAMES 'utf8'; SET SESSION SQL\_BIG\_SELECTS=1" ), ) Das wäre die letzte Möglichkeit die ich so sehe, dass auf deiner Umgebung hinzubekommen. Ansonsten brauchst du ein Hostingpaket, was dir das ermöglicht. Sonst rennst du ggf. immer wieder in diese Problematik. Im schlimmsten Falle auch im Frontend. Das ist hier ja ein altbekanntes Thema. Sebastian PS: Habe diesen alten Artikel noch einmal reaktiviert http://community.shopware.com/_detail_785_712.html Da ist noch ein Beispiel für die driver_options (Anweisung)

Hi Sebastian, danke für Deine Antwort. Ich habe die Zeile "driver_options’ => array( PDO::MYSQL_ATTR_INIT_COMMAND => „SET NAMES ‚utf8‘; SET SESSION SQL_BIG_SELECTS=1“ in meine config.php eingefügt, doch dann lädt mein Backend und Shop nicht mehr. So sieht die config aus: <?php return array (
‚db‘ => array ( ‚host‘ => ‚localhost‘, ‚port‘ => ‚3306‘, ‚username‘ => ‚XXX‘, ‚password‘ => ‚XXX‘, ‚dbname‘ => ‚XXX‘, ‚driver_options‘ => array( PDO::MYSQL_ATTR_INIT_COMMAND => „SET NAMES ‚utf8‘; SET SESSION SQL_BIG_SELECTS=1“ ), );

Hallo, und was passiert, wenn du das wie in dem alten Doku-Artikel einbaust? 'driver\_options' =\> array( PDO::MYSQL\_ATTR\_INIT\_COMMAND =\> 'SET SESSION SQL\_BIG\_SELECTS=1;', PDO::MYSQL\_ATTR\_USE\_BUFFERED\_QUERY =\> true ) Sebastian

Wenn ich wie Du sagst: ‚driver_options‘ => array( PDO::MYSQL_ATTR_INIT_COMMAND => ‚SET SESSION SQL_BIG_SELECTS=1;‘, PDO::MYSQL_ATTR_USE_BUFFERED_QUERY => true einbaue, dann ist der lädt ebenfalls weder Backend, noch Shop. Funktioniert bei Euch denn der Einbau der „driver options“ ? Danke für die Hilfe!

Ich will nicht nerven, aber gibt es noch irgendeine Möglichkeit für uns? Sonst wechseln wir den Hoster, da wir den Newsletter dringed brauchen. Besten Dank!