404 Fehlermeldung

Moin ihr lieben!
Ich habe in meiner alten Firma viel mit Shopware 5 gearbeitet & auch die Installation von einem Shop miterlebt. Leider hilft mir das nicht so wirklich mit Shopware 6 & hoffe, ihr könnt mir ein wenig helfen. Ansonsten versuche ich mich doch lieber nochmal an der 5er Version :wink:

Bei mehreren Installationen von Shopware 6 habe ich schon ziemlich viele Fehler durch - es mag einfach nicht klappen.
Der aktuelle ist:
„Not Found
The requested URL was not found on this server.
Apache Server at jepoplastgmbh.de Port 80“

Einstellungen, die ich vorher beim Webspace-Anbieter gemacht habe, sind:

  • Domain weiterleitung auf Unterverzeichnis + /public
  • .htaccess geändert in



ServerName Hostname

DocumentRoot Unterverzeichnis + /public

 

Options Indexes FollowSymLinks MultiViews

AllowOverride All

Order allow,deny

allow from all

 ErrorLog {APACHE\_LOG\_DIR}/shopware-platform.error.log  CustomLog {APACHE_LOG_DIR}/shopware-platform.access.log combined
 LogLevel debug

Erstellung einer MySQL Datenbank

Sowohl beim Aufrufen von der normalen URL, als auch bei /recovery/install/ wird der oben geschriebene Fehler angezeigt. Ich fühle mich wieder wie ein blutiger Anfänger, aber hoffentlich kann einer von euch da helfen :wink:

Welchen Hoster verwendest du? Kannst du dich via ssh auf den Server einloggen?

Erstelle doch erstmal eine Php-Testdatei und probiere ob du diese zu laufen bekommst.

Dann holst du mit wget shopware6, mit unzip entpacken, DB-anlegen, URL-aufrufen fertig.

 

Die Domain selbst darf nicht weitergeleitet werden auf /public; Nur aufs Unter-/Haupt-verzeichnis dort wo der Shop liegt.

Der Dokumentenstamm muss auf /public zeigen.

Vielen Dank für eure Antworten! =)
@Kulli:Habe die Weiterleitung nun nur auf das Unterverzeichnis gesetzt. 

@Ciatronical: Wir sind bei Alfahositng. Auf SSH kann ich mich anmelden - allerdings habe ich damit tatsächlich noch nie gearbeitet, bin eher bei ftp. wget habe ich vermieden, indem ich das entpacken direkt auf C:\ gemacht habe - dann sind die Dateinamen auch nicht zu lang :wink: Die htaccess habe ich zurückgeändert in diei Standart Version.

Trotzdem ändert das nichts an dem Fehler. Hm, mal weiter puzzeln…

Ist denn mod_rewrite auf dem Server aktiv ?

Wo genau liegt denn die oben genannte .htaccess ? Im Basis-Verzeichnis ?
Im Stamm-(DocumetRoot- httpdocs - etc- ) Verzeichnis der Domain darf sie nicht liegen, dort liegt die htaccess von Shopware.

Die Begriffe was Stamm- Basis- DocumentRoot- undsoweiter Verzeichnisse sind, sind für uns ja oft verwirrend…

 

Ansonsten kann ich mir bei der Fehlermeldung nur noch vorstellen, dass die Domain gar nicht routet, d.h. die DNS nicht richtig konfiguriert sind

1 Like

Jup, mod_rewrite ist aktiv.
Die .htaccess liegt im public Ordner, die habe ich nicht verschoben und ist jetzt auch unverändert & original. War nur ein Versuch, weil das in einer anderen Fragestellung erwähnt wurde. Okay, ich hatte tatsächlich die Weiterleitung bei Alfahosting falsch angelegt - html vorne war nicht benötigt.
Jetzt habe ich aber den Fehler „Forbidden You don’t have permission to access this resource.“ Ordner Berechtigungen liegen aber bei 755, Dateien bei 644

die htacccess im /public wird von shopware angelegt. Original ist die aber nicht…wenn es die im ersten post ist ?

Nein, habe die oben stehende gelöscht (war ja nur ein Versuch aus einer anderen Fragestellung) & wieder die Originale aufgespielt im /public Ordner:

DirectoryIndex index.php



Options -MultiViews



RewriteEngine On

    RewriteCond %{REQUEST_URI}::1 ^(/.+)/(.\*)::\2
    RewriteRule ^(.*) - [E=BASE:%1]

    # Sets the HTTP_AUTHORIZATION header removed by Apache
    RewriteCond %{HTTP:Authorization} .
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{ENV:REDIRECT_STATUS} ^     RewriteRule ^index\.php(?:/(.\*)|) %{ENV:BASE}/$1 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^ - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule ^ %{ENV:BASE}/index.php [L]





RedirectMatch 302 ^/$ /index.php/



Und das steht bei Dir alles ohne Bedingungen drin ? (<if…>

Dann weis ich auch net weiter...Von vorne anfangen - Vorraussetzungen prüfen etc.