admin was not found - direkt nach der

Guten Abend liebes Forum,

Ich bin gerade dabei eine SW6 Testumgebung aufzubauen und hab das gleiche Problem wie hier: https://forum.shopware.com/discussion/62194/admin-was-not-found-direkt-nach-der-installation

Leider hilft mir der Teil nicht weiter. In meiner SW5 Installation ist zwar eine htaccess drin aber nicht in meiner SW6 installation. 

muss ich das mod_rewirte in dem sw5 aktivieren? Ich versteh es nicht ganz bin leider auch noch kein Experte auf diesem Gebiet. 

Wär cool wenn mir jemand dabei ein bisschen weiterhelfen kann. 

 

Liebe Grüße Lukas

Hat niemand eine Idee komm gerade nicht weiter.

https://docs.shopware.com/de/shopware-6-de/erste-schritte/shopware-6-installieren?category=shopware-6-de/erste-schritte

@kulli schrieb:

https://docs.shopware.com/de/shopware-6-de/erste-schritte/shopware-6-installieren?category=shopware-6-de/erste-schritte

Danke schonmal für die Antwort! muss ich die htaccess in dem SW6 Ordner anpassen? Weil bei mir find ich dort keine?  

Okay ich kann eine htaccess bei meinem Hoster konfigurieren. Jedoch steht in meinen SW6 installation nichts drin. Muss man dort das reinschreiben? https://docs.shopware.com/de/shopware-6-de/erste-schritte/shopware-6-installieren?category=shopware-6-de/erste-schritte 

 

Sorry für die Fragen :wink: bin noch ziemlich neu in dem Bereich. 

Eigentlich muss man gar nichts irgendwo reinschreiben.

Dateien hochladen (besser direkt auf dem Server entpacken) und los gehts. (Sollte ! gehen)

Wichtig ist, dass Die aufgerufene Installations-Domain beim Hoster auf /public zeigt.

Wenn alles richtig gelaufen ist, ist im Hauptverzeichnis keine htaccess, die eigentliche htaccess ist im Ordner /public

DirectoryIndex index.php


    Options -MultiViews



    RewriteEngine On

    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
    RewriteRule ^(.*) - [E=BASE:%1]

    # Sets the HTTP_AUTHORIZATION header removed by Apache
    RewriteCond %{HTTP:Authorization} .
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^ - [L]

    # Rewrite all other queries to the front controller.
    RewriteRule ^ %{ENV:BASE}/index.php [L]



    
        RedirectMatch 302 ^/$ /index.php/

 

1 Like

@kulli schrieb:

Eigentlich muss man gar nichts irgendwo reinschreiben.

Dateien hochladen (besser direkt auf dem Server entpacken) und los gehts. (Sollte ! gehen)

Wichtig ist, dass Die aufgerufene Installations-Domain beim Hoster auf /public zeigt.

Wenn alles richtig gelaufen ist, ist im Hauptverzeichnis keine htaccess, die eigentliche htaccess ist im Ordner /public

DirectoryIndex index.php

Options -MultiViews

RewriteEngine On

RewriteCond %{REQUEST_URI}::1 ^(/.+)/(.*)::\2
RewriteRule ^(.*) - [E=BASE:%1]

Sets the HTTP_AUTHORIZATION header removed by Apache

RewriteCond %{HTTP:Authorization} .
RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{ENV:REDIRECT_STATUS} ^ RewriteRule ^index\.php(?:/(.*)|) %{ENV:BASE}/$1 [R=301,L]

If the requested filename exists, simply serve it.

We only want to let Apache serve files and not directories.

RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^ - [L]

Rewrite all other queries to the front controller.

RewriteRule ^ %{ENV:BASE}/index.php [L]

RedirectMatch 302 ^/$ /index.php/

 

Vielen Dank! das hat super geklappt! ich hab eine neue .htaccess Datei in dm public ordner erstellt und jetzt geht es! 

Nur das Frontend wird noch ohne styles angezeigt. :/ 

Hallo,
ich habe leider das gleiche Problem. Habe Shopware 6 lokal auf einem Windows-Rechner schon länger laufen und wollte das System nun remote auf einem Linux-Server installieren. Habe die Installations-Dateien in Document Root kopiert und konnte das System auch installieren. Im letzten Schritt wird der admin aufgerufen, aber nicht gefunden. Das Frontend ist aufrufbar, aber ohne CSS.
Zudem ist das Apache Modul mod_rewrite aktiv und die .htaccess ist korrekt und liegt im /public-Ordner.
Muss die DocumentRoot des Servers evtl. direkt auf /public zeigen? Oder fehlt noch was?

1 Like

Nun funktioniert’s. Musste noch die Konfiguration des VirtualHost anpassen. Statt wie in der Beschreibung

 <Directory _SHOPWARE_DIR_> 
  Options Indexes FollowSymLinks MultiViews 
  AllowOverride All 
  Order allow,deny 
  allow from all 
 </Directory> 

funktioniert’s mit

 <Directory _SHOPWARE_DIR_> 
  Options Indexes FollowSymLinks MultiViews 
  AllowOverride All 
  Require all granted
 </Directory> 

Da hat sich bei der Version 2.4 des Apache scheinbar was geändert. Ist allerdings nicht so mein Thema.
Im Backend wurde ich dann noch genötigt, eine Domain zu verfizieren. Da es sich bei der Installation um eine interne Spielwiese handelt, die nie veröffentlicht werden soll, hat das etwas genervt. Irgenwann war dann auch diese Abfrage verwschwunden, warum auch immer. Sehr verwirrend.

Aber nun geht’s :slight_smile: