/admin was not found - direkt nach der Installation

Guten Tag zusammen,

ich versuche mich gerade zum ersten Mal an Shopware und habe leider direkt nach der Installation mit dem ersten Problem zu kämpfen.
Nach dem ausfüllen der Shopinformationen, wurde ich auf http://MEINSHOP.de/admin weitergeleitet - dort bekomme ich aber folgenden Fehler:

Not Found

The requested URL /admin was not found on this server.

Apache/2.4.29 (Ubuntu) Server at MEINSERVER.stratoserver.net Port 80

Was kann ich da tun? Bin etwas ratlos gerade.

 

Liebe Grüße!

mod_rewrite aktiv?

An welcher Stelle muss ich das aktivieren? Hatte das in der PHP.ini nicht gefunden.
(Sorry, bin leider nur Laie auf dem Gebiet … :X)

Am besten mal den Hoster fragen.  Das ist je nach Hosting unterschiedlich.

Laut FAQ von Strato muss ich die Geschichte in der .htaccess aktivieren - das ist aber bereits der Fall. 
Soll ich es aktivieren oder geht es darum, dass es deaktiviert werden sollte?

Es muss aktiv sein. Dann funktioniert es aber auch 

Habe sehr viel herumprobiert und bin mit jedem Schritt mehr verwirrt. 
Habe erst mal eine PHPinfo Seite erstellt, um zu überprüfen ob das Modul aktiviert wurde. Als ich es dort nicht auffinden konnte habe ich weiterrecherchiert und bin auf den Befehl sudo a2enmod rewrite gestoßen - nach Anwendung wurde das Modul angeblich aktiviert und folgendes kommt wenn ich den Befehl erneut benutze
 

sudo a2enmod rewrite
Module rewrite already enabled
 

Allerdings finde ich in der phpinfo file immer noch keinen Punkt der darauf deuten könnte, dass mod_rewrite aktiv sein könnte. Der Befehl behauptet ja das Gegenteil.
Ich habe auch bereits eine Mail an Strato geschickt, ob man abseits von .htaccess oder dem Befehl oben etwas aktivieren muss, warte da allerdings gerade vergeblich auf eine Antwort.

Andere Sache auf die ich gestoßen bin, ist die  virtual hosts configuration file. Benutzt Shopware so etwas? Wenn ja, wo kann ich diese Datei ändern bzw. nachsehen ob der Punkt „AllowOverride All“ aktiv ist? 
Mit den Infos, die ich gefunden habe, konnte ich allerdings gar nichts anfangen und weiß auch nicht so recht was ich nun noch machen soll…

Die VHost Konfiguration hat nichts mit Shopware zu tun, sondern wird auf dem Server hinterlegt. Da kommst du nicht bei jedem Hosting dran.

Ich habe dasselbe Problem, außerdem ist bei mir die Startseite kaputtl es sieht so aus, als würde überhaupt kein CSS geladen werden. mod_rewrite ist aber laud testpage aktiv, also keine Ahnung was da schiefgelaufen ist.

Early Access ist das noch keine sondern eher eine gerade gepflanzte Software :confused: -.-

@m0rtis schrieb:

Ich habe dasselbe Problem, außerdem ist bei mir die Startseite kaputtl es sieht so aus, als würde überhaupt kein CSS geladen werden. mod_rewrite ist aber laud testpage aktiv, also keine Ahnung was da schiefgelaufen ist.

Hast du eine Lösung finden können. 
Habe bei mir das selbe Verhalten… 

@sawden‍

Vielleicht helfen dir folgende links:

https://forum.shopware.com/discussion/comment/276908/

https://forum.shopware.com/discussion/comment/276912/

1 Like

Habe einen Fehler beim Pfad in der Virtual Host Konfiguration gehabt. Läuft jetzt wie gewünscht!  Thumb-Up
 

und welchen Fehler hattest du? Ich hab das selbe Problem, dass /admin nicht geht und im Frontend kein Template geladen wird. Hier meine config (ist eine lokale Testumgebung auf Port 81):

<VirtualHost *:81>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html/shopware6/public

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

Habs hiermit behoben. Admin geht dann, im Frontend wird aber immernoch kein CSS geladen:

<VirtualHost *:81>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html/shopware6/public

        <Directory /var/www/html/shopware6>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

Und das Problem konnte ich hiermit dann auch lösen: Theme konnte dem Verkaufskanal nicht zugewiesen werden

ich frage mich nur, wozu die Überprüfung der Rechte wärend der Installation gut ist, wenn am Ende bestimmte Dateien nicht abgefragt werden.