doolindoolin MemberComments: 3 Received thanks: 0 Member since: August 10

Guten Tag zusammen,

ich versuche mich gerade zum ersten Mal an Shopware und habe leider direkt nach der Installation mit dem ersten Problem zu kämpfen.
Nach dem ausfüllen der Shopinformationen, wurde ich auf http://MEINSHOP.de/admin weitergeleitet - dort bekomme ich aber folgenden Fehler:

Not Found

The requested URL /admin was not found on this server.

Apache/2.4.29 (Ubuntu) Server at MEINSERVER.stratoserver.net Port 80

Was kann ich da tun? Bin etwas ratlos gerade.

 

Liebe Grüße!

Answers

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7827 Received thanks: 2290 Member since: September 2013

    mod_rewrite aktiv?

  • doolindoolin MemberComments: 3 Received thanks: 0 Member since: August 10

    An welcher Stelle muss ich das aktivieren? Hatte das in der PHP.ini nicht gefunden.
    (Sorry, bin leider nur Laie auf dem Gebiet .. :X)

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7827 Received thanks: 2290 Member since: September 2013

    Am besten mal den Hoster fragen.  Das ist je nach Hosting unterschiedlich.

  • doolindoolin MemberComments: 3 Received thanks: 0 edited August 10 Member since: August 10

    Laut FAQ von Strato muss ich die Geschichte in der .htaccess aktivieren - das ist aber bereits der Fall. 
    Soll ich es aktivieren oder geht es darum, dass es deaktiviert werden sollte?

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7827 Received thanks: 2290 Member since: September 2013

    Es muss aktiv sein. Dann funktioniert es aber auch 

  • doolindoolin MemberComments: 3 Received thanks: 0 edited August 10 Member since: August 10

    Habe sehr viel herumprobiert und bin mit jedem Schritt mehr verwirrt. 
    Habe erst mal eine PHPinfo Seite erstellt, um zu überprüfen ob das Modul aktiviert wurde. Als ich es dort nicht auffinden konnte habe ich weiterrecherchiert und bin auf den Befehl sudo a2enmod rewrite gestoßen - nach Anwendung wurde das Modul angeblich aktiviert und folgendes kommt wenn ich den Befehl erneut benutze
     

    sudo a2enmod rewrite
    Module rewrite already enabled
     

    Allerdings finde ich in der phpinfo file immer noch keinen Punkt der darauf deuten könnte, dass mod_rewrite aktiv sein könnte. Der Befehl behauptet ja das Gegenteil.
    Ich habe auch bereits eine Mail an Strato geschickt, ob man abseits von .htaccess oder dem Befehl oben etwas aktivieren muss, warte da allerdings gerade vergeblich auf eine Antwort.

    Andere Sache auf die ich gestoßen bin, ist die virtual hosts configuration file. Benutzt Shopware so etwas? Wenn ja, wo kann ich diese Datei ändern bzw. nachsehen ob der Punkt "AllowOverride All" aktiv ist? 
    Mit den Infos, die ich gefunden habe, konnte ich allerdings gar nichts anfangen und weiß auch nicht so recht was ich nun noch machen soll..

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7827 Received thanks: 2290 Member since: September 2013

    Die VHost Konfiguration hat nichts mit Shopware zu tun, sondern wird auf dem Server hinterlegt. Da kommst du nicht bei jedem Hosting dran.

  • m0rtism0rtis MemberComments: 1 Received thanks: 0 Member since: August 15

    Ich habe dasselbe Problem, außerdem ist bei mir die Startseite kaputtl es sieht so aus, als würde überhaupt kein CSS geladen werden. mod_rewrite ist aber laud testpage aktiv, also keine Ahnung was da schiefgelaufen ist.

  • PhihucamPhihucam MemberComments: 9 Received thanks: 0 Member since: July 24

    Early Access ist das noch keine sondern eher eine gerade gepflanzte Software :/ -.-

Sign In or Register to comment.