erdbeerdropserdbeerdrops MemberComments: 14 Received thanks: 1 Member since: August 2018

Hallo Alle zusammen,

ich brauche für meinen Shop eigene Versandregeln.. kurze Schilderung der Situation:

Artikel aus Kategorie A brauchen Versand A
Artikel aus Kategorie B brauchen Versand B
Beide Artikel im Warenkorb brauchen Versand C

Versand A konnte ich aus Kategorie B mit Hilfe des Shopeigenen Auschlußverfahrens ausschließen, ebenso Versand B aus Kategorie A, sind beide Artikel drinne, wird auf Versand C ausgewichen. das ist korrekt!

nun ist ein Problem, wenn Artikel A und B im Warenkorb lagen und einer davon wird entfernt, springt es nicht automatisch zurück zu den jeweils korrekten Versandkosten, es bleibt bei den höheren Versandkosten C. Man hat dann zwar die Wahlmöglichkeit, aber es sieht einfach doof aus, wenn erstmal utopische VK berechnet werden.

nun hat meine Webdesignerin gemäß der eigenen Versandregeln eine Abfrage erstellen wollen, dass Versand C nur dann aktiv ist, wenn Artikel A UND B im Warenkob liegen.

Das funktioniert soweit auch, allerdings nur bei Kategorie B, bei Kategorie A nicht. Also entferne ich einen Artikel aus B wieder aus dem Warenkorb, werden die korrekten Versandkosten von A berechnet und Versandosten C sind nicht mehr auswählbar, infolgedessen auch nicht aktiv.
Wirft man einen Artkel aus Kategorie A aus dem Warenkorb, bleibt Versand C aktiv und leider auch in der Vorauswahl.

Kategorie A hat Unterkategorien und ca 550 Artikel, Kategorie B hat keine Unterkategorien und nur 2 Artikel
wir haben zu Testzwecken eine weitere Kategorie mit einer Unterkategorie und einem Testartikel angelegt, ging leider auch nicht, sobald eine Kategorie iene Unterkategorie hat. Wie können wir das Problem lösen?

hier noch die Aussage meiner Webdesignerin, im Fachjargon:

 

"eigene Bedingungen bezueglich Kategorien bei Versandkosten Verwaltung funktioniert nicht, die in den Grundeinstellungen hinzugefuegte Abfrage scheint keinen Effekt zu haben (MIN((SELECT 1 FROM s_articles_categories WHERE articleID=a.id AND categoryID='MeineID')) AS kat_name)
 
 
betrifft nur eine Kategorie, bei anderen Kategorien funktioniert es
 
 
kann das an Einstellungen liegen? kann es was mit der Migration zu tun haben? Kann es an Unterkategorien liegen?"

 

Sign In or Register to comment.