Zahlungsarten für Firmenkunden ausblenden

wie kann man bestimmte Zahlungsarten wie. PayPal oder Sofortzahlung bei der Anmeldung als “Firma”  und ausblenden.?

Umsatzsteuer-ID ist Pflichtfeld. Der Shop enthält Bruttopreise und die Firmen sollen nur die Zahlungsart “Rechnung” oder “Vorkasse” bekommen. 

Im BE Einstellungen/Riskmanagement.

Happy selling,

Geert

1 Like

vielen Dank für die superschnelle Antwort.

werde es heute noch testen.

Willy

 

@vanwittlaer schrieb:

Im BE Einstellungen/Riskmanagement.

Happy selling,

Geert

 

habe die Einstellung geändert und  “PayPal” und “Sofort” für Händler gesperrt.

Dann neue Firma angelegt mit Umsatzsteuer-ID.

trotzdem sind alle  Zahlungsarten “PayPal”,“Sofort”,“Rechnung” und “Vorkasse” verfügbar gewesen.

Erst als ich im BE ( kunden)  von Shopkunde auf Händler umgestellt hatte , hat es funktioniert.

geht das nicht automatisch wenn ich eine Firma anlege ?

 

Das ist schon ein Feature und kein Bug. Da Händler normalerweise bessere Konditionen bekommen als Endkunden, will man, dass sie extra freigeschaltet werden müssen.

Wenn Du mehr Funktionen für Händler oder besondere Kundengruppen benötigtst, gibt’s dafür das Plugin “Business Essentials” von Shopware.

Happy selling,
Geert

Ich habe das Plugin “Business Essentials” installiert und für Händler die Checkbox “Freischaltung der Registrierungen im Backend erforderlich” deaktiviert.
Trotzdem werden bei der Registrierung als Händler die im Riskmanagement gesperrten Zahlungsarten nach wie vor angezeigt.

Im BE erscheint der Händler als Shopkunde und nicht als Händler. Erst nach Umstellung auf “Händler” im BE(Kunden) werden “PayPal” und “Sofort” nicht mehr angezeigt.

Mein Wunsch wäre: Bei Registrierung als Firma und Eingabe der Umsatzsteuer-ID sollen die Zahlungsarten “PayPal” und “Sofort” verschwinden. 

Hallo,

ich habe das Plgin ja nicht installiert. Dein Screenshot legt aber nahe, dass es sinnvoll wäre, das Feld Kundengruppe bis zur Freischaltung mit einem Wert zu belegen. So wie Du Dir das Verhalten wünscht, dann wohl mit der Händlergruppe.

@drakon schrieb:

Hallo,

ich habe das Plgin ja nicht installiert. Dein Screenshot legt aber nahe, dass es sinnvoll wäre, das Feld Kundengruppe bis zur Freischaltung mit einem Wert zu belegen. So wie Du Dir das Verhalten wünscht, dann wohl mit der Händlergruppe.

 

das geht leider nicht , da im Dropdownfeld nur “Shopkunden” auftaucht.