Wishlist Error nach Deaktivierung von Artikel

Hallo Shopware Community, meine Shopware Version: 5.1.1 AdvancedCart Version: 1.1.5 Ich füge der Wishlist nun einen Artikel hinzu. Wenn ich diesen besagten Artikel nun in meinem Backend deaktiviere, erscheint bei allen Kunden, welche diesen Artikel in einer Wishlist enthalten hatten folgende anzeige. (ich habe zur Fehlersuch „showException“ auf true gesetzt) Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. No active product variant found in Shopware/Bundle/StoreFrontBundle/Service/Core/ProductNumberService.php on line 113 Stack trace: #0 Shopware/Core/sArticles.php(1196): Shopware\Bundle\StoreFrontBundle\Service\Core\ProductNumberService->getAvailableNumber(‚31312‘, Object(Shopware\Bundle\StoreFrontBundle\Struct\ProductContext), Array) #1 Shopware/Plugins/Community/Frontend/SwagAdvancedCart/Controllers/Frontend/Wishlist.php(185): sArticles->sGetArticleById() #2 Shopware/Plugins/Community/Frontend/SwagAdvancedCart/Controllers/Frontend/Wishlist.php(247): Shopware_Controllers_Frontend_Wishlist->prepareArticle() #3 Shopware/Plugins/Community/Frontend/SwagAdvancedCart/Controllers/Frontend/Wishlist.php(138): Shopware_Controllers_Frontend_Wishlist->prepareCartItems() #4 Enlight/Controller/Action.php(158): Shopware_Controllers_Frontend_Wishlist->indexAction() #5 Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch(‚indexAction‘) #6 Enlight/Controller/Front.php(227): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #7 Shopware/Kernel.php(148): Enlight_Controller_Front->dispatch() #8 vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #9 Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #10 vendor/symfony/http-kernel/HttpCache/HttpCache.php(449): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(349): Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(Object(Symfony\Component\HttpFoundation\Request), true) #12 Shopware/Components/HttpCache/AppCache.php(178): Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(213): Shopware\Components\HttpCache\AppCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #14 Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #15 shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #16 {main} Das Plugin ist frisch installiert und keine Änderungen wurden vorgenommen. Ich habe hier leider nichst zu diesem Fehler gefunden. Was ich bei einer Deaktivierung des Artikels erwarten würde, wäre eine Benachrichtigung, dass der Artikel xy nicht mehr verfügbar ist. Es scheint wohl hierzu schon einmal in Version 1.1.0 ein Bugfix gegeben zu haben: PT-3205 - Bugfix: Fehler bei nicht mehr vorhandenen Artikeln Wie kann das behoben werden?

Hallo, mach in jedem Fall mal ein Ticket auf, dann kann unsere Entwicklung sich das ansehen: jira.shopware.de Moritz

1 Like

danke für die schnelle Antwort. Anbei der Ticketlink, falls sich jemnad dran hängen möchte. https://issues.shopware.com/#/issues/PT-4644

Ich habe mal all unsere Änderungen deaktiviert, sodass Shopware das Bare Theme benutzt. Leider ist der Fehler nach wie vor da. - Ich füge der Wishlist Artikel XY zu - Ich deaktiviere den Artikel im Backend -> Wishlist Plugin crashed bei allen Usern die diesen Artikel in der Wishlist hatten. Könnte jemand der Community mal versuchen diesen Bug nachzustellen? Shopware 5.1.1 AdvancedCard 1.1.5

Der Fehler wurde laut issues.sw.com auch noch nicht behoben - also kein Wunder, dass du noch Fehlermeldungen bekommst :slight_smile: Viele Grüße

Mein Kollege wollte eigentlich wissen ob jemand aus der Community das Problem nachstellen konnte, weil seitens Shopware dazu keine wirkliche Info kam. (Ja, wir haben sowohl die SW als auch das Modul gekauft) Inzwischen haben wir einen weiteren Testserver frisch aufgesetzt, SW 5.1.1 drauf, per Hand 2 Kunden und 2 Artikel erstellt, Advanced Cart 1.1.6 installiert, Fehler tritt weiterhin auf, obwohl im Changelog auf genau unser Ticket Bezug genommen wird: Advanced Cart Changelog zur Version 1.1.6 vom 23.12.2015: PT-4644 - Bugfix: Problem mit numerischen Bestellnummern und deaktivierten Artikeln Als Artikelnummern haben wir spaßeshalber sowohl rein numerische als auch Mix Buchstaben+Numerisch getestet. Das Ganze ist für uns etwas ärgerlich, da wir so langsam unseren Webshop auf die Shopware umziehen möchten und an dieser Stelle in der Luft hängen. Da das bisherige Ticket inzwischen auf Status gelöst steht bleibt uns wohl nur übrig ein neues aufzumachen.

Nachtrag: Fehler tritt ebenfalls im Shopwaredemoshop (http://www.shopwaredemo.de) auf, allerdings NICHT bei Variantenartikeln, nur bei Nichtvariantenartikeln. Neues Ticket unter https://issues.shopware.com/#/issues/PT-4867