Versandarten Problem bei Gutscheinen

Hallo,

ich habe eine Versandart „Sofortdownload“ erstellt. 

Dafür habe ich im Versandkosten Modul die Abfrage „MIN(b.esdarticle) as all_esd“ eingefügt und unter Versandkosten im Feld Eigene Bedingungen den Zusatz „all_esd“ hinzugefügt.

Damit werden bei ESD Artikeln alle anderen Versandarten ausgeblendet. 

Sobald ich aber einen Gutschien im Warenkorb hinzufüge, greift die Versandart nicht mehr und wird nicht mehr angezeigt.

Wie kann ich das Problem bewerkstelligen?

Jemand einen Tip?

Danke und Grüße

Dany 

Keiner ne Idee?

Das Problem wird beim Gutschein liegen, da dieser als Position in den Warenkorb aufgenommen wird und dann bei deinem Statement anschlägt.
Die Gutschein-Position ist kein Downloadartikel und führt dazu, dass deine Bestellung nicht mehr als reine Download-Bestellung angesehen wird.

Du kannst versuchen den Gutschein herauszufiltern z.B. über den modus (unter s_order_basket) oder einen bestimmten Nummernkreis bei der Gutscheinnummer.

Sowas wie:  MIN(IF(modus=1,b.esdarticle,0)) as all_esd 

Wenn modus <> 1, also kein regulärer Artikel vorliegt, dann schreibt er einen fixen Wert (1 oder 0 je nachdem was du brauchst) für diesen Datensatz rein.

 

1 Like

@PStadtfeld schrieb:

Das Problem wird beim Gutschein liegen, da dieser als Position in den Warenkorb aufgenommen wird und dann bei deinem Statement anschlägt.
Die Gutschein-Position ist kein Downloadartikel und führt dazu, dass deine Bestellung nicht mehr als reine Download-Bestellung angesehen wird.

Du kannst versuchen den Gutschein herauszufiltern z.B. über den modus (unter s_order_basket) oder einen bestimmten Nummernkreis bei der Gutscheinnummer.

Sowas wie:  MIN(IF(modus=1,b.esdarticle,0)) as all_esd 

Wenn modus <> 1, also kein regulärer Artikel vorliegt, dann schreibt er einen fixen Wert (1 oder 0 je nachdem was du brauchst) für diesen Datensatz rein.

 

Vielen Dank für Deine Ausführung. Genau da sehe ich auch das Problem. 

Leider bekomme ich es nicht hin mit Deinen Tips. 

Ich habe „MIN(IF(modus=1,b.esdarticle,0)) as all_esd“ mal in das Versandkostenmodul eingetragen aber das ändert nichts. 

Muss ich noch was ändern?

Danke und Grüße