Update von 4.3.6 auf 5.1.6 kommt bei jedem Artikeldetailaufruf Ups! Ein Fehler ist aufgetreten!

Liebes Forum,

ich habe nun schon ein wenig gegoogelt und auch hier im Forum nach einer Lösung gesucht, jedoch konnte ich leider keine Lösung finden.

Zu meinen Kenntnissen der Shopware würde ich sagen, bin ich noch Anfänger.

Ich habe ein Update von der Version 4.3.6 auf 5.1.6 nach Anleitung gemacht, welches auch ohne Probleme durch lief!

Nun bekommt jeder Besucher, der einen Artikel anwählt und die Detailseite öffnen möchte folgende Meldung:

Ups! Ein Fehler ist aufgetreten!

Wir wurden bereits über das Problem informiert und arbeiten an einer Lösung, bitte versuchen Sie es in Kürze erneut.

Im log auf meinem Server steht leider nur folgendes:

[2016-06-06 13:22:43] core.ERROR: Legacy media url detected. {„requestedUrl“:"/media/image/thumbnail/PonySue23821_105x105.png",„redirectedTo“:„http://shop.manufakt-asendorf.de/media/image/90/5f/5d/PonySue23821_105x105.png“} {„uid“:„a94bc65“}

 

Diese Meldung kommt immer und immer wieder, habe schon ALLE caches geleert, jedoch auch ohne Erfolg.

 

Kann mir jemand weiter helfen und hat eine Lösung für mich??

Vielen Dank

S.Stradtmann

Hallo stradtmann,

hast du die Thumbnails schon generiert? 

Beste Grüße

Hallo Pixalla,

manuell hab ich das noch nicht angeworden, von daher würde ich sagen nein.

Wo kann ich das machen?

@stradtmann schrieb:

Hallo Pixalla,

manuell hab ich das noch nicht angeworden, von daher würde ich sagen nein.

Wo kann ich das machen?

Hallo,

speziell für den Wechsel zwischen Shopware 4 zu Shopware 5 gibt es auch einen Update Guide, siehe: Shopware 5 Update Guide . Bei deinem Thema gibt es speziell seit Version 5.1.0 eine Neuerung: http://community.shopware.com/Update-Guide-Shopware-5.0-auf-Shopware-5.1_detail_1885_441.html#Media_Service . Schlussendlich steht in der Fehlermeldung aus deinem Log ja schon das entsprechende da: du verwendest eine veraltete Bildurl.

Beste Grüße

Sebastian

Danke für die Links!

Ich habe/hatte das so verstanden, wenn ich die neuen responsive Designs verwende, muss ich die Bilder anpassen.

Derzeit habe ich noch das Emotion Blue Template im Einsatz, welches noch in der aktuellen Shopware Version unterstützt werden soll. Ist auch hier ein neu generieren der Thumbnails von nöten?

Entschuldigt bitte für die Fragen…

@stradtmann schrieb:

Danke für die Links!

Ich habe/hatte das so verstanden, wenn ich die neuen responsive Designs verwende, muss ich die Bilder anpassen.

Derzeit habe ich noch das Emotion Blue Template im Einsatz, welches noch in der aktuellen Shopware Version unterstützt werden soll. Ist auch hier ein neu generieren der Thumbnails von nöten?

Entschuldigt bitte für die Fragen…

Hallo,

in diesem Fall nicht - ein problemloser Wechsel von Shopware Version 4 auf Shopware Version 5 unter Weiterverwendung eines emotion - Themes ist aber (meist) nicht problemlos möglich, da sich im Core viel geändert hat.

Am besten ergänzt du folgendes einmal in deiner config.php: Debugging Shopware . Also speziell:

'front' => [
     'throwExceptions' => true,
     'showException' => true
]

Dann müsste es dir die Fehlermeldungen ausgeben, die dir weiterhelfen sollten.

Beste Grüße

Sebastian

Nun bekomme ich folgende Fehlermeldung…

Fatal error: Uncaught exception ‘SmartyException’ with message ‘Unable to load template snippet ‘frontend/detail/navigation.tpl’ in ‘frontend/detail/index.tpl|frontend/plugins/seo/index.tpl’’ in /WWWROOT/239660/htdocs/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /WWWROOT/239660/htdocs/engine/Library/Smarty/sysplugins/smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(NULL, NULL, NULL, NULL, false, false, true) #1 /WWWROOT/239660/htdocs/var/cache/production_201605230943/templates/frontend_emotion_blue_manufakt_de_DE_1/dc/a8/9e/dca89eb77635d0ae2121ed3a98d202c09730d683.snippet.index.tpl.php(386): Smarty_Internal_Template->getSubTemplate(‘frontend/detail…’, NULL, ‘frontend_emotio…’, NULL, NULL, Array, 0) #2 /WWWROOT/239660/htdocs/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php(180): content_575547f618fc52_01583768(Object(Enlight_Template_Default)) #3 /WWWROOT/239660/htdocs/engine/Library/Enlight/View/Default.php(274): Smarty_Internal_TemplateBa in /WWWROOT/239660/htdocs/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php on line 127

Kann mir keiner weiterhelfen? Bzw. kennt niemand diese Fehlermeldung?

Werden noch mehr Daten für die Analyse benötigt?

 

Vielen Dank!

@stradtmann schrieb:

Nun bekomme ich folgende Fehlermeldung…

Fatal error: Uncaught exception ‘SmartyException’ with message ‘Unable to load template snippet ‘frontend/detail/navigation.tpl’ in ‘frontend/detail/index.tpl|frontend/plugins/seo/index.tpl’’ in 

Hallo @stradtmann,

der Fehler liegt wahrscheinlich in einer individullen Anpassung des Templates oder einem Plugin, das dies tut. Man kann nicht alle Templateanpassungen in Shopware 5 verwenden, die in Shopware 4 notwendig oder korrekt waren . An einigen Stellen hat sich das Vererbungsschema durch den Wegfall von _default geändert, hier muss dann evtl. das Shopware 4 Template angepasst werden. Mit dem Shopware Core an sich hat das in der Regel nichts zu tun.

 In der Fehlermeldung sind 3 Templatedateien erwähnt (mit .tpl am Ende).  Wahrscheinlich wird in den letzten beiden Dateien die zuerst genannte aufgerufen.