Update Problem von 6.5.0 auf 6.5.3.3

Hi zusammen,

ich hab mich nun auch mal an das Update eines SW 6.5 Shops auf 6.5.3.3 gemacht und egal welche Methode ich probiere, es klappt nicht.

Der Shop liegt bei Mittwald auf einem Space Server mit genügend Power, allen Systemvoraussetzungen und läuft mit Version 6.5.0 problemlos.
Das einzige, das ich nicht nachvollziehen kann ist, dass kein SW Update im Backend angezeigt wird und auch noch nie wurde obwohl schon länger welche vorhanden sind. Plugin Updates werden problemlos angezeigt und die Plugins lassen sich auch updaten.

Vor der Installation hab ich alle Plugins aktualisiert und dann im Backend deaktiviert. Zudem habe ich auch das Theme auf das Standard Theme umgestellt.
Dann per SSH verbunden im nach der offiziellen Anleitung zunächst

bin/console system:update:prepare

ausgeführt und nach Anpassung der composer.json

composer update 

Hier habe ich nach einiger Zeit folgende Fehlermeldung erhalten

Executing script assets:install [KO]
 [KO]
Script assets:install returned with error code 255
!!
Script @auto-scripts was called via post-update-cmd

Meine Recherchen zu diesser Fehlmeldung habe mir bislang leider nicht weitergeholfen.
Auch eine Installation über den Shopware Installer hat nicht funktioniert. Der ist bei der Frontend Installation stehen geblieben…

Hat jemand eine Idee, wie das Problem zu beheben ist?

Danke!

1 Like

Hey @NGEDV,

bei uns tritt das gleiche Problem auf einem Mittwald-Server auf. Konntest du es beheben ?

Hi NacScha,
schlussendlich hats bei mir dann irgendwann nach zig Versuchen geklappt indem ich die Plugins und das Theme nicht über das Backend deaktiviert hatte, sonder per Console.

Ich bezweifle allerdings stark, dass das die Lösung war - vermute eher es war Zufall, dass es dann mal funktioniert hat.

Bei uns war es tatsächlich ein Fehler im Deployment, wodurch bin/console nicht korrekt ausgeführt wurde.

Falls irgendjemand mögliche Lösung sucht: Bei uns haben Dateien im config-Ordner gefehlt, wodurch die Ausgabe von bin/console (xxx:xxx) immer leer waren :slight_smile: