Update auf 6.6.4.0 mit Fehler

Hallo zusammen,

ich konnte bis dato alle Shopware Updates problemlos einspielen. Unser Server mag wohl Shopware sehr gerne.
Beim letzten Update auf 6.6.4.0 brch der Vorgang plötzlich ab und es wurde ein Fehlerprotokoll erstellt. Ich konnte dann am Ende nicht auf Installieren klicken, sondern musste zurück. Nun im Adminbereich sehe ich, dass die aktuelle Version 6.6.4.0 ist und der Shop funktioniert auch hervorragend.
Allerdings sind bei „Meine Erweiterungen“ keine Apps mehr zu sehen. Die Verbindung zum Store habe ich geprüft und die passt. Ich habe sie extra gelöscht und neu angelegt, aber das brachte nichts.
Die Log Datei beginnt mit dem Fehler: „Warning: Failed to load plugins. Message: syntax error, unexpected identifier „PLUGIN_CONFIG_KEY“, expecting „=““
Hat jemand einen Tipp, was ich tun kann?

Hallo, bei mir auch Fehler, will von 6.6.3.0 auf 6.6.4.0 updaten, nun folgende Meldung:

Protokoll
Run Update preparations
Composer could not detect the root package (shopware/production) version, defaulting to ‚1.0.0‘. See Troubleshooting - Composer

pre-update-cmd: Symfony\Flex\Flex->configureInstaller
Loading composer repositories with package information
pre-pool-create: Symfony\Flex\Flex->truncatePackages
Updating dependencies
Dependency resolution completed in 0.011 seconds
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires jkweb/shopware-category-listing-plugin 1.0.8 (exact version match: 1.0.8 o

Genau den selben Fehler sehe ich in der Protokolldatei auch.

„Composer could not detect the root package (shopware/production) version, defaulting to ‚1.0.0‘. See Troubleshooting - Composer

Hat schon jemand vielleicht eine Lösung? lg Peter

@autostar-handel
Ist das tatsächlich nur uns beiden passiert?
Konntest Du schon eine Lösung finden?

Ich habe versucht die Apps neu zu installierten, geht leider nicht, weil mit dan der Store anzeigt: „Für den ausgewählten Shop wurde bereits eine Lizenz gebucht.“

Dann habe ich versucht eine neue App, die noch nicht installiert was, als wo noch keine Litzenz bestand, zu installieren. Geht leider auch nicht und die Fehlermeldung lautet:

Internal Server Error
The command „‚git‘ ‚branch‘ ‚-a‘ ‚–no-color‘ ‚–no-abbrev‘ ‚-v‘“ failed. Working directory: /home/webpages/lima-city/destillerie/shop-20211029 Error: proc_open(): posix_spawn() failed: Permission denied.

Ich habe versucht, die Apps einfach im Store runter zu laden um sie manuel zu installieren. Das geht leider nicht, es wird nichts installiert.

Nun habe ich über die Datenbank den Store deaktiviert um ihn dann im Backend wieder zu aktivieren. Kann ja sein, dass das was bringt, dachte ich mir.

Siehe da, es gibt einen Button mit der Aufschrift „Store Aktivieren“ :slight_smile:

Dann jedoch erhalte ich folgende Fehlermeldung:

The command „‚git‘ ‚branch‘ ‚-a‘ ‚–no-color‘ ‚–no-abbrev‘ ‚-v‘“ failed. Working directory: /home/webpages/—xxx—/destillerie/shop-20211029 Error: proc_open(): posix_spawn() failed: Permission denied

Die x-en habe ich eingefügt.

Was auch immer das zu bedeuten hat, ich würde ich mich riesig freuen, wenn das jemand wüsste.

Vielen Dank im Voraus.

Diese Fehler tritt meiner Erfahrung nach auf, wenn ein Plugin nicht mit den Composer-Abhängigkeiten der neuen Shopware-Version kompatibel sind.

Falls möglich deinstalliere und entferne deine Plugins über die Konsole nach und nach und schau, ob der Fehler verschwindet. Beginne am besten mit dem Plugin, welches die wenigsten Downloads im Shopware Store hat.

Wieso auch entferne? Wenn eine composer.json innerhalb des custom Ordners liegt, wird das Plugin berücksichtigt, egal ob installiert oder nicht. Die Daten der installierten Plugins musst du natürlich nicht entfernen.

Am besten sowieso mit Backup. Wenn du das Problem hast zurücksetzen und gezielt das Plugin entfernen.

Servus@max_Shop und @Tremer

hab mal alles so gemacht wie vorgeschlagen, aber Fehlermeldung weiterhin:

Problem 1
- Root composer.json requires jkweb/shopware-category-listing-plugin 1.0.8 (exact version match: 1.0.8 or 1.0.8.0), found jkweb/shopware-category-listing-plugin[1.0.8] in the lock file but not in remote repositories, make sure you avoid updating this package to keep the one from the lock file.

Wenn ich mich recht erinnere, ist das Plugin nicht 6.6 kompatibel. Sprich vor dem Update deinstallieren und entfernen oder über composer nachträglich entfernen.

Hierzu gibt es meinerseits noch keine Aufzeichnungen:

Could not execute "composer require" for plugin "MoorlFoundation (moorl/foundation:1.6.20). Output: In Factory.php line 320: "./composer.json" does not match the expected JSON schema: - require.composer/composer : NULL value found, but a string is required require

Weiß jemand, wie man diesen Fehler nachstellen kann?

so, konnte jetzt erfolgreich auf die 6.6.4.0 updaten mit folgenden Änderungen:

Jkweb in DB Tab. plugins gesucht, es war auf 0-----> Zeile gelöscht

composer.json Eintrag für Jkweb gelöscht
composer.lock Eintrag für jkweb gelöscht

Diese Kategorie-Listing Funktion hatte ich mal installiert, aber dann wieder gelöscht, anscheinend nur stümperhaft gelungen…

Hauptsache, es funktioniert jetzt einwandfrei :slight_smile:

Ich nutze diesen Kanal, um meinen Kunden einen Workaround für den o.g. Fehler vorzuschlagen. Leider kann ich aktuell kein Update hochladen, weil die betroffene Zeile (die den Fehler verursacht), eine Pflichtangabe ist und mein Update nicht zugelassen wird.

Sofern dieser Fehler beim Update oder bei der Installation angezeigt wird, bitte in die composer.json des Plugins gehen und die Zeile mit „shopware/core“ löschen:

1 Like

Tausendfach Dank! Hat perfekt funktioniert. Schöpfung sei Dank, keine Neuinstallation nötig!!! :wink:

1 Like