Text im Quelltext und dennoch nicht sichtbar

Hallo,

I have got a problem.
Und zwar denke ich, dass ich mich mit html und css mittlerweile sehr gut auskenne.
Aber: Es gibt fehlerhafte Darstellungen in der Art, dass man vermuten könnte, dass es an CSS, z.B. Inline-Styles oder am stacking context des z-index liegen könnte.
Dem scheint aber nicht so zu sein, da es keine Inline-Styles gibt und „alles“ in den Dev Tools von mir probierte wurde, um irgendwie das Problem zu lösen.
Das Problem ist, dass bestimmter Text nicht dargestellt wird, obwohl er im Quelltext angezeigt wird.
Meiner Meinung nach sollte es irgendwie mit js, smarty oder php zu tun haben. Vielleicht im tpl ein Bereich, der die Textausgabe in jedem Fall unterdrückt oder Ähnliches.
Bei Folgendem tritt es auf (leider nur in meinem weit angepassten Shop und nicht in einem neu aufgesetztem jungfräulichen Shop):

Szenario:

  • Aufruf der Detailbeschreibung eines Artikels
  • Klick auf „weitere Artikel vom Hersteller“
  • nun erscheinen die Artikel, wobei als Erstes die Topseller auftauchen
  • dort gibt es nun mehrere Bereiche, in denen laut Quelltext ein Text erscheinen sollte, dies aber nicht tut (auch nicht bei Entfernung sämtlicher nicht-originalen css-Eigenschaften)
  • als erstes Beispiel: .topseller .product–price-info .product–price .price–default
  • als weiteres Beispiel fehlen die Wörter wie z.B. Neu, Top usw. in den „.product–badges“

Hatte jemand bereits ein ähnliches Problem oder irgendeinen Ansatzpunkt?

MFG
Nils

 

 

 

 

 

 

@Kenny schrieb:

Hallo,

I have got a problem.
Und zwar denke ich, dass ich mich mit html und css mittlerweile sehr gut auskenne.
Aber: Es gibt fehlerhafte Darstellungen in der Art, dass man vermuten könnte, dass es an CSS, z.B. Inline-Styles oder am stacking context des z-index liegen könnte.
Dem scheint aber nicht so zu sein, da es keine Inline-Styles gibt und “alles” in den Dev Tools von mir probierte wurde, um irgendwie das Problem zu lösen.
Das Problem ist, dass bestimmter Text nicht dargestellt wird, obwohl er im Quelltext angezeigt wird.
Meiner Meinung nach sollte es irgendwie mit js, smarty oder php zu tun haben. Vielleicht im tpl ein Bereich, der die Textausgabe in jedem Fall unterdrückt oder Ähnliches.
Bei Folgendem tritt es auf (leider nur in meinem weit angepassten Shop und nicht in einem neu aufgesetztem jungfräulichen Shop):

Szenario:

  • Aufruf der Detailbeschreibung eines Artikels
  • Klick auf “weitere Artikel vom Hersteller”
  • nun erscheinen die Artikel, wobei als Erstes die Topseller auftauchen
  • dort gibt es nun mehrere Bereiche, in denen laut Quelltext ein Text erscheinen sollte, dies aber nicht tut (auch nicht bei Entfernung sämtlicher nicht-originalen css-Eigenschaften)
  • als erstes Beispiel: .topseller .product–price-info .product–price .price–default
  • als weiteres Beispiel fehlen die Wörter wie z.B. Neu, Top usw. in den “.product–badges”

Hatte jemand bereits ein ähnliches Problem oder irgendeinen Ansatzpunkt?

MFG
Nils

 Hallo,

die Zauberkugel ist heute leider defekt - ohne einen Link zum Shop wird dir niemand helfen können. Es wird aber logischerweise etwas mit CSS zu tun haben, beispielsweise ein display: none, ein z-index oder ein falscher float etc.

Beste Grüße

Sebastian

Hallo Sebastian,
 

alle drei von dir erwähnten Dinge habe ich bereits auf Herz und Nieren geprüft und ich meine, dass ich die drei Dinge ausschließen kann.
Leider kann ich dir meine Glaskugel gerade auch nicht ausleihen, brauch ich selbst viel zu oft :slight_smile:
Aber hast du eine IP, die einigermaßen selten wechselt? Dann schalte ich dich frei.
Der Shop ist leider noch nicht fertig. Wäre sehr cool, wenn du dir das mal ansehen könntest.
Es würde mich sehr wundern, wenn du das mit css in den Griff bekommen würdest - beziehungsweise dann würde ich mir wohl noch mal ein Lehrbuch über css reinziehen (müssen).

MFG
Nils