Support-Thread: Neues Plugin: "Erweitertes Grafik Menü"

Keine Chance. Der Plugin-Cache ist schon längst deaktiverit. Sämtliche Shopware-Caches werden und wurden nach jeder Aktion geleert. Mehrfach wurde der Cache-Ordner auch via FTP geleert. Der Quellcode sieht so aus:

Hallo, für mich sieht es nicht so aus, dass mein Plugin dort läuft. Wenn Sie mir über eine PM einen Backendzugang geben, schau ich da mel rein. Ist die Option Grafiken anzeigen wirklich aktiviert? So ein Fehler / Problem ist bisher garantiert noch nicht aufgetreten.

Der Fehler wurde gefunden - der Shop ist nicht auf der aktuellen Version, sondern auf der 4.0.4 - da wird die Variable für das Kategoriebild nicht in das System übergeben.

Hallo Herr Wolf, danke für die Info und Hilfe. Aber warum steht dann in der Plugin-Beschreibung unter: Kompatibel mit: ab 4.0.0 - 4.0.6 nicht drin, dass bei älteren Versionen als 4.0.6 das Kategoriebild shopwareseitig nicht angezeigt wird? Wenn ich im Forum suche, finde ich jetzt auch die entsprechenden Threads. Aber warum muss ich erst Zeit aufwenden und suchen? Sie haben dieses Knowhow, teilen es aber dem Käufer nicht mit. Wie schon in meinem Eingangsthread gesagt: Es fehlt eine Dokumentation zu Ihrem Plugin. Das ist ein großes Manko und hat mich und Sie am Wochenende richtig Zeit gekostet. Immerhin verkaufen Sie Ihr Mini-Plugin für 39 EUR. Das ist nicht wenig. Dafür erwarte ich nicht nur einen zugegebenerweise guten Support, sondern eine vollständige Dokumentation, so wie es sich eben bei sauberer Software-Entwicklung gehört.

[quote]Aber warum steht dann in der Plugin-Beschreibung unter: Kompatibel mit: ab 4.0.0 - 4.0.6[/quote] Fehler im System - wurde auf Anfrage von mir wieder richtig eingestellt [quote]Es fehlt eine Dokumentation zu Ihrem Plugin[/quote] Auch das ist behoben: Ausführliche Anleitung als PDF vorhanden, kann auch vor dem Kauf gelesen werden :slight_smile: [quote]Wir bauen den neuen Shop natürlich mit dem neuesten Release-Stand von Shopware[/quote] Das war aber leider nicht der Fall - es war die 4.0.4 und da steht die Variable der Kategoriegrafik nicht zur Verfügung.

Das erweiterte Menü funktoniert soweit prima. Jetzt habe ich noch 2 Fragen dazu: - Lässt sich das Menü automatisch an die Breite der Kacheln anpassen? Wenn die Kacheln 125x125px haben, passen 5 nebeneinander. Wenn man nur 3 Untermenüs einsetzt, sieht der weiße Bereich rechts davon nicht so schön aus. - Die Kacheln sind nicht ganz mittig (bei 125x125px Größe), sondern leicht nach links versetzt. Wie lässt sich das ändern? Danke und viele Grüße Gabriel

Hallo Gabriel, das Plugin skaliert nicht automatisch. In der menustyle.css können aber die Werte für die Box (Zeile 16) angepasst werden. Das greift dann aber für alle Kacheln. #mainNavigation ul li.dropactive:hover ul.dropdown li a {height:145px; border:#ccc 1px solid; width:145px; } Für individuelle Anpassungen den Code in die eigene Template-CSS übernehmen, um Updatesicher zu sein. Um die Grafiken mittiger zu haben, kann im Plugin bei “CSS Inline für Grafiken” noch ein “margin-left:12px;” angefügt werden. Wirkt sich aber auch auf die Grafiken in den Top-Kategorien aus.

Vielen Dank! Die Breite lasse ich dann doch so, das stört nicht allzu sehr und geht anders wohl auch kaum. Der Tipp mit der margin-left war gut, jetzt sitzt es mittig.

Hallo zusammen, bin noch Anfang mit Shopware und stehe momentan vor dem Problem das erweiterte Grafikmenü umzugestalten. Das Plugin wurde ohne Probleme installiert, aktiviert und funktioniert. Ich habe es nicht als gekachelte Bilder eingestellt sondern als Dropdown mit Text. Wie und wo verändere ich nun z. B. den Hintergrund des Dropdown, etc.? Über eine Nachricht freue ich mich. Gruß jox

Hallo, wenn der Hintergrund des Dropdown als Text geändert werden soll, am besten das Element mit Firefox + Firebug, oder mit dem Chrome-Browser untersuchen (F12). Die Farbe des Dropdown-Hintergrundes im eigenen Template dann ändern: #mainNavigation ul li ul.dropdown li {background-color: #a0a0a0;}

wie kann man denn bei diesme Plugin den Home Button entfernen ?

Ein Bug in Shopware lässt im Moment das Löschen noch nicht zu (steht wohl für die 4.2.0 auf der Liste) Um die Eingabe im Moment los werden zu können, muss das Plugin einmal neu installiert werden. Eine andere Möglichkeit gibt es derzeit noch nicht.

Hallo, ich habe das Menü Plugin gekauft, da in Ihrer Referenz ist auch Zoolandi angegeben ist. Ich wollte das Menü so wie da aufbauen, jedoch ohne Grafiken. Dort werden die 2. Subkategorien gleichzeitig mit der ersten Sub in einer Kachel angezeigt. Ich finde dazu aber keine Einstellmöglichkeit. Können Sie da weiterhelfen? Gruß Mathias

Hallo Markenmix24-de, wie in dem Bild angegeben, ist die TOP-Navigation aus dem Plugin. Das Dropdown-Menü ist durch eine Programmierung geändert. Dazu müsste das Template um die Ordner: plugins/wolfadvancedgraficmenu erweitert werden, und dort die Datei „wolfgraadmenu.tpl“ kopiert und angepasst werden. Die Funktion am Anfang unter neuem Namen duplizieren und so ändern, dass für weitere Unterketegorien kein

-Listing entsteht, - raus und alles in einen

-Block… CSS anpassen. Das müsste also individuell angepasst werden. Mit freundlichen Grüßen M.Wolf

Hallo! Ich hätte nur eine kurze Frage. Bei uns im Top Menu habe ich einige Seiten extra ins Menu hinzugefuegt, die als Landingpages neben den normalen Kategorien funktionieren sollen. Also einfach weitere

  • Tags in die categories_top.tpl eingefuegt, die auf Shopseiten verweisen. Ist es nun richtig, das ich diese Landingpages nicht an das Grafische Menu anbinden kann, bzw, gibt es da eventuell eine Möglichkeit durch eine Template-Anpassung?

Wenn auf “externe” Seiten im Menü verwiesen werden soll, kann dies auch über den Kategoriebaum erfolgen. Unter Artikel -> Kategorien eine neue Kategorie anlegen und den Bereich “Auf externe Seite verlinken” ausfüllen. Also z.B. dort “http://www.meinshop.de/landingpage” einfügen. Nun erscheint der Navigationspunkt auch in der Topnavigation, egal welches Menü aktiviert ist. Oder aber das Template um die Ordner: plugins/wolfadvancedgraficmenu erweitern, und dort die Datei “wolfgraadmenu.tpl” kopieren und angepassen. So ist aber ein Update des Menuplugins schwieriger, da diese Datei dann mit der neuen Version verglichen und evt. angepasst werden muss.

Danke! Ueber die Kategorie kann ich das nicht machen, da ich die neue Seite nur oben im Top menu haben möchte, und wir die linke Navigation auf der Startseite haben, und dort sollte die Seite nicht auftauchen. Gibt es eventuell eine Anleitung was im Plugin template genau geändert werden sollte, bzw. wie komplex das ist? In der pdf-Anleitung habe ich hierzu nichts gefunden.

Hallo, wie oben beschrieben, das Template un die Ordner erweitern und in der wolfgraadmenu.tpl die

  • Einträge manuell einfügen. Für die Darstellung in der ersten Menüzeile im Template ab Zeile 91 (die Zeilennummern hier stimmen jetzt nicht!): {/if} {/if} {/foreach} {\* hier weitere - einfügen \*} Wenn die zweite Zeile verwendet werden soll, ab Zeile 118 (die Zeilennummern hier stimmen jetzt nicht!): {/if} {/if} {/foreach} {\* hier weitere - einfügen \*}

Hallo, trotz Ihrer Anleitung zu “Zooolandi” ist es mir am Wochenende leider nicht gelungen die 3. Unterkat. unter der 2. gleichzeitig in der Kachel anzeigen zu lassen (wie ein Mega Menü). Mit welchen weiteren Kosten müsste ich rechnen wenn Sie mir da weiterhelfen? Gruß Matthias

Seit dem Update auf 1.2.0 verspringt unser Hauptmenü leicht in der Horizontalen, da in den Menüpunkten, die Submenüs (mit Kacheloptik) beinhalten, ein schwarzer Rand im Hauptmenüpunkt hinzugefügt wird (jedoch nur teilweise: oben, links und rechts). In der vorherigen CSS-Datei der 1.1.8 Version hatten wir den Zusatz media=“all” vor der “#mainNavigation ul li.dropactive:hover a” hinzugefügt. Sobald ich diesen Zusatz jedoch in die 1.2.0 Version einsetze, lassen sich die Submenüs nicht mehr anwählen, sondern werden direkt ausgeblendet, sobald ich mit dem Mauszeiger darüberfahren möchte. Wo liegt hier das Problem? Update: Durch Zufall habe ich es selbst herausgefunden. In der CSS-Datei “#mainNavigation ul li.dropactive:hover a {border: 1px solid; height: 28px; position: relative; z-index: 3000;}” musste ich boder:1px auf border:0px abändern, dann funktioniert es auch ohne media=“all”!