Suche läßt sich nicht konfigurieren. Bug im Backend?

Wehwehchen gibt es noch leider eine Menge. Hier allerdings ein recht massiver Fehler. Die Suche kann nicht konfiguriert werden. Wenn ich im Backend dieses tun möchte kommt folgende Fehlerausgabe: ______________ 503 - Service Temporarily Unavailable Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Could not convert database value "s:375:„ab,die,der,un…“ to Doctrine Type object in Doctrine/DBAL/Types/ConversionException.php on line 46 Stack trace: #0 Doctrine/DBAL/Types/ObjectType.php(48): Doctrine\DBAL\Types\ConversionException::conversionFailed(‚s:375:"ab,die,d…‘, ‚object‘) #1 Doctrine/ORM/Internal/Hydration/AbstractHydrator.php(266): Doctrine\DBAL\Types\ObjectType->convertToPHPValue(‚s:375:"ab,die,d…‘, Object(Doctrine\DBAL\Platforms\MySqlPlatform)) #2 Doctrine/ORM/Internal/Hydration/ArrayHydrator.php(83): Doctrine\ORM\Internal\Hydration\AbstractHydrator->gatherRowData(Array, Array, Array, Array) #3 Doctrine/ORM/Internal/Hydration/ArrayHydrator.php(69): Doctrine\ORM\Internal\Hydration\ArrayHydrator->hydrateRowData(Array, Array, Array) #4 Doctrine/ORM/Internal/Hydration/AbstractHydrator.php(106): Doctrine\ORM\Internal\Hydration\ArrayHydrator->hydrateAllData() #5 Doctrine/ORM/AbstractQuery.php(603): Doctrine\ORM\Internal\Hydration\AbstractHydrator->hydrateAll(Object(PDOStatement), Object(Doctrine\ORM\Query\ResultSetMapping), Array) #6 Doctrine/ORM/AbstractQuery.php(456): Doctrine\ORM\AbstractQuery->execute(Array, 2) #7 Shopware/Controllers/Backend/Config.php(145): Doctrine\ORM\AbstractQuery->getOneOrNullResult(2) #8 Enlight/Controller/Action.php(135): Shopware_Controllers_Backend_Config->getFormAction() #9 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispatch(‚getFormAction‘) #10 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #11 Shopware/Bootstrap.php(79): Enlight_Controller_Front->dispatch() #12 Enlight/Application.php(192): Shopware_Bootstrap->run() #13 shopware.php(74): Enlight_Application->run() #14 {main} ________________________ Da wir neu aufgesetzt haben, kann ich mir fast nicht vorstellen, dass es sich um ein individuelles Problem handelt. LG Sebastian

Hi, worüber habt ihr den die Datenbank importiert? Über den Installer oder über PhpMyAdmin? Es könnte nämlich sein das beim Import der Datenbank die Umlaute kaputt gegangen sind. Heiner

1 Like

Weder, noch. Die Datenbank wurde direkt über mySQL exportiert und anschliessend über den gleichen Weg auch wieder importiert, und das sollte eigentlich unabhängig vom verwendeten Zeichensatz funktionieren. Allerdings bedanke ich mich für den Tipp, da der Hinweis trotzdem richtig war. Es lag tatsächlich an den fehlerhaften Umlauten in der Blacklist für Keywords („Einstellungen > Storefront > Suche“ in „Blacklist für Keywords“). Wie diese zustande kamen und in Zukunft vermieden werden können, müssen wir noch herausfinden, aber zumindest lässt sich die Funktion jetzt schon mal konfigurieren.