Grundeinstellung->Suche funktioniert nicht mehr. Warum?

Hallo,

ich wollte die Einstellungen für die Suche bearbeiten und dann bekam ich eine Fehlermeldung. Ich habe keine Ahnung was diese bedeuten soll. Vielleicht weiß das jemand von euch und kann mir einen Tip geben oder mir verraten was ich tun muss.

 

Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Could not convert database value “s:5:“basic”” to Doctrine Type object in vendor/doctrine/dbal/lib/Doctrine/DBAL/Types/ConversionException.php on line 46 Stack trace: #0 vendor/doctrine/dbal/lib/Doctrine/DBAL/Types/ObjectType.php(59): Doctrine\DBAL\Types\ConversionException::conversionFailed(‘s:5:“basic”’, ‘object’) #1 vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/AbstractHydrator.php(297): Doctrine\DBAL\Types\ObjectType->convertToPHPValue(‘s:5:“basic”’, Object(Doctrine\DBAL\Platforms\MySqlPlatform)) #2 vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/ArrayHydrator.php(101): Doctrine\ORM\Internal\Hydration\AbstractHydrator->gatherRowData(Array, Array, Array) #3 vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/ArrayHydrator.php(87): Doctrine\ORM\Internal\Hydration\ArrayHydrator->hydrateRowData(Array, Array) #4 vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/AbstractHydrator.php(147): Doctrine\ORM\Internal\Hydration\ArrayHydrator->hydrateAllData() #5 vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(978): Doctrine\ORM\Internal\Hydration\AbstractHydrator->hydrateAll(Object(PDOStatement), Object(Doctrine\ORM\Query\ResultSetMapping), Array) #6 vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(924): Doctrine\ORM\AbstractQuery->executeIgnoreQueryCache(NULL, 2) #7 vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(766): Doctrine\ORM\AbstractQuery->execute(NULL, 2) #8 Shopware/Controllers/Backend/Config.php(130): Doctrine\ORM\AbstractQuery->getOneOrNullResult(2) #9 Enlight/Controller/Action.php(158): Shopware_Controllers_Backend_Config->getFormAction() #10 Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch(‘getFormAction’) #11 Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #12 Shopware/Kernel.php(153): Enlight_Controller_Front->dispatch() #13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #15 vendor/symfony/http-kernel/HttpCache/HttpCache.php(263): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #16 Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #17 shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #18 {main}  

Schon mal Danke

Grüße Oli

push  Wink

Hallo Community,

ich habe leider immer noch das Problem mit der Fehlermeldung sobald ich „Einstellungen -> Grundeinstellungen -> Storefront -> Suche“ öffnen will.

Vielleicht gibt es doch jemanden der aus dieser Fehlermeldung schlauer wird? Ich habe keine Ahnung  Crying

Gruß okrause

Hallo,

das liegt an der PHP Version und wurde auch mit 5.2 im Core gefixt. Das kannst du auch manuell fixen mit zwei DB querries:

Moritz

1 Like

@Moritz Naczenski

Undecided Bitte hilf mir, und sag mir was ich da machen muss. Wo muss ich das einfügen?

Würde mich auch riesig freuen wenn mir egal wer da mal weiterhelfen könnte. 

Schon mal Danke und Grüße

Da sind zwei UPDATE Befehle die du über den Reiter SQL in deiner Datenbank ausführen kannst in z.B. PHPMyAdmin

Natürlich kannst du deinen Shop auch updaten. Das löst das Problem ebenfalls.

Sebastian

1 Like

Sorry, aber musste blöd fragen. Wusste ja nicht wo ich das eingeben muss  Wink

Jetzt bin ich wieder etwas schlauer. Hat funktioniert. Vielen Dank nochmals

Gruß