SSL überall benutzen

Hallo

 

Ich habe im Backend SSL überall benutzen aktiviert. Soweit funktioniert es. Allerdings nicht auf der Startseite, wenn ich im Browser direkt www.retronia.de eingebe. Dann erscheint diese Verbindung ist nicht sicher.

Ab dem nächsten Seitenaufruf wird https:// davor gesetzt.

 

Kann auch die Startseite beim direkten Aufruf mit https:// versehen werden.

Hi,

das erreichst du über eine Umleitung 

http://community.shopware.com/Umleitung-aller-Aufrufe-auf-HTTPS-Domain_detail_1863.html

Sebastian

Danke Dir… hat geklappt!

:smiley:

@SebastianKlöpper schrieb:

Hi,

das erreichst du über eine Umleitung 

http://community.shopware.com/Umleitung-aller-Aufrufe-auf-HTTPS-Domain_detail_1863.html

Sebastian

Hallo,

wozu ist dann im Backend die Option “SSL überall benutzen” gut, wenn man eine Umleitung einrichten muss um die Startseite in SSL erscheinen zu lassen?

Für Eure Antwort danke im Voraus.

Die Startseite wird ohne Probleme in SSL ausgeliefert, wenn du sie auch per SSL aufrufst. Die Option sorgt nur dafür, dass alle Links im Shop mit SSL ausgeliefert werden. Wenn deine Seite mit HTTP:// erfasst wurde, dann musst du eine Umleitung einrichten, da du die Seite dann ja direkt statisch mit HTTP aufrufst. Die Optionen im Backend sorgen nur dafür, dass die Links korrekt ausgegeben werden.

Unter nginx sieht die Umleitung auf https übrigens wie folgt aus: Alle http-URLs nach https umleiten | Timme Hosting