Slim Application Error bei SW 5.2.0 beta

Hallo,

ich habe SW 5.2.0 beta installiert. Lief alles ohne Probleme. 

Nach dem Aufräumen der Dateien erscheint folgende Fehlermeldung:

 

Slim Application Error

The application could not run because of the following error:

Details

Type:  ErrorException

Code:  2

Message:  is_file(): open_basedir restriction in effect. File(/var/www/clients/client6/web86/web/plugins/.gitkeep/.gitkeep.php) is not within the allowed path(s): (/var/www/clients/client6/web86/web:/var/www/clients/client6/web86/private:/var/www/clients/client6/web86/tmp:/var/www/bolamedia.de/web:/srv/www/bolamedia.de/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin)

File:  /var/www/clients/client6/web86/web/engine/Shopware/Kernel.php

Line:  310

Trace

  

#0 [internal function]: Slim\Slim::handleErrors(2, ‚is_file(): open…‘, ‚/var/www/client…‘, 310, Array)#1 /var/www/clients/client6/web86/web/engine/Shopware/Kernel.php(310): is_file(’/var/www/client…’)#2 /var/www/clients/client6/web86/web/engine/Shopware/Kernel.php(270): Shopware\Kernel->initializePlugins()#3 /var/www/clients/client6/web86/web/recovery/update/src/DependencyInjection/Container.php(175): Shopware\Kernel->boot()#4 /var/www/clients/client6/web86/web/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection{closure}(Object(Pimple\Container))#5 /var/www/clients/client6/web86/web/recovery/update/src/DependencyInjection/Container.php(184): Pimple\Container->offsetGet(‚shopware.contai…‘)#6 /var/www/clients/client6/web86/web/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection{closure}(Object(Pimple\Container))#7 /var/www/clients/client6/web86/web/recovery/common/src/DependencyInjection/Container.php(80): Pimple\Container->offsetGet(‚shopware.theme_…‘)#8 /var/www/clients/client6/web86/web/recovery/update/src/app.php(164): Shopware\Recovery\Common\DependencyInjection\Container->get(‚shopware.theme_…‘)#9 [internal function]: {closure}()#10 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Route.php(462): call_user_func_array(Object(Closure), Array)#11 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route->dispatch()#12 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call()#13 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call()#14 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride->call()#15 /var/www/clients/client6/web86/web/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions->call()#16 /var/www/clients/client6/web86/web/recovery/update/index.php(46): Slim\Slim->run()

#17 {main}

 

Die gleiche Fehlermeldung erscheint auch nach einem manuellen Update von 5.1.5 auf 5.2.0 beta.

Was kann ich machen?

Danke
Bodo

Hi Bodo,

lösche im Verzeichnis /web/plugins folgendes:

/.gitkeep/.gitkeep.php

dann sollte es klappen.

VG

 

 

2 Likes

Habe das gleiche Problem.

 

Das Löschen der .gitkeep.php Datei hat nichts gebracht.

Hallo MSH,

ggfs. auch das Verzeichnis .gitkeep löschen.

 

Sorry, meine Fehlermeldung ist doch ein bisschen anderes:

 

Slim Application Error

The application could not run because of the following error:
Details
Type: ErrorException
Code: 2
Message: is_file(): open_basedir restriction in effect. File(/home/www/web14/html/_xxx-domain.ch/plugins/.gitkeep/.gitkeep.php) is not within the allowed path(s): (/usr/local/php/lib/php/:/home/www/:/usr/bin/:/tmp:/usr/local/php56/lib/php/)
File: /home/www/web14/html/_xxx-domain.ch/engine/Shopware/Kernel.php
Line: 310
Trace

#0 [internal function]: Slim\Slim::handleErrors(2, ‚is_file(): open…‘, ‚/home/www/web14…‘, 310, Array)
#1 /home/www/web14/html/_xxx-domain.ch/engine/Shopware/Kernel.php(310): is_file(’/home/www/web14…’)
#2 /home/www/web14/html/_xxx-domain.ch/engine/Shopware/Kernel.php(270): Shopware\Kernel->initializePlugins()
#3 /home/www/web14/html/_xxx-domain.ch/recovery/update/src/DependencyInjection/Container.php(175): Shopware\Kernel->boot()
#4 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection{closure}(Object(Pimple\Container))
#5 /home/www/web14/html/_xxx-domain.ch/recovery/update/src/DependencyInjection/Container.php(184): Pimple\Container->offsetGet(‚shopware.contai…‘)
#6 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection{closure}(Object(Pimple\Container))
#7 /home/www/web14/html/_xxx-domain.ch/recovery/common/src/DependencyInjection/Container.php(80): Pimple\Container->offsetGet(‚shopware.theme_…‘)
#8 /home/www/web14/html/_xxx-domain.ch/recovery/update/src/app.php(164): Shopware\Recovery\Common\DependencyInjection\Container->get(‚shopware.theme_…‘)
#9 [internal function]: {closure}()
#10 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Route.php(462): call_user_func_array(Object(Closure), Array)
#11 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route->dispatch()
#12 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call()
#13 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call()
#14 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride->call()
#15 /home/www/web14/html/_xxx-domain.ch/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions->call()
#16 /home/www/web14/html/_xxx-domain.ch/recovery/update/index.php(46): Slim\Slim->run()
#17 {main}

Hab auch den Fehler während bzw. am Ende der Installation.   Die Löschung der .gitkeept Datei hilft.

lösche im Verzeichnis /web/plugins folgendes:

/.gitkeep/.gitkeep.php

dann sollte es klappen.

Hat funktioniert , vielen Dank für den Tipp. 

Hat jemand diesen Bug gemeldet?

Hi,

wir haben dafür ein Ticket erstellt.

Es wäre aber noch gut zu wissen, weil wir das Verhalten nicht nachstellen können, ob Ihr die normalen Packages aus unserer Downloadseite genommen habt oder den Github Stand.

Vg,

Marcel

Weder noch. Einfach in Konfigurationen auf anderen Update Channel geändert. 

Danach das Update aus dem Backend durchgeführt.

Ich habe die normalen Packages aus der Downloadseite genommen.

Ich habe dieses Problem auch.

Wo soll sich der Order „/.gitkeep/.gitkeep.php“ denn befinden?

Im Order „Web“ befindet sich bei mir nur ein Ordner „Cache“.

/plugins/