Installationsproblem - Slim Application Error; CODE 2

Hallo!

Bei der Installation von Shopware ist auf der “Zielgeraden” folgender Fehler aufgetreten:

_ Type:  ErrorException
Code:  2_

_ Message:  require_once(): open_basedir restriction in effect. File(/var/www/vhosts/hosting116251.a2f75.netcup.net) is not within the allowed path(s): (/var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/:/tmp/:/var/lib/php5/sessions:/var/lib/php/sessions:/var/www/vhosts/hosting116251.a2f75.netcup.net/tmp)_

_ File:  /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/phpstan/phpstan-shim/bootstrap.php_

_ Line:  8_

_ Trace _

_#0 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/phpstan/phpstan-shim/bootstrap.php(8): Slim\Slim::handleErrors(2, 'require\_once():...', '/var/www/vhosts...', 8, Array)_

#1 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/phpstan/phpstan-shim/bootstrap.php(8): require_once()
#2 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php(70): require(’/var/www/vhosts…’)
#3 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php(60): composerRequireShopware(‘574b1c4a61c1930…’, ‘/var/www/vhosts…’)
#4 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/autoload.php(7): ComposerAutoloaderInitShopware::getLoader()
#5 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/autoload.php(31): require(’/var/www/vhosts…’)
#6 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/install/src/ContainerProvider.php(114): require_once(’/var/www/vhosts…’)
#7 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(118): Shopware\Recovery\Install\ContainerProvider->Shopware\Recovery\Install{closure}(Object(Pimple\Container))
#8 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/install/src/ContainerProvider.php(126): Pimple\Container->offsetGet(‘shopware.contai…’)
#9 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(118): Shopware\Recovery\Install\ContainerProvider->Shopware\Recovery\Install{closure}(Object(Pimple\Container))
#10 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/install/src/ContainerProvider.php(139): Pimple\Container->offsetGet(‘shopware.theme_…’)
#11 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(118): Shopware\Recovery\Install\ContainerProvider->Shopware\Recovery\Install{closure}(Object(Pimple\Container))
#12 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/install/src/app.php(496): Pimple\Container->offsetGet(‘theme.service’)
#13 [internal function]: {closure}()
#14 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Route.php(468): call_user_func_array(Object(Closure), Array)
#15 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1355): Slim\Route->dispatch()
#16 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call()
#17 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call()
#18 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride->call()
#19 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1300): Slim\Middleware\PrettyExceptions->call()
#20 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/recovery/install/index.php(75): Slim\Slim->run()
#21 {main}

Leider fange ich mit der Fehlermöglichkeit nicht viel an. Die Datei bootstrap.php habe ich kontrolliert und diese befindet sich auch im entsprechenden Verzeichnis. 

Öffne die Datei vendor/phpstan/phpstan-shim/bootstrap.php und leere den Inhalt.

Ist mit der nächsten Version behoben

1 Like

Den Inhalt der Datei bootstrap.php habe ich gelöscht, so dass die Datei komplett leer ist 0KB.

Nun tritt aber ein anderer Fehler auf:

Warning : Uncaught ErrorException: require(/var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/…/aws/aws-sdk-php/src/functions.php): failed to open stream: No such file or directory in /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php:70 Stack trace: #0 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php(70): Slim\Slim::handleErrors(2, ‘require(/var/ww…’, ‘/var/www/vhosts…’, 70, Array) #1 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php(70): require() #2 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php(60): composerRequireShopware(‘8a9dc1de0ca7e01…’, ‘/var/www/vhosts…’) #3 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/autoload.php(7): ComposerAutoloaderInitShopware::getLoader() #4 /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/autoload.php(31): r in  /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php  on line  70

Fatal error : composerRequireShopware(): Failed opening required ‘/var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/…/aws/aws-sdk-php/src/functions.php’ (include_path=’/var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/engine/Library:.:/usr/local/php72/share/php72’) in  /var/www/vhosts/hosting116251.a2f75.netcup.net/httpdocs/shopware/vendor/composer/autoload_real.php  on line  70

Dir scheinen irgendwie Dateien zu fehlen. Lade mal den ganzen vendor Ordner nochmal hoch

Hat nun funktioniert, jedoch darf mach nicht den gesamten Inhalt der “bootstrap.php” löschen sondern nur den unteren Block.

DANKE für die super schnelle Hilfe!