Shopware bringt 500er

Hallo kann mir hier einer weiterhelfen ? Nach der Installtion kommt dieser Fehler, sowohl im Frontend als auch in backend

php Version 5.6.30 mysql 5.7

 

[Mon May 29 15:38:00.122771 2017] [proxy_fcgi:error] [pid 14795] [client 95.90.249.110:59708] AH01071: Got error ‘PHP message: PHP Warning:  PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known in wecktrading.de/httpdocs/engine/Shopware/Components/DependencyInjection/Bridge/Db.php on line 60\nPHP message: PHP Fatal error:  Uncaught exception ‘RuntimeException’ with message ‘Could not connect to database. Message from SQL Server: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known’ in wecktrading.de/httpdocs/engine/Shopware/Components/DependencyInjection/Bridge/Db.php:78\nStack trace:\n#0 wecktrading.de/httpdocs/engine/Shopware/Kernel.php(275): Shopware\Components\DependencyInjection\Bridge\Db::createPDO(Array)\n#1 wecktrading.de/httpdocs/engine/Shopware/Components/HttpCache/AppCache.php(260): Shopware\Kernel->boot()\n#2 wecktrading.de/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)\n#3 wecktrading.de/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(344): Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(Object(Symfony\Component\HttpFoundatio…\n’

die config.php sieht so aus. ist das überhaupt richtig ?

 

 [
        'username' => '%db.user%',
        'password' => '%db.password%',
        'dbname' => '%db.database%',
        'host' => '%db.host%',
        'port' => '%db.port%'
    ]
];

 

Nein, deine config sollte schon die Werte enthalten die man da da erwarten würde aslo

 array ( 'host' => 'localhost', 'port' => '3306', 'username' => ' **', 'password' => '***', 'dbname' => '***', ), );

 

1 Like