Shopware Account im Backend wird nicht angezeigt

edit: 1.) So, nachdem der Shop nun laeuft und die Lizenz eingegeben ist, steht nach dem Login im Backend auf der rechten Seite weiterhin: “Kein Account angelegt” Klicke ich dann auf “Account Oeffnen” komme ich auf meinen bereits angelegten Account. Wie fuege ich diesen nun ins Backend ein? 2.) Nach dem Login ins Forum erhalte ich diese Meldung: :Hallo musicstyle, verknüpfen Sie jetzt Ihre Shopware ID: Sobald ich dieses mache, erhalte ich die Meldung, dass dieses nicht moeglich ist, da bereits ein Konto verknuepft waere?! Meine Shopware ID ist omusicstyleo, wie aendere ich dieses? edit: anbei meine .htaccess Datei. Hier im Forum hatten wohl schon einige das Problem, Frage: was muss geaendert werden? Diesn Eintrag: #RewriteBase /Shopware/ Hatte ich nach Durchsicht des Forums mal kurz in #RewriteBase / ageaendert, leibt aber beim Fehler :cry: Siehe auch: http://www.o-musicstyle-o.com/backend/index
RewriteEngine on

#RewriteBase /Shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews # php_value memory_limit 128M # php_value max_execution_time 18000 # php_flag magic_quotes_gpc off # php_flag session.auto_start off # php_flag suhosin.session.cryptua off # php_flag zend.ze1_compatibility_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php edit: Dieser Beitrag von Sebastian Klöpper hat bereits geholfen: Hallo, ihr habt ein altes Systemcheck-Tool. Es gibt im Wiki ein aktuelles für 3.5.4 Aus dem Grund werden die neuen Dateien aus 3.5.4 nicht mit dem Tool für 3.5.3 erkannt :wink: Parse Error kommt i.d.R. immer, wenn die Systemvoraussetzungen nicht passen. Meistens ist die PHP Version zu alt. Bitte das Tool mal installieren: http://files.shopware.de/download.php?package=check Nun sind noch drei Fehler in der Serverkonfiguration. edit: Ich habe das ganze nun manuel hochgeladen und fuer den Check auch die “check.php” installiert. Anbei die Fehler: 1.) http://www.o-musicstyle-o.com/check.php 2.) http://www.o-musicstyle-o.com/ Schoene Demo, so ganz ohne irgendetwas 3.)http://www.o-musicstyle-o.com/backend/index Internal Server Error (500) Unter (1.) habe ich gesehen, dass unter “Shopware Dateien” viele rote Kreuze stehen. Die Dateien habe ich nun bereits 3x im Binary-Mode (mit Filezilla) hochgeladen. In der Server Konfiguration sind 3 rote Kreuze, die “upload max filesize” wird gruen, wenn ich ioncube und Zend optimizer wieder deinstalliere. Ich bin sehr ratlos, vlt. weiss einer noch etwas? edit: wie muss die .htaccess richtig lauten? Vielen Dank Hallo~~~ :slight_smile: Ich wuerde gerne shopware installieren und habe ueber die install.php auf unserer Seite die Shopware Installation aufgerufen. Es erfolgt die Systemueberpruefung, bei der “magic quotes” und “allow url fopen” jeweils ein rotes Kreuz als Status erhalten. Dasselbe gilt fuer den Zend Optimizer und den ionCube Loader, jedoch habe beide ueber FTP probeweise installiert, dann verschwinden die roten Kreuze. Nun ist auf dem Hauptverzeichnis alles geloescht, nur die install.php ist vorhanden. Nach Eingabe der “Datenbank Einstellungen” muss ich auf der Folgeseite “Weitere Einstellungen” ein Paket, eine Methode und ein Format auswaehlen. Egal welche Einstellungen gewaehlt werden, nachdem auf “Start” geklickt wird, erhalte ich folgendes Fenster fuer vlt. 1 Sek: “Herunterladen der Installationsdateien”, direkt gefolgt von “Installation fehlgeschlagen, Oeffnen der Downloaddatei ist fehlgeschlagen.” Ich habe erst Oxid, dann xt commerce getestet, jedoch sind beide Shops nicht nach unserem Geschmack, Oxid ist zwar vielversprechend, jedoch gibt es keine Moeglichkeit in der CE “Download Artikel” anzubieten, was bei einem Shop, welcher nur Artikel zum Download anbietet leider noetig ist und xt commerce hat keinerlei Einstellungensmoeglichkeiten fuers Template wie bei Oxid (ausser ich erwerbe dieses kostenpflichtig). Ich hoffe, dass ich hier Hilfe erhalte und den Shop installieren kann, eine manuelle Installation durch Filezilla und FTP ist nicht moeglich, da bei 1und1 zwar die Datenbank besteht aber es keine Importmoeglichkeit wie in der Anleitung geschrieben, gibt. Daher wuerde ich gerne das automatische Skript verwenden. Wie kann also diese Fehlermeldung umgangen werden? Evtl. muss noch eine Datei manuell per FTP hochgeladen werden? Ueber Tips bin ich dankbar.

so, ich habe soweit herausgefunden, dass wohl die .htaccess Datei Zugriffsrechte einraeumen muss. Leider habe ich diese Datei nicht, ich weiss zwar, wie ich diese erstelle, aber nicht, was ich dort hineinschreiben muss. Google gibt zwar viele Hilfen, aber ich weiss nicht, was das richtige waere :cry: Ich habe nun die Shopware einfach mal auf meinen Computer geladen und die .htaccess, die dort enthalten war per FTP hochgeladen. Funktioniert leider dennoch nicht, in der .htaccess steht folgendes, was muss hier geaendert werden?:
RewriteEngine on

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule application.yaml engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/1 RewriteRule sitemap.xml(.*) shopware.php?controller=SitemapXml RewriteRule templates/.*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
DirectoryIndex index.php DirectoryIndex shopware.php
Deny from all
Options -Indexes # Options -MultiViews # php_value memory_limit 128M # php_value max_execution_time 18000 # php_flag magic_quotes_gpc off # php_flag session.auto_start off # php_flag suhosin.session.cryptua off # php_flag zend.ze1_compatibility_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php

Moin, ich hab zwar nicht viel Ahnung von der Materie, aber habe mal meine verglichen. Soweit habe ich das Gleiche, nur noch einen Absatz mehr:
ExpiresActive On
ExpiresByType image/gif “access plus 2592000 seconds”
ExpiresByType image/x-icon “access plus 2592000 seconds”
ExpiresByType image/jpeg “access plus 2592000 seconds”
ExpiresByType image/jpg “access plus 2592000 seconds”
ExpiresByType image/png “access plus 2592000 seconds”
ExpiresByType text/css “access plus 2592000 seconds”
ExpiresByType text/js “access plus 2592000 seconds”
ExpiresByType text/javascript “access plus 2592000 seconds”
ExpiresByType application/x-javascript “access plus 2592000 seconds”
Header unset ETag FileETag None Vielleicht hilft das!

Hi, erst nochmal zur Klärung - sind jetzt nun alle roten Kreuze weg oder nicht? [quote]Es erfolgt die Systemueberpruefung, bei der „magic quotes“ und „allow url fopen“ jeweils ein rotes Kreuz als Status erhalten. Dasselbe gilt fuer den Zend Optimizer und den ionCube Loader, jedoch habe beide ueber FTP probeweise installiert, dann verschwinden die roten Kreuze. [/quote] Ich vermute, das es nicht an der .htaccess liegt, evtl. eher an den Permissions der entsprechenden Dateien: [quote]„Herunterladen der Installationsdateien“, direkt gefolgt von „Installation fehlgeschlagen, Oeffnen der Downloaddatei ist fehlgeschlagen.“[/quote] hier vieleicht mal mit Dateirechten von 755 oder 777 probieren. …Leider ist 1&1 nicht der optimalste Hoster für Shopware (was man so liest…). Vielleicht solltest Du hierzu nochmals gezielt googlen (shopware + 1und1 oder ähnlich). Möglich, dass Du so das Problem klären kannst. Auch noch eine Möglichkeit: Hast du bei der Übertragung der Shopware-Dateien den Binärmodus gewählt? Text- oder Automatikmodus können manchmal zu Fehlern führen. Grüße rattatui

Hallo~~ danke Ihr beiden. Ich habe das ganze nun manuel hochgeladen und fuer den Check auch die “check.php” installiert. Anbei die Fehler: 1.) http://www.o-musicstyle-o.com/check.php 2.) http://www.o-musicstyle-o.com/ Schoene Demo, so ganz ohne irgendetwas 3.)http://www.o-musicstyle-o.com/backend/index Internal Server Error (500) Unter (1.) habe ich gesehen, dass unter “Shopware Dateien” viele rote Kreuze stehen. Die Dateien habe ich nun bereits 3x im Binary-Mode (mit Filezilla) hochgeladen. In der Server Konfiguration sind 3 rote Kreuze, die “upload max filesize” wird gruen, wenn ich ioncube und Zend optimizer wieder deinstalliere. Ich bin sehr ratlos, vlt. weiss einer noch etwas?

Hi, habe mir gerade noch http://www.o-musicstyle-o.com/check.php angesehen - sieht doch schon ganz gut aus. Ich weiss nicht ob Du zugriff auf deine php.ini hast - das sollte irgendwo in den FAQs von 1und1 zu finden sein. Dort brauchst Du nur upload_max_filesize=10M magic_quotes=off allow_url_fopen=on einzutragen, dass sollte es gewesen sein… Grüße rattatui

1 Like

[quote=“rattatui”]Hi, habe mir gerade noch http://www.o-musicstyle-o.com/check.php angesehen - sieht doch schon ganz gut aus. Ich weiss nicht ob Du zugriff auf deine php.ini hast - das sollte irgendwo in den FAQs von 1und1 zu finden sein. Dort brauchst Du nur upload_max_filesize=10M magic_quotes=off allow_url_fopen=on einzutragen, dass sollte es gewesen sein… Grüße rattatui[/quote] Hi, vielen Dank. Die php.ini hatte ich bereits selbst erstellt, da ich ioncube und den zent optimizer darueber aktiviert habe. Deine Daten habe ich dort eingetragen, allerding mit folgender Zeile: magic_quotes_gpc=off Nun sind alle Punkte im check.php auf gruen, lediglich das Shop backend weist weiterhin folgenden Fehler auf: http://www.o-musicstyle-o.com/backend/index Error 500 - Internal server error Ein interner Fehler ist aufgetreten! Bitte versuchen Sie es zu einem späteren Zeitpunkt. Da bei 1und1 die php.ini jedoch in JEDEM Unterverzeichnis, in dem PHP Dateien stehen, liegen muss, bin ich momentan am php.ini einfuegen… Ich melde mich dann hier nochmals~~

Ich zitiere mal aus einem anderen Post: [quote=“ottscho”]Mache mal das # vor RewriteBase /shop/ weg und versuch es noch einmal.[/quote] Hat geklappt bin im Backend wunderbar :smiley: Vielen Dank ~~~~