Shopware 6 lokale Installation

@Moritz Naczenski schrieb:

Unter Windows wirst du das so nicht zum laufen bekommen.

Entweder du nutzt eine Linux-Shell in Windows (da gibt es glaube ich mitlerweile möglichkeiten) oder setzt auf eine Linux VM. Das war aber in Shopware 5 zu großen Teilen auch schon so. 

Vielen Dank, na ja, das musste ich voraussehen. Dann Linux-VM.

Hallo zusammen !

ich probiere auch mal mein Glück hier im Forum :slight_smile:

Habe alle requirements erfüllt und es geht schon bei dem Erstellen der Konfigurationsdatei los:

> ./bin/setup

liefert folgenden Fehler: SQLSTATE[HY000] [2002] No such file or directory

zur Sicherheit das Kommando separat aufgerufen und das funktioniert:

> mysql -h 127.0.0.1 -u app -p shopware 

daher bin ich erstmal schon überfragt woran es scheitert. die credentials werden mir ja auch im mysql verlangt und das klappt ja …

Wäre um jeden Tipp sehr dankbar - vielen Dank.

Hast du denn mal die IP statt Localhost eingetragen?

hi Moritz,
ich habe es soeben versucht und erhalte dann einen anderen Fehler:

SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client

Undecided

Welche MySQL Version hast du im Einsatz? Laut Google hängt das mit der MySQL Konfiguration zusammen:

https://www.google.com/search?rlz=1C1GCEU_en&q=the+server+requested+authentication+method+unknown+to+the+client&spell=1&sa=X&ved=0ahUKEwikvqzPt9LiAhVRL1AKHczBBy4QBQgrKAA&biw=1734&bih=1301

Wenn du Mac OS nutzen solltest, gibt’s hier ein Guide: https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/system-installation-guides/mac-os-x

LG Andre

hi Andre,
ich benutze MySQL 8.0.16 auf einem macOs 10.14.5
Ich probiere es dann mit dem MAMP … hoffentlich klappt das :slight_smile:
Danke !

hi,

habe nun alles mit MAMP vorbereitet und die ersten mysql Befehle gingen sauber durch bis auf den hier:

(5/28) Starting
> mysql -u ‘shopware’ -p’XXXXXXXX’ -h ‘localhost’ --port=‘3306’ shopware6dev < vendor/shopware/platform/src/Core/schema.sql
    Warning: Using a password on the command line interface can be insecure.
    ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘JSON                                    NOT NULL,
        author              VARC’ at line 9

Execution aborted, a subcommand failed!

 

woran scheitert es hier? wäre dankbar für eure tipps :wink: danke

PS. der Pfad mit der schema.sql ist korrekt.

Moin @m0nstersnatch‍,

deine MySQL Version ist zu veraltet. :slight_smile:
Du brauchst mindestens MySQL 5.7.21 oder, wenn du MariaDB nutzt, Version 10.3.

Gruß,
Patrick  Shopware

hi Patrick,

danke für die Info. 
Würde evtl. SQLite 3.7.17 (enthalten im XAMPP) ausreichend sein, oder muss es zwingend MySQL sein? Für letzteres müsste ich MAMP Pro kaufen…
Vielen Dank 

hi zusammen,

leider war es mir nicht möglich unter MacOS Mojave (10.14.5 18F132) PHP 7.2+ zum Laufen zu bewegen.

Apache stürzt bei der Initialisierung ab mit der Fehlermeldung:

There are serious issues with it, due to the original apache not loading foreign libraries anymore. PHP within apache will most certainly not work anymore if you proceed!

Ich hatte von einem Kollegen die Info bekommen, es steht ein RC-1 zur Verfügung, konnte diesen allerdings auf der Download Seite nicht finden - hat jemand eine Info dazu?

Danke

Der Shopware 5.6 RC ist gestern erschienen - das hat nix mit Shopware 6 zu tun.

 

@Moritz Naczenski schrieb:

Der Shopware 5.6 RC ist gestern erschienen - das hat nix mit Shopware 6 zu tun.

 

Hi Moritz, danke für die rasche Rückmeldung und Info. 

Gibt es einen geplanten Termin wann der erste RC von Shopware 6 erscheinen wird? Danke.

Einen Termin noch nicht - geplant ist etwa Mitte Juli. Also absehbar.

Mein Fazit nach 3 Tagen am Stück mit Shopware 6.1.5 unter XAMPP, MAMP, WAMP, Vagrant, Docker und Oracle Virtual Box:

Shopware 6 Entwicklung funktioniert in keinster Weise mit Windows 10!

Es gibt in erster Linie immer wieder dieses Problem:

User Notice: Key file „file://C:\wamp64\www\shopware615/config/jwt/public.pem“ permissions are not correct, recommend changing to 600 or 660 instead of 666

 

Ende der Durchsage!

1 Like

ich verwende Windows Subsystem for Linux. bei mittlerweile allen meinen projekten - funktioniert ausgezeichnet
(mit nginx/mariadb/php-fpm )

meine projekte liegen in /mnt/c/projekte/shopware6dev - den ordner kann man in phpstorm öffnen und damit entwickeln.

ich glaube sogar gesehen zu haben dass phpstorm mittlerweile direkte wsl unterstützung hat (noch nicht getestet)

git geht natürlich auch - sowohl innerhalb wsl als auch mit phpstorm oder tortoise

pro-tipps:

  • in nginx muss man fastcgi_buffering off; setzen - sonst gibts tatsächlich ab und an problemchen
    - defender für den WSL app-ordner deaktivieren wg. performance
  • rechte auf www-data für von windows erstellte dateien ausserhalb wsl: diese config innerhalb debian:
    /etc/wsl.conf
    [automount]
    options = „metadata,uid=33,gid=33“
1 Like

Ich habe das alles so eingerichtet. Hat eine Ewigkeit gedauert bis ich mich da “durchgefuchst” hatte! Erst mal auch noch die falsche Mariadb (Version 10.1) installiert. Diese dann auf Version 10.4 upgedated! Zuletzt habe ich dann im PhpStorm im Apache-Root-Verzeichnis die folgenden Befehle ausgeführt:

 

git clone https://github.com/shopware/development.git

cd development

Händisch Ordner “platform” gelöscht

git clone https://github.com/shopware/platform.git

Virtual Host angelegt (nur im Apache innerhalb des WSL nicht in der Windows hosts-Datei)

bin/setup

 

Das lief alles einwandfrei durch aber im Frontend kann ich nur auf localhost zugreifen und sehe nur eine weiße Seite. Der Virtual Host scheint auch nicht zu funktionieren. Datenbank wurde unter Mariadb ebenfalls beim Bin-Setup nicht angelgt. Hast du noch einen Tipp für mich was ich hier falsch gemacht habe?

hm logfiles helfen meist… php-log/apache-log und shopware log in var/log

klingt für mich erstmal nach ner fehlerhaften apache config

evtl rechte problem? alles www-data (normal). mit apache hab ichs noch nicht verwendet - nur nginx (dort reicht dann mehr oder weniger die symfony config bisschen modifiziert). 

hast die dev console in chrome/edge mal angesehen? evtl dort fehler? rewrite modul nicht aktiv?

Das rewrite modul ist laut phpinfo aktiviert. Ich hatte es auch aktiv per " sudo a2enmod rewrite" aktiviert. Das Frontend öffnet immerhin mit Inhalt, jedoch ohne CSS und somit ohne Layout. Für den admin vermute ich aber auch hier irgendwo den Fehler beim URL-Rewrite, weil Shopware direkt nach der Installation nicht auf http://localhost/shopware615/admin sondern auf http://localhost/shopware615/public/admin springt. Dort kommt sogar der Login-Screen, welcher auch zumindest noch die eingegebenen Daten überprüft (es kommt die übliche Fehlermeldung bei falschen Zugangsdaten). Allerdings erscheint anschließend eine weiße Seite mit diesem Inhalt im Quelltext:

        Shopware Administration (c) shopware AG
    
    
            
        
        
        
        
        
        
        
    
    
    













    /*
        root-level domain configuration

        host: shopware.next
        port: 80
        scheme: http
        schemeAndHttpHost: http://shopware.next
        uri: http://shopware.next/admin
        basePath:
        pathInfo: /admin

        -----------------------------------------------

        sub-folder domain configuration

        host: localhost
        port: 80
        scheme: http
        schemeAndHttpHost: http://localhost
        uri: http://localhost/next/web/admin
        basePath: /next/web
        pathInfo: /admin
    */
    Shopware.Application.start({
        apiContext: {
            host: 'localhost',
            port: 80,
            scheme: 'http',
            schemeAndHttpHost: 'http://localhost',
            uri: 'http://localhost/shopware615/public/admin',
            basePath: '/shopware615/public',
            pathInfo: '/admin',
            liveVersionId: '0fa91ce3e96a4bc2be4bd9ce752c3425',
            systemLanguageId: '2fbb5fe2e29a4d70aa5854ce7ce3e20b'
        },
        appContext: {
            features: {"next733":false,"next1797":false,"next3722":false},
            firstRunWizard: true,
            systemCurrencyId: 'b7d2554b0ce847cd82f3ac9bd1c0dfca'
        }
    });

 

dein document-root-ordner ist falsch gesetzt.
bei shopware6 ist (wie bei jeder symfony anwendung) oder “root” ordner /public

sprich:
href="/shopware615/public/bundles/…
sollte in deiner html-ausgabe eigentlich so aussehen:
href="/bundles/…

du kannst shopware6 nicht ohne weiteres in einen unterordner kopieren und aufrufen

am besten du legst dir nen vhost an mit entsprechenden einstellungen.
die url kannst du ja in der windows hosts datei definieren

ach ja: die url muss dann auch in der shopware storefront definiert sein (musst ggf. in der db ändern - könnte evtl auch via konsole gehen - bin grade nicht sicher)

Ich empfehle euch Dockware.io

Das klappt sogar unter Windows.