Seite wird ausgebremst (Request Controller / CSRFtoken)

Hallo zusammen,

ich habe gerade gesehen, dass meine Seite beim Laden durch zwei Punkte drastisch verlangsamt (+2 Sekunden) wird. 

Zunächst durch eine Datei, die den folgenden Link hat: 

https://XXXXX/widgets/index/refreshStatistic?requestPage=/&requestController=index

und

https://XXXXXX/csrftoken

 

Weiß jemand, was es damit auf sich hat? 

Nein, das ist aber nicht das Problem, sondern das First Byte mit über 4 Sekunden:

Wende dich mal an den Provider, oder den Betreiber des Servers.

Wundere Dich aber nicht wenn Du siehst wo der der liegt: 153.92.194.171 - Whois - utrace - IP-Adressen und Domainnamen lokalisieren

 

 

 

Ahso danke für den Hinweis. Ich habe den Provider nun per Ticket kontaktiert. 

Die waren leider bei Shopware als Partner hinterlegt, weswegen ich diese gewählt hatte.

Meinen Speedtest hatte ich über Pingdomtools gemacht gehabt und dort erschien nur das, was ich oben erwähnt habe. 

 

Hallo Kulli,

ich habe nun folgende Nachricht erhalten:

Für Seiten die im HTTP-Cache von Shopware sind erhält man einne TTFB von 130ms.
Dies ist schnell und optimal.

Seiten die nicht Cache sind haben einen TTFB von bis zu 4 Sekunden, das können wir bestätigen.
Dies lässt sich aber leider nicht ändern. Daher ist es erforderlich den Shopware-Cache-Warmer einzurichten und diesen auch immer nach Arbeiten an dem Shop auszuführen:
https://community.shopware.com/Shopware-CLI-Nützliche-Befehle--Tricks_detail_1990.html#HTTP-Cache_aufw.C3.A4rmen

Serverseit stimmt somit alles. Es liegt hier lediglich ein höherer TTFB vor, wenn die Seiten nicht im Cache liegen.

Also den HTTP Cache erwärme ich eigentlich regelmäßig im Backend.

Laut dem Link soll ich das hier als Cronjob ausführen:

 php bin/console sw:warm:http:cache

Ich kenne bis jetzt nur Cronjobs über einen Link.

Muss ich das eventuell unter serverseitigder Cronjob eintragen?

 

Dass man den Cache aufwärmt, wenn man dran gearbeitet hat ist selbstverständlich. Das erklärt nicht den langen First Byte.

Ich würde den Provider nochmal direkt auf den First Byte ansprechen mit Verweis hier auf Forum und die Grafik dazu;

Ist der Shop im Bearbeitungsmodus ? oder Aktiv ?

Ansonsten würde ich raten den Provider zu wechseln.

Darf ich fragen wer das ist und welches Paket gebucht wurde ?

Hallo Kulli,

der Shop ist natürlich im aktiven Modus.

Ich bin derzeit bei Mittwald und habe das Paket Managed Vserver L für 30€ netto im Monat.

Leider habe ich bereits sehr viel investiert ( knapp 500€ ) weswegen ich mir einen erneuten Wechsel nicht leisten kann.

Davor war ich bei Alfahosting und bereue den Wechsel. Mittwald ist leider sauteuer und bietet irgendwie keinen Mehrwert (langsamer Support etc.)

Ich werde erneut auf den ersten Byte hinweisen und auch den Thread hier verlinken.