Robots: noindex ????

Habe meine Seite bei http://www.seorch.de durchlaufen lassen. Im Ergebnis steht das folgende Seiten bei mir auf Robots: noindex stehen??? Also account,note… ist mir ja noch klar aber z.B. …deko-und-zubehoer-fuer-kindergeburtstag/ sollte schon indexiert werden. Mache ich was falsch? Ich verzweifel noch mit Shopware!!! http://www.muster.de/account http://www.muster.de/note http://www.muster.de/checkout/cart http://www.muster.de/verleihkisten/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/alles-fuer-prinzessinnen/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/alles-fuer-prinzessinnen/tisch-und-wand-deko/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/alles-fuer-piraten/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/alles-fuer-ritter/ Eine weitere Meldung lautet: Canonical Tag zeigt auf andere URL http://www.muster.de/ http://www.muster.de/account http://www.muster.de/note http://www.muster.de/shopware.php/ http://www.muster.de/shopware.php/kontaktformular http://www.muster.de/checkout/cart http://www.muster.de/kontaktformular http://www.muster.de/verleihkisten/verleihkiste-piratenparty/ http://www.muster.de/verleihkisten/verleihkiste-ritterparty/ http://www.muster.de/verleihkisten/verleihkiste-prinzessin-party/ http://www.muster.de/deko-und-zubehoer-fuer-kindergeburtstag/sonstige/ Hat jemand ein ähnliches Problem? LG. Melanie

Hallo Melanie, die robots.txt wird von Shopware wie alle anderen Seiten über eine Smarty-Template-Datei erzeugt. Diese sollte so aussehen: /templates/_default/frontend/robots_txt/index.tpl User-agent: \* Disallow: {url controller=compare fullPath=false} Disallow: {url controller=checkout fullPath=false} Disallow: {url controller=register fullPath=false} Disallow: {url controller=account fullPath=false} Disallow: {url controller=note fullPath=false} Sitemap: {url controller=index}sitemap.xml Um das von dir beschriebene Ergebnis zu erhalten, muss diese irgendwie verändert worden sein - durch ein Plugin, eigene Template-Dateien. Am besten du schaust nach, ob Du in einem Ordner /frontend/robrots_txt/index.tpl eine davon abweichende Version findest. Das Canonical-Problem ist uns noch nie aufgefallen. Allerdings habe ich schon Kundeninstallationen gesehen, in denen ein buntes Kuddelmuddel aufgetreten ist. Ursache waren immer Plugins. Deinstalliere alle Plugins, die am SEO-Router Änderungen vornehmen und teste dann die Seite in den Webmaster-Tools erneut. Wenn der SEO-Index von Shopware getestet werden soll, muss er vorab neu aufgebaut werden. Viele Grüße H. Thomas

Hallo, was mir auf jeden Fall schon einmal auffällt ist, dass du shopware.php in der URL hast. Ich meine das wird seit 4.0.7/4.0.8 bereits standardmäßig abgefangen und SEO freundlich umgeleitet. Das würde bei dir also darauf hindeuten, dass noch ein ältere Version im Einsatz (< 4.1). Da wäre im ersten Schritt ein Update zu empfehlen. Solltest du dann noch einen Effekt mit noindex bei dieser Art URL haben (deko-und-zubehoer-fuer-kindergeburtstag/) so müsste man dann noch einmal genauer analysieren. Sebastian

Hallo, vielen Dank für die Antworten! Das „Kuddelmuddel“ wird irgendwie immer mehr! Vorab sei gesagt, ich habe aktuell Version 4.1.4. Anscheinend stimmt aber bei mir etwas nicht, da ich z.B. unter SEO/Router/Einstellungen den Punkt „Shopware-Kernel aus URL entfernen“ nicht habe. Ich habe auch schon einmal mit Patrick Schücker email kontakt gehabt, der meinte er müsse sich das mal anschauen. Inhalt meiner index.tlp User-agent: * Disallow: {url controller=compare fullPath=false} Disallow: {url controller=checkout fullPath=false} Disallow: {url controller=register fullPath=false} Disallow: {url controller=account fullPath=false} Disallow: {url controller=note fullPath=false} Sitemap: {url controller=index}sitemap.xml

Was wird denn im Browser angezeigt, wenn Du die robots.txt manuell aufrufst? www.domain.de/robots.txt Wenn wirklich Menüpunkte im Backend fehlen, müsste sich tatsächlich jemand das System anschauen.

[quote=„hth“]Was wird denn im Browser angezeigt, wenn Du die robots.txt manuell aufrufst? http://www.domain.de/robots.txt Korrekt, oder? User-agent: * Disallow: /compare Disallow: /checkout Disallow: /register Disallow: /account Disallow: /note Sitemap: http://www.partyleihkiste.de/sitemap.xml

[quote=“memie100”][quote=“hth”]Was wird denn im Browser angezeigt, wenn Du die robots.txt manuell aufrufst? http://www.domain.de/robots.txt Korrekt, oder? User-agent: * Disallow: /compare Disallow: /checkout Disallow: /register Disallow: /account Disallow: /note Sitemap: http://www.partyleihkiste.de/sitemap.xml[/quote][/quote] Ja, das ist in Ordnung. Der Fehler liegt also nicht in der robots.txt und deine Aussage, dass die Kategorien durch die robots.txt geblockt werden, kann nicht stimmen. Vielleicht sind die Angaben des SEO-Tools falsch interpretiert oder faktisch falsch. Da Du deine URL immer noch geheim hälst, kann man natürlich auch keinen schnellen Blick auf eine der angeblich geblockten Seiten werfen. Ich rate eigentlich auch dazu, die FRage, ob etwas indexiert wird oder nicht, ob die robots.txt funktioniert und ob ein Link von Ihr geblockt wird, mit den Google-Webmaster-Tools zu untersuchen. Dort bekommst Du alle notwendigen Informationen, die ganze automatische SEO-Checkerei ist nicht notwendig.

[quote=„hth“][quote=„memie100“][quote=„hth“]Was wird denn im Browser angezeigt, wenn Du die robots.txt manuell aufrufst? http://www.domain.de/robots.txt Korrekt, oder? User-agent: * Disallow: /compare Disallow: /checkout Disallow: /register Disallow: /account Disallow: /note Sitemap: http://www.partyleihkiste.de/sitemap.xml[/quote][/quote] Ja, das ist in Ordnung. Der Fehler liegt also nicht in der robots.txt und deine Aussage, dass die Kategorien durch die robots.txt geblockt werden, kann nicht stimmen. Vielleicht sind die Angaben des SEO-Tools falsch interpretiert oder faktisch falsch. Da Du deine URL immer noch geheim hälst, kann man natürlich auch keinen schnellen Blick auf eine der angeblich geblockten Seiten werfen. www.partyleihkiste.de Ich rate eigentlich auch dazu, die FRage, ob etwas indexiert wird oder nicht, ob die robots.txt funktioniert und ob ein Link von Ihr geblockt wird, mit den Google-Webmaster-Tools zu untersuchen. Dort bekommst Du alle notwendigen Informationen, die ganze automatische SEO-Checkerei ist nicht notwendig.[/quote] Laut WMT werden aktuell 108 Seiten „Von Robots blockiert“ Wenn ich z.B. die Seite: http://www.partyleihkiste.de/deko-und-zubehoer-fuer-kindergeburtstag/alles-fuer-ritter/ aufrufe, und den Quelltext ansehe steht dann auch

Hi, ich habe mir deinen Shop ja vor zwei Wochen mal angesehen. Beim Update auf 4.1.4 sind einige Datein nicht richtig eingespielt worden. Das ist Wuchses Problem warum du trotz 4.1.4 immer noch nicht die shopware.php entfernen kannst. Du solltest also als erstes dieses Problem lösen. Dann sind andere Probleme vlt. auch schon gelöst.

Ja werde ich versuchen! Dankeschön LG. Melanie

Hallo, 1. Angeblich falsche Canonical-Links: http://www.partyleihkiste.de/verleihkis … atenparty/ Der Link wird vom SEO-Router (Shopware) korreht per 301-redirect auf den aktuell gültigen Link http://www.partyleihkiste.de/verleihkiste-piratenparty geleitet. Dort steht auch der korrekte Canonical-Link (http://www.partyleihkiste.de/verleihkiste-piratenparty). Wenn man bei http://www.partyleihkiste.de/verleihkis … atenparty/ das letzte / entfernt, landet man auf der Startseite und im HIntergrund wird ein 404-Error ausgegeben. Dann weiß auch jede Suchmaschine, dass der Link nicht mehr existiert. Hier funktioniert eigentlich alles wie erwartet. Keine Ahnung, warum der Fehler bei dem SEO-Tool angezeigt wird. 2. metag-Tag noindex Die kann man für Kategorien im SEO-Rouer von Shopware setzen: SEO Nofollow Viewports. Steht dies drin, sollte eigentlich auch bei den Kategorien “Index” stehen: login,ticket,tellafriend,note,support,basket,admin,registerFC,newsletter,search,search,account,checkout,register, Ansonsten solltes man natürlich wirklich alle Dateien des Updates aufspielen und als erstes Fehler korrigieren.

Hallo, entferne das listing am Ende, wie in dem Beispiel angegeben.

1 Like

Wegen diesem Shopware.php Problem bzw. dem Kuriosen Update werde ich noch einmal Patrcik Schücker fragen ob er sich das mal anschaut! Danke allen erstmal für die rege Konversation!