Produktseite kann nicht mehr geöffnet werden

Hallo zusammen,

ich habe gestern zum testen einen Rabatt Code erstellt, welcher als nicht funktionsfähig ausgespuckt wurde. Im Anschluss daran konnte ich die Produktseite nicht mehr öffnen, für welche ich den Rabatt Code erstellt hatte. Nun habe ich mir gedacht, dass es eventuell an einem Plugin liegen könnte oder was auch immer und habe sämtlich Plugins erst einmal deaktiviert. Des Weiteren habe ich auch das Theme (Kara-Theme) zusätzlich deaktiviert um herauszufinden, ob es daran liegen könnte, was es nicht tut!

Nun habe ich in der log diesen Fehler hier gefunden:

log Datei

[2022-04-14T13:57:53.336882+00:00] php.CRITICAL: Uncaught Error: Argument 1 passed to Shopware\Core\Content\Media\Cms\Type\ImageSliderTypeDataResolver::sortItemsByPosition() must be an instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaCollection, instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaEntity given, called in /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php on line 72 {„exception“:"[object] (TypeError(code: 0): Argument 1 passed to Shopware\Core\Content\Media\Cms\Type\ImageSliderTypeDataResolver::sortItemsByPosition() must be an instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaCollection, instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaEntity given, called in /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php on line 72 at /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php:82)"}
[2022-04-14T13:57:53.338113+00:00] request.CRITICAL: Uncaught PHP Exception TypeError: „Argument 1 passed to Shopware\Core\Content\Media\Cms\Type\ImageSliderTypeDataResolver::sortItemsByPosition() must be an instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaCollection, instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaEntity given, called in /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php on line 72“ at /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php line 82 {„exception“:"[object] (TypeError(code: 0): Argument 1 passed to Shopware\Core\Content\Media\Cms\Type\ImageSliderTypeDataResolver::sortItemsByPosition() must be an instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaCollection, instance of Shopware\Core\Content\Product\Aggregate\ProductMedia\ProductMediaEntity given, called in /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php on line 72 at /home/users/vanade/www/vendor/shopware/core/Content/Media/Cms/Type/ImageSliderTypeDataResolver.php:82)"}

In den jeweiligen Dateien sind zwar die Aussagen vorhanden, aber ich kann damit jedoch nicht so wirklich was anfangen und Tante Google hat mir leider auch nicht helfen können.
Wäre nett, wenn sich jemand das einmal anschaut und mir den Weg zeigt, warum das ganze nicht klappt.

Danke und Gruß
Flo

Der Fehler sagt aus, dass der ImageSlider falsche Daten erhält. Wieso der jetzt fehl schlägt, kann ich dir nicht sagen. Eventuell ein zugeordnetes Bild gelöscht?

Hat jedenfalls nichts mit deinem Rabattcode zu tun.