Produktexporte: Es sollen keien Varianten exportiert werden, auch KEINE Hauptvariante

Hallo,

wir haben folgendes Problem. Bei einem Export Feed möchten wir sämtliche Varianten ausschließen. Die Option “Varianten exportieren” = “Nein” bewirkt offensichtlich nur, dass keine "Unter"varianten exportiert werden.
Die Hauptvariante (oder der Elternartikel oder wie auch immer man es nennt) wird trotzdem im Feed mit ausgegeben.

Beispiel:

Artikelüberschrift: Hose in blau, grau oder grün
Hauptvariante: blau
Untervarianten grau und grün

Im Feed wird die Hauptvariante mit der Artikelüberschrift “Hose in blau, grau oder grün” mit ausgegeben. Die Untervarianten nicht (sollen ja auch nicht).

Wie kann ich es unterbinden, dass auch die Hauptvarianten NICHT mit exportiert werden? Stehe gerade echt auf dem Schlauch.

Danke für Eure Tipps :slight_smile:

Peter

Hallo heizman24,

das wird nicht so einfach möglich sein, da Shopware Artikel ohne Varianten und die Hauptvariante gleich behandelt. 

Du könntest evtl. eine Abfrage machen, ob ein Artikel Varianten besitzt und dann evtl. keine Ausgabe machen.

Viele Grüße

Hi,

du kannst prinzipiell alle Konfigurator-Artikel ausschließen, indem du bspw. unter “Weitere Filter” unter “Eigene Filter” das hier einträgst:

a.configurator_set_id IS NULL

Musst du aber eben testen, ob das zum gewünschten Ergebnis führt - damit sollten eigentlich alle Artikel ausgeschlossen werden, die irgendwie Varianten-Artikel sind oder haben.

Besten Gruß

Daniel 

Hallo und Danke!

Das mit dem Filter und

a.configurator_set_id IS NULL

scheint zu funktionieren. Dafür ersteinmal herzlichen Dank.

Nun haben wir natürlich gleich ein weiteres Problem, das ich mal versuche zu schildern:

Der Feed enthält jetzt knapp 500 Artikel weniger, aber keinerlei Variantenartikel mehr. So weit, so gut.

Wir nutzen seit einiger Zeit den idealo Direktkauf für bestimmte Artikel (nur versandkostenfreie Artikel). Das oben beschriebene Thema war bis zur Nutzung des idealo Direktkaufs kein Problem, da die Kunden ja immer in den Shop geleitet wurden. Mit dem Direktkauf ist es natürlich insofern doof, wenn da etwas mit „Produkt x in rot oder grün“ steht, der Kunde aber eigentlich immer nur die Hauptvariante bestellen konnte.

Das haben wir ja jetzt erst einmal bereinigt, indem wir keinerlei Varianten mehr ausgeben.

Kann man nun den Filter wieder entfernen und stattdessen mit einer IF Abfrage es so gestalten, dass die idealo Direktkauf-Artikel keine Variantenartikel mehr enthalten?

In dem Feed werden idealo Direktkaufartikel mit einem seperaten Feld als solche markiert: checkoutApproved (true | false).
Unsere Abfrage sieht im moment für iedalo Direktkaufartikel wie folgt aus:

{if ($sArticle.attr12 == "true" OR $sArticle.attr12 == "1") AND ($sArticle.shippingfree == "1")}true{else}false{/if}{#S#}

Dabei ist attr12 noch eine extra Checkbox, die wir auswerten. Wenn ich nun aber noch a.configurator_set_id mit abfragen möchte, dann bekomme ich einen Syntaxfehler.

{if ($sArticle.attr12 == "true" OR $sArticle.attr12 == "1") AND ($sArticle.shippingfree == "1") AND (a.configurator_set_id IS NULL)}true{else}false{/if}{#S#}

Was mache ich hier falsch? Das elegante an dieser Lösung wäre, dass ich weiterhin die (Haupt)varianten zu idealo exportieren, aber für den idealo Direktkauf ausschließen könnte.

Vielen Dank und LG,
Peter

 

Hi,

an dieser Stelle benötigst du ja Smarty-Syntax. Entsprechend muss es statt “a.configurator_set_id IS NULL” eher “empty($sArticle.configurator_set_id)” heißen. Das könntest du einmal ausprobieren. Ich weiß allerdings nicht, ob die Variable in Smarty auch verfügbar ist - kann ich gerade nicht prüfen. Auch das

Besten Gruß

Daniel

Hallo Daniel,

vielen Dank für Deine Bemühungen, leider funktionert  empty($sArticle.configurator_set_id) nicht. Vermutlich steht die Variable tatsächlich nicht zur Verfügung.

Schade, vielleicht hast Du ja noch eine andere zündende Idee. :slight_smile:

Beste Grüße,
Peter