Plugin

Hallo Community ich habe 15 Euro bezahlt für das Plugin Zahlungsanbieter. Leider wird einem nicht beschrieben wie dieses manuell zu installieren ist. Alle Plugins bisher funktionierten über den selben weg und es gab nie Probleme bis jetzt. Der Ordner von diesem Plugin ist wie folgt aufgebaut: Zahlungsanbieter/ dann ein zusatz Ordner(templates)und die Datei Bootstrap/Im Ordner templates ein Unterodrner frontend/ dann wieder ein unter Ordner namens plugins / dann ein Ordenr wieder mit dem name Zahlungsanbieter / und dort ist eine index.tpl Datei Kann es sein das man die inex.tpl datei noch wo anderst einbauen muss oder hat jemand das template schon mal manuell installiert ? Wäre super wenn Ihr mir helfen könnt. Danke liebe Grüße Patrick

hi hier in forum gibt es schon viele information wie man ein plugin manuell installiert. lg manuel

Hallo, also die Ordner- /Dateistruktur von Dir kann ich nicht nachvollziehen. Wäre besser gewesen wie z.B.: /engine/Shopware/Plugins/Community/Frontend/Zahlungsanbieter/templates/frontend/plugins/zahlungsanbieter/index.tpl …usw. Es muss ja auch kein Installationsfehler vorliegen - die index.tpl muss man auch nicht woanders einbauen et.ctr. Das das Plugin ja auf den Shopseiten angezeigt wird, könnte auch eine früher erfolgte Veränderung im Template-Design jetzt das Prob verursachen. Obwohl du leider nichts davon schreibst, gehe ich mal davon aus: das Plugin ist im Backend richtig installiert und aktiv geschaltet, oder wie? Falls dies der Fall ist, Versuch mal: - mindestens einen Zahlungsanbieter im Backend einzubinden - anstelle Deinem Template ein standard Template kurz zum Testen zu laden - ALLE im Plugin angebotenen Positionen zu testen, und dabei jeweils immer wieder Shop-Caches und den Browser-Cache löschen.

@rattatui Also ich habe das Plugin manuell installiert so wie ich bisher auch alle installiert habe und dann im backend aktiviert habe. Nur bei diesem Plugin welches ich auch normal installiert habe wird leider nichts im backend angezeigt um dieses zu aktivieren, was ich nicht nachvollziehen kann. @Minalo super hilfe wusste ich noch garnicht ;D

hm… :frowning: ich weiss garnicht mehr auf welche weise ich das Plugin installiert habe (habe die 1.1.)… Das einzige was mir jetzt einfällt ist wenn wir die Pfade/Dateien vergleichen… Du hast ja offenbar schon so einiges installiert - Rechtefehler wie kein 777 oder keine binäre übertragung der Dateien können wir also ausschließen nehme ich an?

Also ich lade die Plugins immer im Binären modus hoch an den rechten allerdings musste und habe ich auch noch nie was geändert. Vielleicht muss man die rechte bei diesem Plugin ja ändern ? Wenn ja wäre es nett wenn du mir grade sagen kannst wo ich das mache in nutze WinSCP. Oder liegt es einfach an der Version 1.2 ? Das diese nicht kompatibel ist mit der 3.5.4 Version Danke lg Patrick

Hi, ich meinte nur der Vollständigkeit halber die Rechte des Plugin-Verzeichnisses für Community Plugins soll ja 777 haben… hast Du bestimmt schon, wenn du andere Community Plugins bereits am laufen hast oder? …die weiteren Unterordner von Community-Verzeichnis(777) haben bei mir 750 und die index.tpl des Plugins z.B. 740 -aber ob’s daran liegt?!? Kannst ja mal probieren… Grüße rattatui

[quote]Oder liegt es einfach an der Version 1.2 ? Das diese nicht kompatibel ist mit der 3.5.4 Version [/quote] …ich habe 3.5.5 und die 1.1 Version des Plugins - das können wir dann wohl schon mal ausschließen :wink:

1 Like

Ok und könnte es was mit den rechten zu tun haben ? Wahrscheinlich auch nicht oder ? Dann können wir nun wie du schon sagtest mal die Pfade vergleichen wäre super nett wenn du mir deinen gerade mal posten könntest dann schau ich bei mir mal nach. Falls es mit den rechten zusammen hängen könnte müsstest du mir eine kurze instruktion geben wo ich dies bei WINSCP ändern kann. Vorab erstmal ein riesen dankeschön fürs helfen. Lg PAtrick

Es hat geklappt danke nochmals ;D

[quote=„junak“]Es hat geklappt danke nochmals ;D[/quote] Hi, sorry ich hatte gestern keine Zeit - freut mich das es nun funktioniert. Was war es denn? Grüße rattaui