Plugin Manager in Verbindung PHP Version 5.4

Hallo,

ich muss das Thema noch mal hochholen.

Bisher war es so, dass der Plugin Manager mit der  PHP Version 5.4 immer funktioniert hat. 5.6 funktionierte nicht und es kam eine Fehlermeldung.
Nun hab ich auf Version 5.2.3 upgedatet und muss die 5.6 nutzen und stehe nun wieder vor dem Problem mit dem Plugin Manager.
Alle anderen Funktionen arbeiten nach dem Update problemlos.

Hat jemand noch eine Idee?
Im Errorlog auf dem Server wird nichts geschrieben.
Aber vielleicht mache ich hier auch einen Fehler? Das Log hab ich in der htaccess wie folgt aktiviert:

addhandler php56-cgi .php

php_flag log_errors on
php_value error_log „/www/htdocs/w011ae55/errorlogs/log.txt“

Komme hier leider nicht weiter…

Gruß & Dank
Dirk

Sind alle deine installierten Plug-Ins für die verwendete Shopware Version freigegeben?

Ich denke du setzt durch eine neuere PHP-Version auch eine neuere Version des Ioncube-Loaders ein, hast aber noch alte Plugins die damit nicht kompatibel sind. Also würde ich als erstes empfehlen, einmal die Plugins nach und nach zu überprüfen. Das kannst du bspw. indem du dir eine Kopie des Shops aufsetzt und schrittweise alle Plugins löschst, bis der Plugin-Manager wieder aufgeht.

Kann der Plugin-Manager auch per URL direkt aufgerufen werden?

Z.B.: www.meine-domain.de/pluginmanager

Gruß

Olaf

Hallo,

nein, direkt kann ich den Pluginmanager nicht aufrufen. Sollte das funktionieren?

Ansonsten werde ich das mit der Testumgebung wohl tun. Reicht es wenn ich dort einfach nach und nach die Plugins aus /engine/shopware/Plugins lösche oder muss noch mehr getan werden?

Viele Grüße
Dirk

 

Das reicht wenn du die schrittweise da rauslöschst

1 Like

Danke, erstes Plugin (Vorschaubilder neu generieren) war auch gleich das Problem.