Plugin lässt sich nicht installieren - 503 Service Unavailable [GELÖST: falsche PHP-Version]

Hallo zusammen,

mir sind nun leider die Ansätze ausgegangen. Ich versuche das Plugin “SwagDefaultSort” zu installieren. Den Ordner mit dem Plugin habe ich unter /engine/Shopware/Plugins/Community/Plugins/ hochgeladen und im Plugin Manager wird das Plugin auch angezeigt. Ein Klick auf das Installieren-Icon lässt die Installation kurz rödeln und bricht dann ab. Firebug liefert mir folgende Fehlermeldung:

Fatal error: Uncaught TypeError: Argument 1 passed to Shopware\Models\Menu\Repository::findOneBy() must be of the type array, string given, called in /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Plugins/Community/Frontend/SwagDefaultSort/Bootstrap.php on line 116 and defined in /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Models/Menu/Repository.php:52
Stack trace:
#0 /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Plugins/Community/Frontend/SwagDefaultSort/Bootstrap.php(116): Shopware\Models\Menu\Repository->findOneBy('label', 'Einstellungen')
#1 /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Components/Plugin/Namespace.php(354): Shopware_Plugins_Frontend_SwagDefaultSort_Bootstrap->install()
#2 /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Bundle/PluginInstallerBundle/Service/InstallerService.php(131): Shopware_Components_Plugin_Namespace->installPlugin(Object(Shopware_Plugins_Frontend_SwagDefaultSort_Bootstrap))
#3 /var/www/vhosts/rheingrafenberg.de/sho in /var/www/vhosts/rheingrafenberg.de/shopware/engine/Shopware/Models/Menu/Repository.php on line 52
503 Service Unavailable

Folgendes habe ich bisher probiert, nichts hat geholfen:

  • CHMOD rekursiv 777 für den ganzen Plugin-Ordner
  • Alle Caches mehrfach gelöscht
  • Im Ordner /var/cache/prod_xxx/doctrine/attributes nach “.php” geschaut, nichts gefunden (unsichtbare Dateien sind selbstverständlich eingeblendet)
  • Vendor-Ordner gelöscht und neu hochgeladen aus frisch geladner Install-Zip
    - Composer-Befehle manuell ausgeführt (composer install && composer dump-autoload -o)
  • Update von 5.1.3. auf 5.1.4

Ich bin mit meinem Latein am Ende und weiß nicht, was ich noch probieren kann um das Plugin zu installieren. Hat von euch noch jemand eine Idee, was ich noch versuchen kann?

Meinst du das Plugin? > GitHub - shopwareLabs/SwagDefaultSort

Wenn ja steht da

Working with Shopware version 5.0.0 to 5.1.1. Higher versions may work either but were not tested.

Und du hast 5.1.4 oder nicht.  Wearing-Sunglasses 

Laut diesem Beitrag > http://forum.shopware.com/discussion/comment/156498/#Comment_156498 haben die User Newb und derkosta das Plugin auf 5.1.3 bzw. 5.1.4 laufen. Das liegt bei mir m.E. nicht am Plugin sondern an der generellen Installation von Plugins.

Hast du dich hier verschrieben?

/engine/Shopware/Plugins/Community/Plugins/

den Ordner gibt es doch nicht.

Hast du das auch beachtet? > http://forum.shopware.com/discussion/comment/156498/#Comment_156498 

Warum machst du denn ein neues Thema auf, wäre es dort nicht besser aufgehoben.

Uwe

Ja, sorry, habe mich verschrieben. Ist natürlich im Ordner /engine/Shopware/Plugins/Community/Frontend/ abgelegt.

Mir geht es hier primär nicht um das Plugin SwagDefaultSort sondern generell um den Fehler 503 Service Unavailable. Das hat mit dem Plugin m.E. nichts zu tun. Irgendwo anders muss es hier klemmen…

Das Plugin SofortPayment lässt sich übrigens auch nicht installieren. Fehlermeldung hier ist analog zum SwagDefaultSort Plugin. Wo klemmt es hier?

“NetworkError: 503 Service Unavailable - http://shopware.xxxxxx/backend/PluginInstaller/installPlugin

Problem ist gelöst!

Meine Shopware-Instalnz lief auf PHP-Version 7.0.4. Scheinbar ist da auch noch der Session-Bug am Werk, der in den Systemanforderungen in Verbindung mit PHP-Version 5.6.0-5.6.3 genannt wird. Ist aber nur eine Vermutung.

Jetzt läuft mein Shopware 5.1.4 auf PHP 5.5.9 und beide Plugins (SwagDefaultSort und SofortPayment) lassen sich ohne Probleme installieren und aktivieren.